Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

20.08.2011, 13:07

DNS - Auflösung tut nicht mehr, keine Route ins Netz

Liebes Forum,

ich betreibe meine NSLU unter V2.3R63-uNSLUng-6.10-beta . Gestern wollte ich per ipkg update/upgrade mein System auf den neusten Stand bringen und merkte, daß er die URLs nicht auflösen konnte. Ein einfacher Ping auf IP-Adressen jedoch geht durch wie Butter. Habe gestern ca. 3 Std. versucht den Fehler zu finden; arbeite aber zu selten mit Linux, daß mir das debugging nicht leicht fällt. Vielleicht seht Ihr was, was ich übersehen habe.

Hier mein Setup:

- 2 Router kaskadierend;
- Router1 ist über ein Kabelmodem mit dem Internet verbunden
- Router2 bezieht von Router 1 per DHCP seine Adresse
- An Router 2 hängt die NSLU, die eine fixe IP (192.168.2.77) im Subnetz des Routers 2 besitzt.

[img]https://dl-web.dropbox.com/get/Public/nslu%20setup.JPG?w=20e7152a[/img]
Hier die notwendigen Setup-Files:

cat /etc/resolv.conf
nameserver 192.168.2.100
nameserver 80.69.100.12
nameserver 193.174.75.154

=====
ping auf 80.69.100.12 geht wie gesagt durch

=====

ifconfig:

ixp0 Link encap:Ethernet HWaddr 00:1A:70:A0:BA:68
inet addr:192.168.2.77 Bcast:192.168.2.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9931 errors:0 dropped:0 overruns:0 frame:0
TX packets:13444 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:256
RX bytes:1181384 (1.1 MiB) TX bytes:3323416 (3.1 MiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:86 errors:0 dropped:0 overruns:0 frame:0
TX packets:86 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:9617 (9.3 KiB) TX bytes:9617 (9.3 KiB)

route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 ixp0
127.0.0.0 0.0.0.0 255.255.255.0 U 0 0 0 lo
239.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 ixp0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.2.100 0.0.0.0 UG 1 0 0 ixp0

Achso: Wichtig ist, daß alle Rechner, die per DHCP - IP Zuweisung an Router 2 hängen, ohne Probleme ins Internet kommen.

Vielen Dank für Eure Tipps/Hilfe/Hinweise etc.

Tano

Anzeigen

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

2

20.08.2011, 15:36

Moin,

leider geht aus Deinen Ausführungen nicht hervor, ob Du auch URLs versucht hast. Wenn nein, heute schon probiert ipkg.nslu2-linux.org zu erreichen?

Ist zufällig NSLookup auf der NSLU2 installiert?

Wenn ja, aknnst Du mal sowas versuchen...

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
root@Linus:~# nslookup
> ipkg.nslu2-linux.org
Server:         192.168.10.100
Address:        192.168.10.100#53

Non-authoritative answer:
ipkg.nslu2-linux.org    canonical name = milla.nas-admin.org.
Name:   milla.nas-admin.org
Address: 140.211.169.161
> server 208.67.222.222
Default server: 208.67.222.222
Address: 208.67.222.222#53
> ipkg.nslu2-linux.org
Server:         208.67.222.222
Address:        208.67.222.222#53

Non-authoritative answer:
ipkg.nslu2-linux.org    canonical name = milla.nas-admin.org.
Name:   milla.nas-admin.org
Address: 140.211.169.161
>


192.168.10.100 ist mein Router, 208.67.222.222 ein Nameserver von OpenDNS.Org

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Anzeigen

3

20.08.2011, 23:39

Hi Caplink,

danke für Deine Antwort.

Leider versuchte ich das bereits, habe nur vergessen das zu dokumentieren.
Keine URL geht, auch nicht die von Dir vorgeschlagene....
nslookup habe ich leider nicht installiert...

>nslookup
bash: nslookup: command not found

ping 208.67.222.222
PING 208.67.222.222 (208.67.222.222): 56 data bytes
64 bytes from 208.67.222.222: icmp_seq=0 ttl=54 time=40.6 ms
64 bytes from 208.67.222.222: icmp_seq=1 ttl=54 time=32.4 ms

NSLOOKUP installiere ich aber sobald die die Namensauflösung wieder tut - oder gibt es einen Weg wie das zu installieren ist OHNE DNS?

Weitere Tipps?

Danke & Grüße
Tano

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

4

21.08.2011, 11:47

Moin,

Ich kann Dir leider nicht sagen, in welchem Paket nslookup oder auch dig enthalten sind, die Paketsuchmschine auf NSLU2-Linux.Org macht auch nicht mehr das, was sie früher gemacht hat....

Pakete kannst Du installieren, indem Du sie von http://ipkg.nslu2-linux.org/feeds/optwar…2/cross/stable/ herunter lädst, in ein beliebiges Verzeichnis auf der NSLU packst, in dieses Verzeichnis wechselst, und mittels ipkg install Paket (ohne Endung) installierst (aus dem Gedächnis, bin alt und hab schon lang keine NSLU mehr am Start).

bye
JrB
"Supporting joe users worldwide" <- that's our motto


5

21.08.2011, 13:13

Hi Caplink,

danke Dir! Habe den "Fehler" gefunden: in der /etc/resolf.conf fehlte der Eintrag des Routers 1

Quellcode

1
nameserver 192.168.1.1


Ich verstehe nicht warum es nun daran hing, denn die anderen Einträge

Quellcode

1
2
3
4
5
/etc/resolv.conf
nameserver 192.168.1.1
nameserver 80.69.100.174
nameserver 80.69.100.12
nameserver 193.174.75.154


sind auch vollwertige DNS Server, aber nun tut die Namensauflösung auf jeden Fall....

Danke Dir nochmal!

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

6

21.08.2011, 19:04

Moin,

als Vermutung, Router 1 mag Anfragen auf Port 53 nicht weiterreichen (jedenfalls nicht solange er nicht der Forwarder ist).

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Verwendete Tags

DNS, Namensauflösung

Social Bookmarks