Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Hock

Anfänger

  • »Hock« ist der Autor dieses Themas

Beiträge: 7

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: originale Firmware 2.3r29

  • Nachricht senden

1

18.11.2009, 16:55

kein Browserzugriff

Moin zusammen,
nachdem ich nun alles mögliche zu Selbsthilfe versucht habe, bleibt mir jetzt nur noch der Weg euch um Hilfe zu bitten.
Ich habe meine NSLU2 zwar schon einige Jahre in Betrieb. Allerdings brauchte ich sie bisher nur zur Aufzeichnung von TV Sendungen bei der die Original Firmware ausreichte. Nun wollte ich mit einigem Leuten über FTP ein paar Dateien tauschen. Dieses nahm ich zum Anlass der NSLU2 ein neues Betriebssystem zu verpassen, in diesem Fall "Unslung-6.10-beta ".
Anfangs schien noch alles in Ordnung zu sein. Ich konnte auf die Box zugreifen. Das gewohnte Bild im Browser erschien mit dem Zusatz Unslung-6.10-beta. Ich dachte schon ich hätte alles geschafft und wollte nun erst einmal eine Festplatte formatieren was mir allerdings nicht gelang. Nach einem Neustart der NSLU2 konnte ich dann auf einmal nicht mehr mit dem Browser auf die Box zugreifen. Nach wie vor lässt sich die NSLU2 mit FTP ansprechen und auslesen. Das schlimme ist, da ich mir so sicher war das alles in Ordnung ist, hatte ich den Telnet Zugriff noch nicht aktiviert.
Im Moment wäre ich schon froh, wenn ich die alte Original Firmware wieder aufspielen könnte. Meine Linux Kenntnisse sind wohl doch zu begrenzt, um mit der NSLU2 größere Sprünge zu machen. Vielleicht kann mir ja einer von euch sagen, wie ich wieder mittels Browser auf meine NSLU2 zugreifen kann, beziehungsweise eine Firmware installieren.


mfg Hock

Anzeigen

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

2

18.11.2009, 19:49

Moin,

Kurze Antwort, Gar Nicht...
Du musst zum Firmware flashen eines der Tools verwenden, upslug2 (Linux/MAC) oder Sercom Utility (Windows, hier im Downloadbereich).

Die andere Frage wäre natürlich, was verstehst Du unter "kein Browserzugriff"? Feh lermeldung, wenn ja, welche? Wenn nein, was dann?
Bootest Du mit oder ohne externen Datenträger?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Anzeigen

Hock

Anfänger

  • »Hock« ist der Autor dieses Themas

Beiträge: 7

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: originale Firmware 2.3r29

  • Nachricht senden

3

18.11.2009, 23:24

vielen Dank für die schnelle Antwort caplink811.

Opera meldet

"Fehler!
Die Verbindung zum Server konnte nicht hergestellt werden."

mit Browser Zugriff meine ich natürlich die Oberfläche de erscheinen sollte, wenn man in einem Browser direkt die IP der NSLU2 eingibt. Und beim durchlesen diverser Beiträge hier ist mir aufgefallen das nach der Installation von Unslung-6.10-beta trotzdem die von mir vorgegebene IP Adresse weiterhin gültig ist. Kurz, sie wurde nicht zurückgesetzt. Und ich kann auch nach wie vor mit FTP auf die NSLU2, beziehungsweise auf die angeschlossenen Datenträger mit meiner alten IP zugreifen.
Nach der Installation habe ich zuerst einen Neustart ohne Datenträger gemacht. Anschließend mit Datenträger (USB Stick). Bis dahin war alles noch in Ordnung. Nach dem nächsten Neustart war dann Feierabend - keine Benutzeroberfläche im Browser mehr, weder mit noch ohne Datenträger.

Ich werde mir nun das Windows Utility Sercom runterladen und hoffen das ich damit zurechtkomme.

mfg Hock

JoeBie

Anfänger

Beiträge: 5

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: originale Firmware 2.3r29

  • Nachricht senden

4

19.11.2009, 00:42

Falls Du den Port 80 im Menü Administration - System geändert?

Dann musst Du den in Opera auch so angeben http://IP der SLUG:Neuer Port (z.B. http://192.168.1.77:8082)
Schöne Grüsse
JoeBie

Hock

Anfänger

  • »Hock« ist der Autor dieses Themas

Beiträge: 7

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: originale Firmware 2.3r29

  • Nachricht senden

5

23.11.2009, 15:36

Tja - es hätte so schön sein können. :(
Zuerst habe ich das Upgrade Utility, nachdem ich es endlich gefunden hatte, aus dem Internet gezogen. Dann mit der Reset-Methode bis zum blinken der LED gewartet. Anschließend Originalfirmware aufgespielt(mittlerweile mit mehreren verschiedenen Firmware versucht). Das sah auch ganz gut aus. Zuerst "Erasing EEPROM", dann "Upgrading" und zum Schluss "Verifying Target". Ergebnis: "Upgrade successfully!". bis ich versucht habe die Oberfläche im Browser aufzurufen. Kurz - gleiche Fehlermeldung wie vorher. Ich hatte zwar gedacht beim Löschen würde auch auf die ursprüngliche IP (192.168.1.77) zurückgestellt, aber dem war nicht so. Nach wie vor lässt sich die Box mit der von mir eingegebenen IP Adresse ansprechen. Also unter Löschen verstehe ich etwas anderes. BTW dies war übrigens der einzige Punkt bei dem sich am Fortschrittsbalken nichts tat.

@JoeBie, gute Frage. ?( Ich meine ich hätte sowas laut Anweisung in der PDF Datei gemacht. Und soweit ich mich erinnere habe ich auf Port 80 umgestellt (?)
In dieser Richtung habe ich nun auch alles durchgetestet. Ohne Erfolg.


Ich hatte mal irgendwo hier gelesen, dass man schon mit einem Hammer auf die NSLU2 einschlagen müsste um sie zu zerstören. Scheinbar habe ich einen leichteren Weg gefunden. :D

Wenn noch einer eine Idee hat, gleichzeitig auch die Geduld hat sie mir zu erklären, ich wäre sehr dankbar. Ich möchte mich ungern von diesem Teil trennen. Schließlich hat sie fast fünf Jahre tadellos funktioniert.

cu Hock

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

6

23.11.2009, 19:22

Moin,

warum sollte die NSLU nicht unter der von Dir eingegebenen IP zu erreichen sein?
Wenn Du das willst, solltest Du die Konfiguration der NSLU löschen, siehe http://www.nslu2-linux.org/wiki/HowTo/ResetSysConf .

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Hock

Anfänger

  • »Hock« ist der Autor dieses Themas

Beiträge: 7

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: originale Firmware 2.3r29

  • Nachricht senden

7

23.11.2009, 22:40

Moin,

warum sollte die NSLU nicht unter der von Dir eingegebenen IP zu erreichen sein?.....


Nun JrB, dass ist eigentlich ganz schnell zu erklären. Ich war bis jetzt der Meinung das mit den Worten "Erasing EEPROM" ein Vorgang gemeint ist, der sowohl die Firmware wie auch die Einstellungen löscht. Wenn dem nicht so ist, wo werden denn dann die Einstellungen gespeichert?
Mir ist es im Grunde genommen noch lieber, dass die von mir eingetragenen IP Adresse beibehalten wird. So erspare ich mir die Umstellung meines Netzwerkes. Es wundert mich halt nur.
Ich will doch nur meine Oberfläche wiederhaben, damit ich an der NSLU2 wieder Einstellungen vornehmen kann. Mir ist es mittlerweile auch egal welche Firmware ich nehmen kann, Hauptsache es läuft wieder. :(

cu Hock

8

03.12.2009, 13:46

Und soweit ich mich erinnere habe ich auf Port 80 umgestellt (?)
In dieser Richtung habe ich nun auch alles durchgetestet. Ohne Erfolg.


Auch schon nachgesehen? Port per Zufallsprinzip anzutesten könnte langwierig sein/werden. Über Putty nachgesehen?

Hock

Anfänger

  • »Hock« ist der Autor dieses Themas

Beiträge: 7

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: originale Firmware 2.3r29

  • Nachricht senden

9

04.12.2009, 12:07

wieso erledigt?

. Über Putty nachgesehen?


Hi Jimmbob23,
wie muss ich da vorgehen. Ich habe bisher noch nicht mit Putty gearbeitet.

cu Hock

Linux-Beginner

unregistriert

10

04.12.2009, 19:19

Mir ist es im Grunde genommen noch lieber, dass die von mir eingetragenen IP Adresse beibehalten wird. So erspare ich mir die Umstellung meines Netzwerkes.
Kann es sein dass sich dein PC im Netzwerkbereich 192.168.0.xx befindet?
Falls dies der Fall ist, kannst du natürlich nicht auf 192.168.1.77 zugreifen. Hier müsstest Du kurz die IP Adresse vom PC ändern.

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

11

04.12.2009, 20:02

Moin,

Wenn die NSLU nach wie vor über die von Dir ehedem konfigurierte IP erreichbar ist (FTP), kannst Du /etc/httpd.conf (osä) downloaden? Und wenn ja, den Port auslesen?

Oder einfacher, nimm einen Portscanner (nmap oder ahnlich, nmap -p 1-65535 -T4 -A -v -PE IP_Address)

Just my 2 Cent

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Hock

Anfänger

  • »Hock« ist der Autor dieses Themas

Beiträge: 7

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: originale Firmware 2.3r29

  • Nachricht senden

12

04.12.2009, 23:14

Wow!
Ich hatte schon die Hoffnung aufgegeben. Hab mich nicht mehr getraut weiter zu fragen. Also danke nochmal, dass ihr so viel Geduld mit mir habt. :thumbup:

Ums nochmal zusammenzufassen. Mein Netzwerk läuft unter 192.168.2. X. Ich hab eine gefritzte Speedport W 900V als Router (192.168.2.1).
Die NSLU2 hat die IP-Adresse 192.168.2.111 vor dem Firmware Update auf "Unslung-6.10-beta " von mir bekommen und lief tadellos..
Nach dem Update und jetzt, nach dem Zurückflashen auf Originalsoftware, ist die NSLU2 nach wie vor unter dieser IP (192.168.2.111) per FTP und Ping zu erreichen. Angeschlossene Datenträger kann ich per FTP ansprechen, kopieren, herunter laden. Ich komme lediglich nicht auf die Browseroberfläche um Einstellungen vorzunehmen.

Die Sache mit dem Portscanner werde ich morgen Früh direkt in Angriff nehmen.

Also vielen Dank nochmal.

mfg Hock :thumbup:

innovonet

Schüler

Beiträge: 157

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Unslung 6.10

Wohnort: Giessen

Beruf: Dipl.-Ing.Elektro

  • Nachricht senden

13

05.12.2009, 00:48

Hallo Hock,
in deinem System sollte ein Prozess laufen:
/usr/sbin/thttpd -C /etc/thttpd.conf
Womit auch klar wäre, in welcher Datei die Konfiguration liegt?
Bei mir steht dort u.a.
# This section _documents_ defaults in effect
port=80
Wahrscheinlich kannst du dir aber die Prozessliste nicht anzeigen lassen, wenn kein telnet geht.
Zumindest sollte der Port zu lesen sein, wenn auch hier nicht änderbar. Wie man den im Brauser verwendet haben andere bereits geschrieben.
Falls bei dir auch port=80 steht läuft der Prozess nicht. Wobei ich mich frage, wie das System so verbiegen kann, dass beim Start ohne Datenträger die Weboberfläche nicht mehr funktioniert??? Mal so nebenbei: das NSLU2 nimmt es gelegentlich übel, wenn im laufenden Betrieb der Datenträger entfernt oder der Saft abgestellt wird.
Viel Erfolg, Thomas
V2.3R63-uNSLUng-6.10-beta, WD TV Live, Noxon. Zeitweilig mal Soundbridge, FSG3, Intradisk, Showcenter 200.

Hock

Anfänger

  • »Hock« ist der Autor dieses Themas

Beiträge: 7

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: originale Firmware 2.3r29

  • Nachricht senden

14

07.12.2009, 20:14

Moin zusammen,
ich hab's nun endlich geschafft. 8o Nachdem ich meinen PC mehrere Stunden mit dem scannen der Ports beschäftigt habe, haben sich schließlich vier offene Ports gefunden. Natürlich war es der letzte, der endlich die Weboberfläche hervorbrachte. (Wie ich auf die Idee gekommen bin?) ;(
Nun werde ich mein System erst einmal auf den alten Stand bringen. Ob ich mich noch einmal mit der Umstellung auf Unslung beschäftigen werde Weiß ich nicht. Erstmal muss ich jetzt meine Nerven etwas beruhigen.
Aber immerhin ist es gut zu wissen wo man Hilfe her bekommt. Und deswegen hier auch nochmal meinen herzlichen Dank an Euch. :love:

Hock

Ähnliche Themen

Social Bookmarks