Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Heagar

Anfänger

  • »Heagar« ist der Autor dieses Themas

Beiträge: 21

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

1

10.10.2009, 09:12

MPD startet nicht

Hallo,

ich habe auf meiner Slug mpd installiert, die /etc/mpd.conf mit folgenden Inhalt erstellt:

port "6600" # Der Port auf dem der MPD lauscht
music_directory "/musik/mp3" # Pfad zu eurer Musik
playlist_directory "/musik/mp3" # Hier wird die Playliste gespeichert
db_file "/musik/music.db" # Hier die Musik-Datenbank
log_file "/var/log/mpd.log" # Hier sollte MPD schreibrechte haben
error_file "/var/log/mpd.error" # Ganz nützlich falls etwas nicht funktioniert
state_file "/musik/mp3/state" # Sie veranläßt MPD, wieder zu starten, was auch
# immer unterbrochen wurde (shutdowns,reboots,usw..)
audio_output_format "44100:16:2"

# output options
mixer_type "oss"
mixer_device "/dev/mixer"
mixer_control "oss"
replaygain "album"

audio_output {
type "oss"
name "my sound card"
device "/dev/dsp"
}

User "root"


mpd versuche ich mit

mpd /etc/mpd.conf

zu starten.

Ich bekomme dann als Fehlermeldung:

mpd: error while loading shared libraries: libsqlite3.so.0: cannot open shared object file: No such file or directory

Kann mir jemand helfen herauszufinden was das falsch läuft, bzw. was fehlt?

Vielen Dank für eure Hilfe

Heagar

PS: Meine Soundcard wird erkannt und ich kann mit madplay einzelne Titel abspielen.

Anzeigen

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

2

10.10.2009, 09:25

AW: MPD startet nicht

Moin,

Ist es eigentlich schwierig Fehlermeldungen auch zu lesen?

Zitat von »Heagar;36203«


mpd: error while loading shared libraries: libsqlite3.so.0: cannot open shared object file: No such file or directory


Ist die angemahnte Datei in /lib oder /usr/lib vorhanden?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Anzeigen

Heagar

Anfänger

  • »Heagar« ist der Autor dieses Themas

Beiträge: 21

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

3

10.10.2009, 09:31

AW: MPD startet nicht

Hallo Cap,

nein, ist natürlich nicht so schwierig...

die Datei ist nich in der /lib enthalten. Ich weis aber nicht was das für eine Datei sein soll oder wo ich sie herbekomme.

Grüße

Heagar

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

4

10.10.2009, 11:08

AW: MPD startet nicht

Moin,

Vielleicht ipkd list|grep sqlite, oder evtl ipkg install sqlite...

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Heagar

Anfänger

  • »Heagar« ist der Autor dieses Themas

Beiträge: 21

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

5

10.10.2009, 13:24

AW: MPD startet nicht

Jepp, das wars. Danke Die!!!

jetzt kann ich weiter probieren.

Heagar

Social Bookmarks