Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Dienstag, 8. September 2009, 21:55

Slug bootet nicht mehr von Disk1

Hallo Zusammen,

zunächst die Konfig:

NSLU2
WD 640 GB HD an DISK1
Unsling
Unslung V6.8

Ich habe folgendes Problem:

Vor einigen Tagen wollte ich n paar Dateien auf die NSLU2 kopieren. NSLU2 angeschaltet, hat gebootet und dann das erste Prob. Auf die Platte ließ sich nicht mehr zugreifen. Nach ewigem hin und her hab ich dann gesehen, dass die USB-Platte in DISK2 eingesteckt war statt wie sonst in DISK1. Ist wohl Umbauarbeiten passiert, hab dan wohl ohne gucken einfach in DISK2 gesteckt. Nach dem Umstecken in DISK1 ließ sich die Platte wieder mit dem Unslung V6.8 booten und auch Mediatomb lief ohne Probs.
Dann hab ich die NSLU2 wieder ausgemacht.

Eben als ich wieder dran wollte:NSLU2 an, die bootet und nach kurzer zeit war sie dann da. Ich versuche mich anzumelden und bekomme die Fehlermeldung, dass es den User und das PW nicht gibt. Also nochmal geschaut, USB-HDD an Disk1 wie es auch sein soll. Dann Platte nochmals gebootet. Wiederrum falscher User etc.

Dann ins Webinterface und was sehe ich da, beide Stati der HHDs auf nicht formatiert. Ich versuche mich in die Administration einzuloggen, der nimmt wieder den user nicht, also mit Standard Admin/admin versucht, damit ok. Ich schau auf den Status der Disks: DISK1 not formated, DISK2 not installed. DISK2 ok, da ja nichts dran ist, aber warum findet der die DISK1 nicht mehr??? Nach mehrfachen Reboots ohne Erfolg, die NSLU2 bootet nicht von der Platte, erkennt aber, dass eine dran ist. Am PC ist die Platte zu sehen , alle Daten drauf.

Wie kann ich, ohne die komplette NSLU2 neukonfigen zu müssen, die Platte , ohne diese neu formatieren zu müssen, wieder ans Laufen bekommen?

Vielen Dank schonmal!!!!
Viele Grüße Camillo :-)

Anzeigen

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

2

Dienstag, 8. September 2009, 22:20

AW: Slug bootet nicht mehr von Disk1

N'Abend,
Augen aufmachen, und oder Suche nutzen wären evtl. Möglichkeiten...
http://www.nslu2-info.de/forum/showthread.php?t=7918, Vorher Variante.

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Anzeigen

3

Mittwoch, 9. September 2009, 21:58

AW: Slug bootet nicht mehr von Disk1

Vielen Dank für die schnelle Antwort, ich hab mal die vorher Variante versucht, allerdings scheitert es schon beim mounten:
"mount: mounting /dev/sda1 on /share/hdd/conf failed"
und auch bei
"mount: mounting /dev/sda2 on /share/hdd/conf failed"

die darauf folgende Befehle nimmt er:

touch /share/hdd/conf/.dongle
chmod 0666 /share/hdd/conf/.dongle
touch /share/hdd/conf/.htpasswd
chmod 0644 /share/hdd/conf/.htpasswd

Ich komm nicht weiter...
Es ist viel verlangt, aber hat jemand eine Step-by-Step Anleitung zum wiederherstellen?

Danke, viele Grüße :-)

innovonet

Schüler

Beiträge: 157

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Unslung 6.10

Wohnort: Giessen

Beruf: Dipl.-Ing.Elektro

  • Nachricht senden

4

Sonntag, 13. September 2009, 21:26

AW: Slug bootet nicht mehr von Disk1

Hallo Camillo,
prinzipiell solltest Du erst mal darauf achten, ob nach der Betriebsbereitschaft heftige Aktivitäten auf der Platte stattfinden. Achte da mehr auf die Festplatten-LED als auf das NSLU2-LED. Möglicherweise findet gerade der regelmässige Putzzyklus statt, der bei größeren Platten auch schon mal länger dauern kann (ist abschaltbar, Vorsicht!).
Das mit dem nicht mounten sieht nicht so gut aus. Vielleicht solltest Du erst mal mit "fdisk -l /dev/sda" (bzw. /sdb) anzeigen lassen, was überhaupt mit der Platte los ist. Bei mir erscheint dann z.B.:

/dev/sda1 x x x 83 Linux
/dev/sda2 x x x 83 Linux
/dev/sda3 x x x 82 Linux swap

Diese 3 Partitionen müssen vorhanden sein, damit die NSLU2 die Platte als Linuxsystem einbindet (und noch einige weitere Dateien)!
Die wichtigste ist dabei die sda1, auf welcher Deine Daten sind. Sofern diese noch vorhanden ist kannst du sie zumindest manuell mounten und sichern.
Das mit dem touch ist hier nur verwirrend. Es funktioniert immer, auch wenn keine Partition gemountet wurde. Es geht dann halt ins RAM (oder flash oder wo auch immer?). Es hat in dem Fall leider keine positivien Auswirkungen. Also: erst mal erfolgreich mounten, mit "mount" prüfen und dann touchen.
Für eine einfache Wiederherstellung verwende ich einen Stick, einen Partitionsmanager und rsync. Rsync ist aber wiederum ein Thema für sich.
Viel Erfolg, Thomas
V2.3R63-uNSLUng-6.10-beta, WD TV Live, Noxon. Zeitweilig mal Soundbridge, FSG3, Intradisk, Showcenter 200.

5

Montag, 21. September 2009, 11:49

AW: Slug bootet nicht mehr von Disk1

Danke für Antwort.

Jetzt kommt das nächste Problem. Im Webinterface kann ich Telnet nicht mehr aktivieren, steht auf enabled, kann aber nicht auf die NSLU2 drauf. wenn ich auf disable klicke kommt folgende Fehlermeldung: Error: Unable to save data to file. Mit Firefox und Inet Explorer die selbe Meldung....

Hat jemand ne Ahnung was da los ist?

innovonet

Schüler

Beiträge: 157

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Unslung 6.10

Wohnort: Giessen

Beruf: Dipl.-Ing.Elektro

  • Nachricht senden

6

Donnerstag, 24. September 2009, 20:44

AW: Slug bootet nicht mehr von Disk1

Erst Telnet enable und Telnet login, dann Festplatte anschließen.
V2.3R63-uNSLUng-6.10-beta, WD TV Live, Noxon. Zeitweilig mal Soundbridge, FSG3, Intradisk, Showcenter 200.

Social Bookmarks