Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

wiggedy

Schüler

  • »wiggedy« ist der Autor dieses Themas

Beiträge: 47

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

1

07.07.2009, 21:13

Nach Reboot kein Zugriff aufs Webinterface

Hallo, ich habe nach einem Jahr uptime meine NSLU2 gebootet. Per SSH komme ich noch drauf, auch die shares gehen noch. Leider komme ich weder mit meinem PAsswort noch mit dem Standardpasswort auf das Webinterface. Zumindest falls default user:admin password:admin ist.

Kann mir jemand weiterhelfen?

Anzeigen

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

2

08.07.2009, 15:44

AW: Nach Reboot kein Zugriff aufs Webinterface

Moin,

die Suchfunktion scheint mal wieder defekt...
Wenn Du Shell Zugriff hast, im Verzeichnis Management unterhalb des Homeverzeichnisses des Webserver sollte sich eine .htpasswd befinden (aus dem Gedächnis, keine Unslung NSLU online), darin findest Du den Namen des Verwaltungsusers, und das verschlüsselte PW. Wenn Dir zu dem Namen kein passendes PW einfällt, kopiere die entsprechende .htpasswd aus /initrd (dort sollte die Kombination admin/admin sein.

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Anzeigen

wiggedy

Schüler

  • »wiggedy« ist der Autor dieses Themas

Beiträge: 47

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

3

12.07.2009, 00:52

AW: Nach Reboot kein Zugriff aufs Webinterface

hi caplink danke für die Antwort. Die .htpasswd unter Management ist leer und in der initrd liegt leider keine.

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

4

12.07.2009, 10:50

AW: Nach Reboot kein Zugriff aufs Webinterface

Moin,
wie gesagt, das Alter ist hoch, das Gedächnis schlecht, evtl. so http://www.nslu2-info.de/forum/showthrea…hlight=htpasswd

bye
JrB
"Supporting joe users worldwide" <- that's our motto


wiggedy

Schüler

  • »wiggedy« ist der Autor dieses Themas

Beiträge: 47

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

5

20.07.2009, 10:56

AW: Nach Reboot kein Zugriff aufs Webinterface

Also die Dateien sind beide leer. Wenn ich einen Admin eintrag mache und die dateien kopiere geht es nicht. Der Link zu dem Tool ist down. Findest Du das Tool vielleicht noch, wie heißt dies?

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

6

20.07.2009, 18:44

AW: Nach Reboot kein Zugriff aufs Webinterface

packe noch ein /forum dazwischen, dann klappt es auch mit dem Link

bye
JrB
"Supporting joe users worldwide" <- that's our motto


wiggedy

Schüler

  • »wiggedy« ist der Autor dieses Themas

Beiträge: 47

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

7

23.07.2009, 00:38

AW: Nach Reboot kein Zugriff aufs Webinterface

dann bin ich im Redboot, verstehe ich, aber ich muss doch nur die htaccess Datei überschreiben. ich habe ja noch vollen ssh Zugriff mein Problem ist, dass ich nicht weiss wie die htaccess datei aussehen muss, da meine beide leer sind, also sowohl die /home/httpd/html/Management/.htpasswd als auch die /share/flash/data/home/httpd/html/Management/.htpasswd. Es macht aus meiner Sicht keinen Sinn eine leere Datei über eine andere zu kopieren.

Ich benötige also zumindest die Original .htaccess Datei um mit admin admin wieder rauf zu kommen.

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

8

23.07.2009, 16:10

AW: Nach Reboot kein Zugriff aufs Webinterface

Moin,

ich bin zwar alt, aber nicht senil, wo steht da...

Quellcode

1
2
3
4
5
6
7
8
9
10
N'Abend,

das Passwort ist in /home/httpd/html/Management/.htpasswd abgelegt. Diese Kombination admin:XP4AVpoPzC2is entspricht User admin, Passwort admin. Das Problem besteht eher darin an die Datei zu kommen...
Nutzt Du eine externe Platte/Mem-Stick ? Wenn ja, ohne diese booten und dann Telnet aktivieren, in diesem Falle sollte admin:admin funktionieren. Dann kannst Du mit cp /home/httpd/html/Management/.htpasswd /share/[hdd|flash]/data/home/httpd/html/Management/.htpasswd die Datei ersetzen.

bye
 JrB
 		  		  		  		 		 			 				__________________
				"Supporting joe users worldwide" <- that's our motto
[COLOR=Blue]

... was von redboot?

bye
JrB
[/COLOR]
"Supporting joe users worldwide" <- that's our motto


wiggedy

Schüler

  • »wiggedy« ist der Autor dieses Themas

Beiträge: 47

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

9

26.07.2009, 22:24

AW: Nach Reboot kein Zugriff aufs Webinterface

Vorher ging es um das Tool, auf welches Du verlinkt hast und dass war für den vereinfachten Zugriff für den Redboot.

Also um auf die einfache Frage zurückzukommen, wie sieht die originale htaccess Datei aus?

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

10

27.07.2009, 16:41

AW: Nach Reboot kein Zugriff aufs Webinterface

Du kannst lesen?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


wiggedy

Schüler

  • »wiggedy« ist der Autor dieses Themas

Beiträge: 47

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

11

27.07.2009, 22:05

AW: Nach Reboot kein Zugriff aufs Webinterface

ja kann ich. Du bist wirklich sehr freundlich. anstatt mir die datei mal kurz zu posten, bist du mehr damit beschäftigt mir zu sagen, dass ich zu blöd bin. ich habe sehr wohl gesehen, dass dort der admin inkl. passwort erwähnt wird, ist in der datei nicht mehr vorhanden, als der eintrag dieser beiden werte, ich kenne .htaccess dateien mit deutlich mehr inhalt.
außerdem habe ich nicht gefunden, wie man das management einzeln neustartet, um die datei einzulesen.

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

12

27.07.2009, 22:22

AW: Nach Reboot kein Zugriff aufs Webinterface

Punkt 1. Die Datei ... Du verweist darauf, das der Link nicht funktioniert, ich rate Dir ein /forum einzufügen... hast Du es versucht?

Punkt 2. Ich habe einen Auszug aus der uNSLUng .htpasswd gepostet, in .htpasswd Files stehen gemeinhin User:Passwortkombinationen.

Punkt 3. Jeider gehst Du nicht darauf ein, ob wenn Du ohne externes Medium bootest es immer noch Probleme gibt... Du hast den verlinkten Thread gelesen? Und das Vorgeschlagene probiert?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


wiggedy

Schüler

  • »wiggedy« ist der Autor dieses Themas

Beiträge: 47

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

13

04.08.2009, 22:28

AW: Nach Reboot kein Zugriff aufs Webinterface

Zitat von »caplink811;35795«

Punkt 1. Die Datei ... Du verweist darauf, das der Link nicht funktioniert, ich rate Dir ein /forum einzufügen... hast Du es versucht?

Punkt 2. Ich habe einen Auszug aus der uNSLUng .htpasswd gepostet, in .htpasswd Files stehen gemeinhin User:Passwortkombinationen.

Punkt 3. Jeider gehst Du nicht darauf ein, ob wenn Du ohne externes Medium bootest es immer noch Probleme gibt... Du hast den verlinkten Thread gelesen? Und das Vorgeschlagene probiert?

bye
JrB


Ok sorry hatte früher keine Zeit es zu testen.

1. Das mit dem forum hatte ich verstanden
2. Wenn ich ohne externes Medium boote komme ich auf das Gerät via Webinterface admin admin geht. Über telnet kam ich auch drauf. Dann habe ich anschliessend die Platte angesteckt das file unter /share/flash/data/home/httpd/html/Management/.htpasswd gelöscht und anschliessend das file aus dem internen Speicher wie beschrieben rüberkopiert. Danach habe ich neu gebootet und komme wieder nicht drauf.
3. siehe 2.

Social Bookmarks