Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Mittwoch, 8. April 2009, 20:51

glib - gtk - GLIB wird nicht gefunden!

Hallo Leute!

Ich habe ein großes Problem und werke jetzt schon Stunden daran!
Folgendes:

Ich habe meinen Slug schon ordentlich aufgemotzt mit Haufenweise Programmen!
Alles funktioniert wunderbar!

Jetzt hab ich mir noch dazu GTK installiert - Die GTK-Demo geht auch ohne Probleme und verbindet sich anstandslos mit meinem X-Server!

Lange rede kurzer Sinn: Ich will mir jetzt einfach einen GUI FTP Clienten installieren!
2 habe ich probiert - gFTP und Junkie!
Bei beiden kommt wenn ich ./configure laufen lasse der Fehler das die GLIB nicht gefunden wurde!

Ich habe schon Tipps gelesen das man an den GLIB Versionscheck in der configure.in ein "_2" ranmachen soll, nix geholfen!

Was hab ich noch probiert:

  • Neuesten GLIB mit ipkg - Package glib (2.16.6-1) installed!
  • Mehrere Reinstalls - kein Erfolg!
  • LD_LIBRARY_PATH und PATH gesetzt auf diverse SysOrdner - kein Erfolg!
  • Mehrere Reboots des Slugs - kein Erfolg!
  • Nach einer glib-config gesucht - nicht gefunden!
  • Fast alles Libs installiert die via ipkg zur Verfügung stehen - kein Erfolg!
  • Ich kann alles installieren - Ausser Dinge die die GLIB brauchen!
  • GLIB schon selbst kompiliert und installiert - kein Erfolg!
  • Andere GTK FTP Clienten probiert - kein Erfolg!


Firmware Version: V2.3R63-uNSLUng-6.10-beta

Ich hoffe irgendwer hat einen Rat für mich wie ich die GLIB so ins System einbinde das sie auch erkannt werden (installed is sie ja, siehe oben)!

Kurzer Log meines ./configure beim Junkie

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
...
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for a BSD-compatible install... ./install-sh -c
checking whether ln -s works... yes
checking for ranlib... ranlib
checking build system type... armv5b-unknown-linux-gnu
checking host system type... armv5b-unknown-linux-gnu
checking for main in -lcrypt... yes
checking for pkg-config... /opt/bin/pkg-config
checking for GLIB - version >= 2.0.3... no
*** Could not run GLIB test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding GLIB or finding the wrong
*** version of GLIB. If it is not finding GLIB, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location  Also, make sure you have run ldconfig if that
*** is required on your system
***
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
configure: error: "Cannot find glib"                  
...

Anzeigen

Social Bookmarks