Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Dienstag, 30. Dezember 2008, 02:47

Mediatomb kann nicht gestartet werden

Hallo zusammen,

nachdem die Trial vom Twonky abgelaufen ist, wollte ich mir Mediatomb installieren. Ich habe ipgk update, dann ipkg install mediatomb gemacht.
dann heißt es man soll mediatomb starten mit dem Befehl mediatomb.
Allerdings erscheint dann die Meldung -sh mediatomb not found.
Was mache ich falsch? Den weiteren Verlauf (Config, etc) habe ich mir durchgelesen und traue mir zu das zu schaffen :o
Aber ich komm nicht über den start Befehl hinaus.
Kann jemand helfen?
Gruß

Unslung 6.10beta mit Unsling auf HDD

Anzeigen

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

2

Dienstag, 30. Dezember 2008, 14:24

AW: Mediatomb kann nicht gestartet werden

Moin,

Du möchtest die Suchfunktion nutzen, Dein Suchbegriff könnte $PATH sein...

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Anzeigen

francy

Anfänger

Beiträge: 14

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

3

Donnerstag, 1. Januar 2009, 15:36

AW: Mediatomb kann nicht gestartet werden

Hallo

Stehe vor einen ähnlichen Problem.

Mit "/opt/etc/init.d/S90mediatomb start" starte ich das Prog. Leider kommte ne Fehlermeldung das der Start deaktiviert ist.

Mit der Befehlszeile müsste das zum aktivieren sein oder

To run MediaTomb on startup, edit /opt/etc/default/mediatomb and set MT_ENABLE to true.


Aber ich weis nicht wie ich die anwenden (eintippen) muss. Oder geht das nicht per Telnet?

vlt kann mir wer helfen

mfg francy

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

4

Donnerstag, 1. Januar 2009, 16:33

AW: Mediatomb kann nicht gestartet werden

Moin,

kommentiere in /opt/etc/init.d/S90mediatomb die erste if Sequenz aus...

bye
Joerg
"Supporting joe users worldwide" <- that's our motto


francy

Anfänger

Beiträge: 14

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

5

Donnerstag, 1. Januar 2009, 19:27

AW: Mediatomb kann nicht gestartet werden

Hallo

Danke für den Tip

Äh was meinst du mit kommentieren

edit: mediatomb startup is disabled. meinst du das damit? das will ich ja wegbekommen.

mfg francy

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

6

Donnerstag, 1. Januar 2009, 19:46

AW: Mediatomb kann nicht gestartet werden

----8< Cut 8<----
24 # See how we were called.
25 case "$1" in
26 start)
27 #if [ ${MT_ENABLE} = false ] ; then
28 # echo "mediatomb startup is disabled in /opt/etc/default/mediatomb"
29 # exit 0
30 #fi
31
32 # Check if MT is already running
33 if [ -e /opt/var/lock/mediatomb ] ; then
34 $0 stop
35 fi
36
37 # Start daemon.
38 touch $MT_PIDFILE
39 chown $MT_USER.$MT_GROUP $MT_PIDFILE
40
41 mkdir -p "/$MT_HOME/$MT_CFGDIR"

----8< Cut 8<----

bye
JrB
"Supporting joe users worldwide" <- that's our motto


francy

Anfänger

Beiträge: 14

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

7

Donnerstag, 1. Januar 2009, 19:58

AW: Mediatomb kann nicht gestartet werden

Hallo

Sorry für meine Unwissenheit. Aber muss ich das bei Telnet eingeben oder muss ich da irgendwie per ftp ne Datei editieren?

Wenn ich die Zahlen aufmache kommen unter Windows irgendwelche Sicherheitszertifikate auf

mfg francy

francy

Anfänger

Beiträge: 14

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

8

Freitag, 2. Januar 2009, 19:22

AW: Mediatomb kann nicht gestartet werden

Also ich kapier das nicht.

Was hat es mit den Raute Zeichen auf sich. Muss ich da irgendwas eingeben?

mfg francy

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

9

Freitag, 2. Januar 2009, 19:35

AW: Mediatomb kann nicht gestartet werden

Hallo Francy,

1.) Du musst Dich mittels telnet auf die SLUG einloggen.

2.) Mit einen Editor die Datei /opt/etc/init.d/S90mediatomb öffnen
(z.B. nano /opt/etc/init.d/S90mediatomb)

3.) Die von caplink811 markierten Änderungen durchführen -
Also Rauten vor den markierten Zeilen einfügen.

4.) Die Datei speichern und den Editor beenden.

5.) /opt/etc/init.d/S90mediatomb start ausführen

6.) hoffen das es geht ;)

MfG
Werner

francy

Anfänger

Beiträge: 14

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

10

Freitag, 2. Januar 2009, 20:00

AW: Mediatomb kann nicht gestartet werden

Hi!!!

Danke

Das mit den Editor. Muss ich die Datei mit einen Editor unter FTP zugriff editieren oder geht das mit Telnet?

Das mit den Rauten ist auch dann klar.

Werde mal nach den Nano editor googeln und dann melde ich wieder.

Schön langsam wirds ja bei mir. Also mit meiner DM7020er tue ich mich leichter.

mfg francy

francy

Anfänger

Beiträge: 14

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

11

Freitag, 2. Januar 2009, 20:26

AW: Mediatomb kann nicht gestartet werden

Also ich habe mir jetzt den Nano Editor als i386 heruntergeladen. Muss ich denn jetzt noch auf die NSLU bringen oder? Hmm wie stell ich das wieder an.

Sorry für meine Unwissenheit, aber mit Telnet und Linux habe ich nicht viel am Hut

mfg francy

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

12

Freitag, 2. Januar 2009, 20:41

AW: Mediatomb kann nicht gestartet werden

N'Abend,

a.) Applikationen die auf der NSLU ausgeführt werden sollen, müssen zur selbigen binärkompatibel sein, aka für ARM Prozessoren kompiliert, aber damit
b.) nicht jeder das Rad neu erfinden muß verfügt Unslung-FW über ein
c.) Paketmanagement, welches es ermöglicht, zur Verfügung stehende Applikationen einfach herunter zu laden und zu installieren.

ipkg --help, oder ipkg list sind Deine Freunde.

Die Kommandos

ipkg install nano
/opt/bin/nano Dateiname
evtl. Probleme beseitigen
/opt/bin/nano Dateiname

sollten Dich ans Ziel führen.

Bye
JrB

PS: http://www.netzmafia.de/skripten/unix/ ist als Lektüre zur guten Nacht empfehlenswert...
"Supporting joe users worldwide" <- that's our motto


francy

Anfänger

Beiträge: 14

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

13

Freitag, 2. Januar 2009, 21:22

AW: Mediatomb kann nicht gestartet werden

Hi!!!

Also das mit dem IPKG Install hatte ich ja schon mal *gg*

Also der Nano Editor ist jetzt drauf. Aber mit der Befehlszeile nano /opt/etc/init.d/S90mediatom

komme ich nicht drauf. Bin auch mit den cd Befehl direkt ins init.d Verzeichniss rein und habe da versucht die Datei zu editieren.

Gehört da die Befehlszeile anders geschrieben?

mfg francy

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

14

Freitag, 2. Januar 2009, 21:47

AW: Mediatomb kann nicht gestartet werden

Hm, entweder Du bemühst die Suchfunktion um Fundstellen für "$PATH", oder Du schreibst die Befehlszeile so wie in meinem Beispiel, oder Du beschreibst die etwaigen Fehlermeldungen genauer...

bye
JrB
"Supporting joe users worldwide" <- that's our motto


francy

Anfänger

Beiträge: 14

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

15

Freitag, 2. Januar 2009, 22:06

AW: Mediatomb kann nicht gestartet werden

Also wenn ich /opt/bin/nano Dateiname eingebe. Also bei Dateiname gehört Mediatomb rein oder?

Kommt die Fehlermeldung Error: Opening Terminal unknown.

Wenn ich $PATH eingebe dann kommt


Zitat


LKGAAE1B8 login: root
Password:
Welcome to Unslung V2.3R63-uNSLUng-6.10-beta
---------- NOTE: THIS SYSTEM IS CURRENTLY UNSLUNG ----------

BusyBox v1.3.1 (2007-12-29 03:38:35 UTC) Built-in shell (ash)
Enter 'help' for a list of built-in commands.
# /opt/etc/init.d/S90mediatomb
mediatomb startup is disabled in /opt/etc/default/mediatomb
# nano /opt/etc/default/mediatomb
-sh: nano: not found
# cd /opt/etc/default
# nano mediatomb
-sh: nano: not found
# nano/opt/etc/default/mediatomb
-sh: nano/opt/etc/default/mediatomb: not found
# /opt/bin/nano mediatomb
Error opening terminal: unknown.
# /opt/bin/nano mediatomb
Error opening terminal: unknown.
# /opt/bin/nano /opt/etc/default/mediatomb
Error opening terminal: unknown.
# echo $PATH
/sbin:/bin:/usr/sbin:/usr/bin
# /opt/bin/nano mediatomb
Error opening terminal: unknown.
# /opt/bin/nano mediatomb
Error opening terminal: unknown.
# /opt/bin/nano mediatomb
Error opening terminal: unknown.
# echo $PATH
/sbin:/bin:/usr/sbin:/usr/bin
# $PATH
-sh: /sbin:/bin:/usr/sbin:/usr/bin: not found
# nano $PATH
-sh: nano: not found
#



Ich habe hier mal alles rauskopiert

mfg francy

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

16

Freitag, 2. Januar 2009, 22:37

AW: Mediatomb kann nicht gestartet werden

Den Befehl:

ipkg install nano

hast Du ausgeführt? Was passiert, wenn du den Befehl ausführst?
MfG
Werner

francy

Anfänger

Beiträge: 14

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

17

Samstag, 3. Januar 2009, 08:12

AW: Mediatomb kann nicht gestartet werden

# ipkg install nano
Package nano (2.1.7-1) installed in root is up to date.
Nothing to be done
#

Das kommt jetzt. Also es ist installiert.

mfg francy

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

18

Samstag, 3. Januar 2009, 08:32

AW: Mediatomb kann nicht gestartet werden

Morgen,

sorry, ich hab es gestern überlesen:

# /opt/bin/nano mediatomb
Error opening terminal: unknown.

Also installiert ist er. Nur leider fehlen noch einige Pakete. Ich hab mal hier nach der Fehlermeldung gesucht:

https://www.nslu2-info.de/forum/showpost…369&postcount=4

ipkg install ncurses termcap

sollte hier helfen.

Danach sollte /opt/bin/nano gehen ...

Wenn man nur "nano" ohne vorangestellten Pfad eingeben möchtest musst du die Pfadvariable mit /opt/bin erweitern.

MfG
Werner

francy

Anfänger

Beiträge: 14

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

19

Samstag, 3. Januar 2009, 12:46

AW: Mediatomb kann nicht gestartet werden

Hi!!!

Danke also der termcap hat funktioniert. Wurde installiert.

Habe dann nen Reboot gemacht, Telnet wieder im Webif Enabled und per Telnet den Befehl # /opt/bin/nano eingegeben.

Es kommt immer wieder die Fehlermeldung Error opening terminal: unknown.

Habs schon mit mehreren Methoden probiert die Datei zu editieren. Habe mich die ganzen befehlt mal angeschaut. Aber ich komme trotzdem nicht hin

mfg francy

francy

Anfänger

Beiträge: 14

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

20

Samstag, 3. Januar 2009, 13:33

AW: Mediatomb kann nicht gestartet werden

Habs jetzt mal mitn Linux Editor unter Windows die Datei Editiert. Muss ja auch gehen. Mal sehen da ich da irgendwie mit root Rechte reinkomme

mfg francy

Social Bookmarks