Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

chralt

Schüler

  • »chralt« ist der Autor dieses Themas

Beiträge: 57

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

1

19.04.2008, 12:19

CUPS läuft nicht

Hallo Zusammen,

ich habe cups anhand der Anleitung auf http://www.nslu2-linux.org/wiki/HowTo/AddPrinter installiert - und hoffentlich nichts vergessen.

Was sich nicht installieren lies war "cups-doc-de":

Nothing to be done
An error ocurred, return value: 4.
Collected errors:
Cannot find package cups-doc-de.
Check the spelling or perhaps run 'ipkg update'

???

Das Webinterface läßt sich aber nicht starten, es kommt die Fehlermeldung "404 Not Found"




was hast Du bereits probiert?: viel gelesen und gesucht

Die Suche schon benuzt?: ja

Art der Firmware: unslung 6.8

wird ein externer Datenträger genutzt, wenn ja, was für eine Art: USB-Platte 250 GB, USB-Stick 1GB

Anzeigen

Beiträge: 88

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

2

19.04.2008, 18:03

Was sich nicht installieren lies war "cups-doc-de":

*probier es mal mit (ipkg install cups-locale-de) sollte dann gehen



Das Webinterface läßt sich aber nicht starten, es kommt die Fehlermeldung "404 Not Found"

* haste cups mal manuell gestartet und geschaut ob er ohne fehler startet ( /opt/etc/init.d/S88cups )

und schau auch mal unter /opt/var/log/cups nach in die log datein da kann man schonmal ein paar probleme finden und beheben

Anzeigen

chralt

Schüler

  • »chralt« ist der Autor dieses Themas

Beiträge: 57

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

3

20.04.2008, 13:27

Hallo,

"ipkg install cups-locale-de" hat geholfen,die cups-Startseite läßt sich nun aufrufen.

Wenn ich jedoch z. B. auf "Verwalten" klicke, bekomme ich folgende Fehlermeldung:

[Fehler]
426 Upgrade Required
Um auf diese Seite zuzugreifen, müssen Sie die URL https://meine_nslu2:631/admin verwenden.
[/Fehler]

Anschließend meldet Mozilla einen Seiten-Ladefehler:

[Fehler]
Fehler: Server nicht gefunden
Der Server unter meine_nslu2 konnte nicht gefunden werden.
[/Fehler]

Auf der Drucker-Seite habe ich die Fehlermeldung

[Meldung]
hp990c (Standarddrucker) "Die Gerätdatei „/dev/lp0“ konnte nicht geöffnet werden: Permission denied"
[/Meldung]

lp0 hat alle Rechte per chmod 777 bekommen.

Auf der Lasche "Aufträge" stehen 2 Druckaufträge (Testseite drucken), im Spool-Verzeichnis sind auch entsprechende Daten zu finden.

Der Drucker ist über einen Hub gemeinsam mit der 250GB-Platte am Port 1 angeschlossen

Gruß

chralt

Beiträge: 88

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

4

20.04.2008, 14:05

  1. Creating the SSL certificates:
    • openssl req -new -x509 -keyout /opt/etc/cups/ssl/server.key -out /opt/etc/cups/ssl/server.crt -days 365 -nodes. You may have to use /opt/bin/openssl if openssl is not in the path.
    • You will be prompted for information to be placed in the certificate.
    • Restart cups [with /opt/etc/init.d/S88cups restart].
haste das auch gemacht???

das mit der testseite geht bei mir auch nicht wenn ich aber vom pc ein auftrag losschicke kommt er durch und es wird gedruckt

chralt

Schüler

  • »chralt« ist der Autor dieses Themas

Beiträge: 57

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

5

20.04.2008, 14:59

Hallo,

(jetzt) ja. :-)

hat aber leider nix geändert.

Was ich noch vergessen habe: ich kann auf den Rechnern im Netz auch keinen Drucker auf der slug finden!?

Auf der Kiste läuft auch natürlich auch samba, mit diversen Netzfreigaben.

Und noch was: lpc status gibt den Drucker als Parallelport-Gerät aus:

[Meldung]
root@neun_nlsu2:/>lpc status
hp990c:
printer is on device 'parallel' speed -1
queuing is enabled
printing is disabled
3 entries
daemon present
[/Meldung]

Wo stelle ich denn das um?

Gruß

Chralt

Beiträge: 88

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

6

20.04.2008, 20:14

printer is on device 'parallel' (das ist bei mir auch so das passt schon )

printing is disabled (dein drucker ist nicht gestartet schau da mal nach)

Was ich noch vergessen habe: ich kann auf den Rechnern im Netz auch keinen Drucker auf der slug finden!? (richte den drucker mal mauell ein ca so: https://"deine ip":631/printers/"drucker name")

und probiere es dann nochmal

hast du auch dein treiber für dein drucker installiert ??

chralt

Schüler

  • »chralt« ist der Autor dieses Themas

Beiträge: 57

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

7

22.04.2008, 20:36

Hallo,

ich glaube das ich den Drucker erst mal wieder an den PC hänge und von dort aus freigebe. :-(

Folgendes habe ich bisher noch gemacht: nach meinen bisherigen Versuchen habe ich mal so als "blöde Idee" versucht die Konfigurationseite unter Linux (Suse 10.3) aufzurufen - das gleiche wie bisher. Anschließend der gleiche Versuch die Seite unter Windows (XP) aufzurufen und siehe da es funktionierte - leider aber nur kurz. Mein Browser ist immer der Feuerfuchs, aktuell. Diverse Erweiterungen habe ich für die Versuche abgeschaltet (ich weiss nicht ob Javascript oder was auch immer benötigt wird)

Was ich während des kurzen Zeitraums des Funktionierens feststellen konnte war, das ich aus einer Anwendung heraus (StarOffice) einen Job auf den Drucker abschicken konnte, aber dort blieb er hängen, einen Ausdruck physischer Art bekam ich also nicht.

Nach ein paar Versuchen mit den diversen Unterseiten stürzte irgend etwas ab - und seit dem ist nix mehr: ich bekomme nur noch die Meldung "403 Forbidden" und das war's.

Auch eine Neuinstallation unter Verwendung von "force-reinstall" hat nichts gebracht, ein vorheriges deinstallieren ging nicht wegen Hinweisen auf andere installierte Programmpakete, u. a. Samba (Version 3.0.28-2).

Hier mal ein paar Daten meiner Installation:

Die die printers.conf:
# Printer configuration file for CUPS v1.1.23
# Written by cupsd on Thu Feb 3 01:11:29 2005
<DefaultPrinter hp990c>
Info HP990c
DeviceURI parallel:/dev/lp0
State Idle
Accepting Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
</Printer>

Es gibt eine cups.cond und eine cupsd.conf - beide sind identisch in Größe und Inhalt, und noch eine wesentlich kleinere cupsd.conf.default (diese wohl ohne Funktion, oder?)

Das Verzeichnis /opt/etc/cups/interfaces ist aktuell leer - ich weiss nicht ob das immer so war.

Im Verzeichnis /opt/etc/cups/ppd liegt die Treiberdatei deskjet.ppd (ich hab' 'nen Deskjet 920C).

So ich hoffe das ich jetzt alles wesentliche habe.

Wenn noch Ideen kommen, werde ich das noch mal versuchen, aber im Augenblick habe ich keine große Lust weitere Stunden ohne Aussicht auf Erfolg damit zu verbringen. Da versuche ich doch erst mal die hier liegende Soundkarte unter meinem Lieblings-BS zum Tönen zu bekommen.

Weitere sachdienliche Hinweise kann ich natürlich auch noch geben so diese denn hilfreich sein könnten.

Trotzdem bedanke ich mich natürlich bei Benbensimpson für die Hilfe die auch schon etwas weitergeholfen hat.

Mit freundlichen Grüßen
chralt

chralt

Schüler

  • »chralt« ist der Autor dieses Themas

Beiträge: 57

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

8

19.04.2009, 21:55

AW: CUPS läuft nicht

Hallo Zusammen,

ich bin immer noch mit meinem Versuch den Drucker (HP920C) über die SLUG zu betreiben »am kämpfen« - und zwar erfolglos. (und ich sehe gerade das mittlerweile fast ein Jahr vergangen ist seit meiner letzten Meldung)

Ich habe jetzt mal versucht alle notwendigen Informationen zusammen zu suchen und zu dokumentieren.

Die Installation habe ich anhand der hier im Forum - auch über Verknüpfungen - zu findenden Anleitungen durchgeführt, und _meine_ eigentlich alles beachtet, installiert, .... zu haben.

Unter diversen BS wird der/ein Drucker auf der SLUG erkannt, läßt sich aber wegen angeblich fehlenen Treibers nicht sauber ansprechen, die Fehlermeldung habe ich aber leider jetzt gerade nicht parat (unter OS/2 kommt nach dem Drucken die Meldung der Drucker sei nicht eingeschaltet bzw. offline)

Auf der SLUG läuft V2.3R63-uNSLUng-6.8-beta, samba - 3.0.28-2 -, und diverses anderes Zeugs. :-)

Der Drucker ist an einem 4-fach Hub (an Disk 1) angeschlossen, gemeinsam mit einer 250GB-Platte, an dem anderen USB-Port (Disk 2) hängt ein 1GB-Stick mit dem BS und den Programmen für die SLUG

Hier mal die Informationen von denen ich glaube das sie relevant sind, ich hoffe das nichts fehlt, sonst bitte nachfragen - Danke!

1.:
/unslung/smb.conf (Ausschnitte):
[global]
dos charset = CP850
workgroup = ARBEITSGRUPPE
server string = Netzwerkspeicher
interfaces = ixp0, lo, #, neu
guest account = guest
username map = /etc/samba/smbusers
max log size = 50
name resolve order = wins bcast
socket options = TCP_NODELAY SO_KEEPALIVE SO_SNDBUF=16384 SO_RCVBUF=16384
printcap name = /etc/printcap
os level = 65
preferred master = Yes
dns proxy = No
ldap ssl = no
config file = /unslung/smb.conf
create mask = 0755
force create mode = 0755
force directory mode = 0755
hosts allow = 127.0.0.1, 192.168.0.
hosts deny = 0.0.0.0/0
ea support = Yes
printing = cups
print command = lpr -P'%p' %s; rm %s
lppause command = lp -i '%p-%j' -H hold
lpresume command = lp -i '%p-%j' -H resume
queuepause command = disable '%p'
queueresume command = enable '%p'
case sensitive = No
store dos attributes = Yes

[printers]
comment = alle Drucker
path = /opt/var/spool/Samba
printable = Yes
print command = lpr -P %p -o raw %s -r
lpq command = lpstat -o %p
lprm command = cancel %j %p
use client driver = Yes
browseable = No

2.:
opt/etc/cups/printers.conf:

# Printer configuration file for CUPS v1.3.7
# Written by cupsd on 2008-12-22 16:51
<DefaultPrinter deskjet>
Info HP920C
Location Büro
DeviceURI parallel:/dev/lp0
State Idle
StateTime 1229961080
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy retry-job
</Printer>

/opt/etc/cups/ppd/deskjet.ppd ist vorhanden

Die Rechte von b/dev/lp0:
crwxrwxrwx 1 root root 180, 0 Apr 14 2007 lp0

Status des Druckers in CUPS:

Beschreibung: HP920C
Ort: Büro
Marke und Modell: HP DeskJet Series, 1.3
Druckerstatus: verarbeitend, Aufträge akzeptieren, publiziert.
Geräte URI: parallel:/dev/lp0

Das Starten des Testdrucks führt zu folgenden Meldungen:

deskjet (Standarddrucker) "Starting GPL Ghostscript 8.62..."
deskjet (Standarddrucker) "No pages found!"


Der anschließende Status des Druckauftrags ist folgender:

deskjet-87 Test Page anonymous 17k Unbekannt gestoppt um
novalue

Die Druckaufträge (Testdruck aus CUPS) landen auch im Spoolverzeichnis:
/opt/var/spool/cups

beim Neustart von CUPS fällt mir in der /op7/var/log/cups/error_log folgendes auf :

Unable to open listen listen socket for address :::631 - Address family not supported by protocol.
Listening to 0.0.0.0:631 on fd 0...
Resuming new connection processing...
Report: clients=0
Report: jobs=10
Report: jobs-active=3
Report: printers=1
Report: printers-implicit=0
Report: stringpool-string-count=413
Report: stringpool-alloc-bytes=7352
Report: stringpool-total-bytes=8208

Der Druckerstatus in CUPS istr nach Neustart von CUPS (/opt/etc/init.d/S88cups) folgender:

deskjet (Standarddrucker)

3.:
Installiert ist folgendes (für CUPS)
cups - 1.3.7-1 -
cups-doc - 1.3.7-1 -
cups-driver-gutenprint - 5.1.7-1 -
cups-locale-de - 1.3.7-1 -
ghostscript - 8.62-1 -
gutenprint - 5.1.7-1 -

4.:
dmesg sagt zum Drucker folgendes:

hub.c: new USB device 00:01.2-1.4, assigned address 7
Device descriptor:8 bytes received.
Device descriptor:18 bytes received.
printer.c: usblp0: USB Bidirectional printer dev 7 if 0 alt 0 proto 2 vid 0x03F0
pid 0x1504

Wobei »assigned address X« nach jedem neuen Einschalten des Druckers um »1« ansteigt.

So. wie oben geschrieben hoffe ich das ich alles wichtige aufgeführt habe und würde mich freuen wenn jemand eine Idee hat. Ich vermute mal das es sich - wie immer in solchen Fällen - nur um eine Kleinigkeit handelt.

Vielen Dank schon mal im Voraus

chralt.

Social Bookmarks