Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Nic

Anfänger

  • »Nic« ist der Autor dieses Themas

Beiträge: 20

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

1

Sonntag, 6. April 2008, 13:23

EXT3 Platte an Disk 1 mounten

Hallo,

ich habe folgende Konfiguration: Nslu2 mir Unslung auf Disk 2. Da diese Platte nun voll ist habe ich mir ne zweite Platte geholt und diese mit Gparted auf EXT3 formatiert und sie an Disk 1 angeschlossen. Nun würde ich die Platte gerne mounten. Aber irgendwie klappt das nicht:

Zitat


/ # /bin/mount /dev/sdb1 /share/hdd2
mount: Mounting /dev/sdb1 on /share/hdd2 failed: Invalid argument
Hat jemand nen Tip wie ich das hinbekomme? Auf meinem Laptop lässt sich die Platte tadellos mounten!

Danke für eure Hilfe

Nic


Die Suche schon benuzt?: ja

Anzeigen

Phantomias2006

Fortgeschrittener

Beiträge: 309

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

2

Sonntag, 6. April 2008, 13:38

Hi

also ich kann nur von meinen System reden aber wenn ich an Port1 eine Disk anschließe wird die automatisch gemountet (Siehst du normalerweise im WebPanel)
ansonst würde ich die Platte noch mal Formatieren aber im WebPanel (Administration/Advanced/Disk/Format Disk1)

Es sei denn ich verstehe deine Frage jetzt nicht richtig?!

mfg
Phantomias

Anzeigen

Nic

Anfänger

  • »Nic« ist der Autor dieses Themas

Beiträge: 20

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

3

Sonntag, 6. April 2008, 13:45

Im Webpanel wird die Platte als nicht formatiert angezeigt! Ich versuche jetzt mal übers Webpanel zu formatieren und melde mich nochmal!

Phantomias2006

Fortgeschrittener

Beiträge: 309

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

4

Sonntag, 6. April 2008, 13:50

Jep dacht ich mir...

Sag dann bescheid obs geht

mfg
Phantomias

Nic

Anfänger

  • »Nic« ist der Autor dieses Themas

Beiträge: 20

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

5

Sonntag, 6. April 2008, 14:33

So da bin ich wieder. Nachdem ich die Platte mit dem WI formattiert habe, wird die Platte jetzt zwar erkannt, nun habe ich aber drei Partitionen auf der Platte:

Zitat


/ # fdisk -l /dev/sdb

Disk /dev/sdb: 255 heads, 63 sectors, 60801 cylinders
Units = cylinders of 16065 * 512 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 1 60771 488143026 83 Linux
/dev/sdb2 60772 60786 120487+ 83 Linux
/dev/sdb3 60787 60801 120487+ 82 Linux swap
/ #



Ich möchte aber nur eine Datenpartition darauf haben! Wie bekomm ich das hin?

Gruß

Phantomias2006

Fortgeschrittener

Beiträge: 309

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

6

Sonntag, 6. April 2008, 14:45

Hattest du vorher nur eine Partition wie du sie unter Linux formatiert hast??

Also ich bin ja kein Linux Profi :-) aber ich würde sagen wenn er die Partitionen anlegt wird er sie auch brauchen?! (Hast du Disk 1 oder Disk 2 Formatiert?!
Für Unslung an Disk2 braucht er auf jeden Fall die Partitionen
ob er die bei Disk 1 auch braucht kann dir nur ein Linux Profi sagen...

mfg
Phantomias

Nic

Anfänger

  • »Nic« ist der Autor dieses Themas

Beiträge: 20

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

7

Sonntag, 6. April 2008, 14:54

Also ich denke nicht dass ich auf der Platte an Disk 1 zwingend drei Partionen brauch, warum er das so anlegt kann ich mir nicht erklären. Hätte auf jedenfall gerne nur eine Datenpartition.

Aber trotzdem danke für Deine Mühe!

Weiß vielleicht noch jemand ne Lösung für mein Problem?

Gruß

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

8

Sonntag, 6. April 2008, 15:17

Moin,

/share/hdd2 existiert? Korrekt wäre wohl /share/hdd/data, zumal dieses Verzeichnis existiert.

Ansonsten wäre es gut nicht mit der NSLU die neue/andere Platte zu formatieren, es werden einerseits 3 Partitionen angelegt (da führt kein Weg vorbei), und andererseits kommt die Konfiguration durcheinander...

Wie Du schon versucht hast, formatier die Platte irgendwo, und häng Sie manuell ein.

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Nic

Anfänger

  • »Nic« ist der Autor dieses Themas

Beiträge: 20

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

9

Sonntag, 6. April 2008, 15:20

Genau das hatte ich ja probiert. /share/hdd2 existiert natürlich und trotzdem bekomme ich beim Versuch die Platte manuell zu mounten oben beschrieben Fehler: Invalid argument.

Ich weiß nicht woran es hakt!!!

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

10

Sonntag, 6. April 2008, 19:27

N'Abend,
Zugriffrechte des mountenden Users auf das in Frage stehende Verzeichnis reichen aus?
Mal mounten mit der Option -t ext2 oder -t ext3 versucht?

Ansonsten versuche mal die Partition nach /mnt/tmpmnt zu hängen (das sollte existieren)...

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Nic

Anfänger

  • »Nic« ist der Autor dieses Themas

Beiträge: 20

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

11

Sonntag, 6. April 2008, 19:45

Zitat

/ # /bin/mount /dev/sdb1 /mnt/tmpmnt
mount: Mounting /dev/sdb1 on /mnt/tmpmnt failed: Invalid argument


Zitat

/ # /bin/mount -t ext3 /dev/sdb1 /mnt/tmpmnt
mount: Mounting /dev/sdb1 on /mnt/tmpmnt failed: Invalid argument


Funktioniert auch beides nicht. In der Zwischenzeit hab ich mal FAT32 ausprobiert. Damit geht es tadellos, allerdings nützt mir FAT nicht viel, da nur max 4GB-Files unterstützt werden. Kumpel von mir hat das genauso am laufen, dann muss das doch bei mir auch gehen.

Hab hier noch nen Auszug aus Dmesg falls es was nützt:

Zitat


ufsd: failed to mount sd(8,17)
I/O error: dev 08:11, sector 1
out of order segment: rcv_**** B8C6E344 seq B8C6E36C - B8C6E372
ofo requeuing : rcv_**** B8C6E36C seq B8C6E36C - B8C6E372
prune_queue: c=4f1a2e84
prune_queue: c=b3cf4dd9
out of order segment: rcv_**** B8F486BF seq B8F486F8 - B8F48700
ofo requeuing : rcv_**** B8F486F8 seq B8F486F8 - B8F48700
attempt to access beyond end of device
08:11: rw=0, want=2, limit=1
EXT3-fs: unable to read superblock
attempt to access beyond end of device
08:11: rw=0, want=2, limit=1
EXT2-fs: unable to read superblock
FAT: bogus logical sector size 0
VFS: Can't find a valid FAT filesystem on dev 08:11.
jffs2: attempt to mount non-MTD device 08:11
attempt to access beyond end of device

Nic

Anfänger

  • »Nic« ist der Autor dieses Themas

Beiträge: 20

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

12

Montag, 7. April 2008, 10:18

Ich habs hinbekommen! Der Fehler war dass ich die Systemrescuedisk (Gparted) zum erstellen der Partition benutzt habe. Irgendwie scheint die CD Mist zu bauen. Hab nun mal Knoppix genommen, und siehe da die platte wird erkannt!

Social Bookmarks