Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

chriwi

Schüler

  • »chriwi« ist der Autor dieses Themas

Beiträge: 127

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Unslung 6.10

Wohnort: Stuttgart Deutschland

Beruf: IT-Ingenieur

  • Nachricht senden

1

Mittwoch, 27. Februar 2008, 20:26

init mit 94%CPU-Last bei top, system langsam

Hallo,

ich habe einen Unslung5 Slug auf dem ein selbst zusammengebastelter LAMP und noch einige weitere Services laufen, er lief zuletzt stabiel uber 200 Tage ohne Probleme und viel dann einem Stromausfall zum Opfer, danach lies er sich problemlos wieder hochfahre und schien problemlos weiter zu laufen, nach 9 Tagen wurde er aber sehr langsam und als ich top aufgerufen habe sah ich das init kontinuierlich 94% der Prozessorlast erzeugt, ausserdem zeigte ps -A eine groessere Anzahl an Zombiprozessen von dnsmasq mit <defunct> an, dnsmasq wird bei mir vom Crondaemon immer dann neu gestartet wenn der Router eine neue externe IP-Adresse bekommtv und spielt dann ueber ein Portforwarding Namserver fuer das externe Internet (fragt nicht wie aber es Funktioniert (wens interessiert kann dei genaue Beschreibung auch hier im Forum finden)).
Wie Kommt es zu der hohen Prozessorlast durch init und die vielen Zombie-dnsmasq?
Wie kann ich das verhindern.
Nach einem Neustart ist die init CPU-Last wieder unter 1%.




was hast Du bereits probiert?: nach init, top und %CPU gesucht und nach cron und Zombie

Die Suche schon benuzt?: nein

Art der Firmware: Unslung5

wird ein externer Datenträger genutzt, wenn ja, was für eine Art: 250GB IDE mit USB2.0-Enclosure
tschüs

chriwi

NSLU2 unslung5.x
running NFS, xmail, mysql, mc, apache, popper (webmailer), PHPmyadmin, brim, Kplaylist, PunBB, WBBlite, Ajaxterm, AjaXplorer, Mediatomb

Anzeigen

Social Bookmarks