Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Hawk026

Anfänger

  • »Hawk026« ist der Autor dieses Themas

Beiträge: 20

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

1

23.09.2007, 17:48

plötzlich kein connect mehr per putty ?

Hi,

komme seit heute nicht mehr auf die NSLU2 per putty...
Ging immer nun wollte ich die nslu neu starten und siehe da es kommt jedesmal die meldung "network error connection refused". Das ist mal echt schlecht da ich sie nun nichtmehr auf 10Mbit stellen kann für die dboxen und somit aufnahmen nichtmehr möglich sind. Per SMB komme ich ganz normal drauf genauso per Dbox allerdings bringt das alles nix....
Ist unslung 6.8 drauf
cu

Anzeigen

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

2

23.09.2007, 17:53

Tach,

Putty -> Telnet, oder Putty -> SSH?
Wenn Ersteres, Telnet auch im WebIF aktiviert?
Bei letzterem, aktiviere Telnet (WebIF) log Dich ein, und kontrolliere ob Dein SSH Server läuft (ps -ef|more und suche nach sshd oder dropbear).

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Anzeigen

Hawk026

Anfänger

  • »Hawk026« ist der Autor dieses Themas

Beiträge: 20

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

3

23.09.2007, 18:03

Hi,

also ist Putty -> SSH Port 22.
Seitdem Unslung drauf ist komme ich generell nur noch mit putty und ssh auf die kiste. Mit telnet geht seitdem nichtmehr da ich telnet seit unslung nicht mehr aktiviert bekomme im WebI. Gehe ich auf den admin Bereich akzeptiert er kein Password mehr. Habe unter ssh "root + nslu". Beim admin Bereich habe ich schon alle möglichen versucht:
admin + admin
admin + nslu
admin + nslu2
root
root + nslu
root + nslu2
etc...
Habe damals auch mal irgendwo gelesen das man in den admin bereich nichtmehr kommt wenn unslung drauf ist ?!?!

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

4

23.09.2007, 18:10

Tach,

Wie klappt es mit der Telnet AKtivierung, wenn Du ohne Festplatte startest?
Wenn das geht, solltest Du Dir die entsprechenden Logfiles anschauen, ob irgendwas nach sshd Fehlern aussieht (sshd logt nach Syslog, also mußt Du die Platte stecken, und nach etwas Wartezeit nach /share/hdd/data/var/log/messages, oder /share/hdd/data/opt/var/log/messages schauen [ggfs. hdd durch flash ersetzen]).

bye
JrB
"Supporting joe users worldwide" <- that's our motto


innovonet

Schüler

Beiträge: 157

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Unslung 6.10

Wohnort: Giessen

Beruf: Dipl.-Ing.Elektro

  • Nachricht senden

5

23.09.2007, 18:12

Hallo, Telnet sollte auch noch mit unslung gehen. U.U. gibt es aber Szenarien, die das verhindern.
Verwendest Du mehrere nslu2-formatierte Datenträger? Kannst Du dich noch nach Start vom Flash (ohne Platten) per Web einloggen?
Einloggen als Root im Web-If. ist normalerweise nicht möglich.
Gruß, Thomas
V2.3R63-uNSLUng-6.10-beta, WD TV Live, Noxon. Zeitweilig mal Soundbridge, FSG3, Intradisk, Showcenter 200.

Hawk026

Anfänger

  • »Hawk026« ist der Autor dieses Themas

Beiträge: 20

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

6

24.09.2007, 07:30

Hi
vielen Dank für eure Antworten, also ohne Platte starten (Platte ist an Port2 - flash) klappt. Dann kann ich im WebI Telnet mit "admin - admin" aktivieren. Stecke ich dann die Platte an und warte nen moment finde ich unter /share/flash/data/var/log zwar ein paar log files aber nix was mit ssh zutun hat.
Folgende Files liegen im Ordner:

-DEFHOSTNAME
-bftpd.log
-messages
-messages.old
-samba
-serverlog
-wtmp

Da ich hier nix finde was ssh angeht, kann ich ssh irgendwie manuell wieder aktivieren ?
Ansonsten habe ich nur eine Platte an Port2.
Aber wie gesagt das einloggen mit unslung im WebI klappt einfach nicht, nur wenn er aus dem flash startet.

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

7

24.09.2007, 21:10

N'Abend,

Du kannst kontrollieren, ob /share/flash/data/opt/etc/init.d/S40sshd vorhanden ist, und die Dateirechte 755 besitzt (Startscript für SSH). Und ggfs. mal den Inhalt von /share/flash/data/etc/inetd.conf posten, bzw. mit /etc/inetd.conf vergleichen.

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Hawk026

Anfänger

  • »Hawk026« ist der Autor dieses Themas

Beiträge: 20

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

8

25.09.2007, 11:33

Hi,

also die /share/flash/data/etc/inetd.conf hat folgenden inhalt:

ftp stream tcp nowait root /usr/sbin/bftpd

die inetd.conf im Verzeichnis /etc sieht dagegen so aus:

ftp stream tcp nowait root /usr/sbin/bftpd
telnet stream tcp nowait root /usr/sbin/telnetd

Und die S40sshd ist vorhanden hat auch die Rechte 755 und sieht so aus:

#!/bin/sh

if [ -f /opt/var/run/sshd.pid ] ; then
kill `cat /opt/var/run/sshd.pid`
else
killall sshd
fi

rm -f /opt/var/run/sshd.pid

umask 077

/opt/sbin/sshd

Vielleicht kannst du damit ja was anfangen, schonmal vielen dank !!!!
Gruss

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

9

25.09.2007, 18:02

Tach,
sieht erstmal gut aus...
Hm, so eine Idee - Du hast nicht zufällig xinetd auf Deiner NSLU installiert? Existiert /share/flash/data/opt/etc/init.d/S10xinetd?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Hawk026

Anfänger

  • »Hawk026« ist der Autor dieses Themas

Beiträge: 20

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

10

25.09.2007, 20:56

Hi,

nein habe ich nicht...
Hat sich aber gerade erledigt habe noch ne andere 250GB Platte leergeräumt und die neu mit unslung gemacht. Die alte Platte hängt jetzt mir 2. dran bis ich die leer geräumt habe...
Trotzdem vielen dank für deine Bemühungen !
Gruss
Marc

Social Bookmarks