Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

reini

Anfänger

  • »reini« ist der Autor dieses Themas

Beiträge: 8

Wohnort: Hörsching (A)

  • Nachricht senden

1

Sonntag, 26. August 2007, 23:50

Zwei HD am USB-Hub

Hallo.

:confused: Kann ich das mit einem Script lösen oder geht das einfacher?

IST-Zustand:
Unslung V2.3R63-uNSLUng-6.8-beta
USB-Stick an 'Disk 2' - USB-Hub an 'Disk 1' - 2 HDs am USB-Hub

** Teil 1 ********************************
Nach dem Anschluss einer weiteren formatierten HD über den USB-Hub
habe ich über das NSLU2 WebIF einen neuen User admin_2 angelegt.

Dann /share/hd2/data anlegen und passend konfigurieren:
mkdir -p /share/hd2/data
chmod 755 /share/hd2
chmod 755 /share/hd2/data
chown admin /share/hd2
chown admin /share/hd2/data


** Teil 2 ********************************
Die zusätzliche HD nun anhängen (ist bei mir sdc):
mount /dev/sdc1 /share/hd2/data

Nun muss ich noch die /etc/samba/smb.conf erweitern:
...
[admin_2]
valid users=@"administrators"
comment=
path=/share/hd2/data/
read only=yes
write list=@"administrators"


Ab jetzt kann ich z.B. unter Windows mit:
NET USE v: "\\10.0.2.16\admin_2" passwort /USER:admin
das Laufwerk verbinden.

*****************************************
Funktioniert perfekt.

ABER: Nach einem Neustart fehlt das 'mount' und in der smb.conf ist die Erweiterung um den erforderlichen 'admin_2' auch weg.
Und wenn 'mount' in der 'fstab' eingetragen wird, ist der Eintrag nach einem Neustart wauch ieder weg.

Mit der vorigen Anleitung ab ** Teil 2 ** kann ich alles händisch wieder herstellen, ABER automatisch wäre das besser.

Kann ich das mit einem Script lösen oder geht das einfacher?:confused:



was hast Du bereits probiert?: suchen, suchen , such...

Die Suche schon benuzt?: ja

Anzeigen

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

2

Sonntag, 26. August 2007, 23:59

N'Abend,

was Du gerne automagisch erledigt haben möchtest, sind Dinge die von /usr/sbin/USB_Detect erledigt werden, und das ist leider ein Linksys Binary, und entsprechend dem weiß niemand was das Teil so macht....
Die einfachste Lösung wäre wohl ein Umstieg auf Debainslug um die verschiedenen Hotplug Mechanismen zu nutzen.

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Anzeigen

reini

Anfänger

  • »reini« ist der Autor dieses Themas

Beiträge: 8

Wohnort: Hörsching (A)

  • Nachricht senden

3

Montag, 27. August 2007, 00:08

@caplink811

Zitat

... Umstieg auf Debainslug um die verschiedenen Hotplug Mechanismen zu nutzen.
Danke für die Info. Mal schau'n.

Social Bookmarks