Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »Benbensimpson« ist der Autor dieses Themas

Beiträge: 88

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

1

Sonntag, 12. August 2007, 20:29

habe ein Problem mit einer config

so hab mir mal das hier http://forum.mindfactory.de/322374-post19.html installiert bekomme beim starten immer die Antwort

Required config entry 'mp3_dir' Not specified
Error reading config File (/opt/etc/mt-daapd/mt-daapd.conf)


und hier meine config


#
# Location of the admin web pages. If you installed from
# ipk, this is correct
#

web_root /opt/share/mt-daapd/admin-root

#
# Port (required)
#
# What Port to listen on. It is possible to use a different
# Port, but this is the default iTunes Port
#

Port 4000

#
# admin_pw (required)
#
# This is the Password to the administrative pages
#
# YOU SHOULD PROBABLY CHANGE THIS
#

admin_pw ******
#
# db_dir (required)
#
# This is where mt-daapd stores its Database of Song Information.
#
# If you installed this from .ipk, this is correct
#

db_dir /opt/var/mt-daapd

#
# mp3_dir (required)
#
# Location of the mp3 Files to share. This corresponds
# to a folder called "mp3" in the "DISK 1" share.
#

#mp3_dir /share/flash/data/steam/dbox






habe hier bei db_dir /opt/var/mt-daapd
auch schon mal /opt/etc/mt-daapd eingegeben
aber der Fehler bleibt

kann mir evtl jemand von euch experten sagen was da wieder mal falsch ist

bekomme bei der ip abfrage immer ne zeitüberschreitung


was hast Du bereits probiert?: google boardsuch

Die Suche schon benuzt?: ja

Art der Firmware: unslung 6.8

wird ein externer Datenträger genutzt, wenn ja, was für eine Art: maxtor 320gb an port 2

Anzeigen

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

2

Sonntag, 12. August 2007, 21:44

N'Abend,

Zitat von »Benbensimpson;26366«


#
# mp3_dir (required)
#
# Location of the mp3 Files to share. This corresponds
# to a folder called "mp3" in the "DISK 1" share.
#
#mp3_dir /share/flash/data/steam/dbox


a. steht die Lösung in der Fehlermeldung, und b. wäre es wohl recommend das Kommentarzeichen vor der mp3_dir Zeile zu entfernen, und den Pfad anzupassen.

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Anzeigen
  • »Benbensimpson« ist der Autor dieses Themas

Beiträge: 88

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

3

Sonntag, 12. August 2007, 22:49

Zitat von »caplink811;26368«

N'Abend,



a. steht die Lösung in der Fehlermeldung, und b. wäre es wohl recommend das Kommentarzeichen vor der mp3_dir Zeile zu entfernen, und den Pfad anzupassen.

bye
JrB




ok punkt 1 ist klar das # weg und dann pass das aber die config pfad angabe past ja laut meldung auch nicht

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

4

Sonntag, 12. August 2007, 22:54

N'Abend,

ich kann aktuell nicht folgen...

Zitat:
Required config entry 'mp3_dir' Not specified
Error reading config File (/opt/etc/mt-daapd/mt-daapd.conf)

meint, der benötigte Eintrag "mp3_dir" kann nicht gefunden werden, und zwar beim lesen (mit Fehlern) der Datei /opt/etc/mt-daapd/mt-daapd.conf....
Wenn Du also das Kommentarzeichen entfernt, und ggfs. die Pfadangabe angepasst hast, sollte es funktionieren.

bye
JrB
"Supporting joe users worldwide" <- that's our motto


  • »Benbensimpson« ist der Autor dieses Themas

Beiträge: 88

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

5

Sonntag, 12. August 2007, 23:00

Zitat von »caplink811;26376«

N'Abend,

ich kann aktuell nicht folgen...

Zitat:
Required config entry 'mp3_dir' Not specified
Error reading config File (/opt/etc/mt-daapd/mt-daapd.conf)

meint, der benötigte Eintrag "mp3_dir" kann nicht gefunden werden, und zwar beim lesen (mit Fehlern) der Datei /opt/etc/mt-daapd/mt-daapd.conf....
Wenn Du also das Kommentarzeichen entfernt, und ggfs. die Pfadangabe angepasst hast, sollte es funktionieren.

bye
JrB

ok werde das mal probieren aber nur weil die mp3 angaben nicht richtig ist kann ich die ganze
oberflache nicht starten



so mal angepasst

jetzt bekomme ich immer die meldung

# ./S60mt-daapd
Required config entry 'servername' not specified
Error reading config file (/opt/etc/mt-daapd/mt-daapd.conf)

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

6

Sonntag, 12. August 2007, 23:18

N'Abend,

weiß nicht, hab's aber auch nicht programmiert...

bye
JrB
"Supporting joe users worldwide" <- that's our motto


  • »Benbensimpson« ist der Autor dieses Themas

Beiträge: 88

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

7

Sonntag, 12. August 2007, 23:20

Zitat von »caplink811;26380«

N'Abend,

weiß nicht, hab's aber auch nicht programmiert...

bye
JrB



ok aber trozdem danke

innovonet

Schüler

Beiträge: 157

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Unslung 6.10

Wohnort: Giessen

Beruf: Dipl.-Ing.Elektro

  • Nachricht senden

8

Montag, 13. August 2007, 15:01

Hallo miteinander,
zum MT-Daapd / Firefly:
  1. Läuft offenbar nicht, wenn #db_dir... nicht auskommentiert ist! Sqlite versucht dann, eine Datenbank unter /var/cache... anzulegen.
  2. mp3_dir muss ein existierender Pfad sein!
  3. ggf. Kommentar bei logfile entfernen und loglevel ändern für nähere Infos
Wenn 1. und 2. nicht passen startet Firefly / Weboberfläche nicht.
Du hast doch eine firefly.conf unter /etc/ipkg vor "ipkg install mt-daapd" angelegt oder manuell installiert?
Ansonsten wird die alte mt-daapd Version installiert.
Gruß, Thomas
V2.3R63-uNSLUng-6.10-beta, WD TV Live, Noxon. Zeitweilig mal Soundbridge, FSG3, Intradisk, Showcenter 200.

  • »Benbensimpson« ist der Autor dieses Themas

Beiträge: 88

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

9

Donnerstag, 16. August 2007, 10:47

Danke an alle

Jetzt läuft es, es musste nur der Servername eingetragen werden und das mp3 Verzeichnis passte nicht

Social Bookmarks