Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

06.01.2007, 17:56

NFS Installation auf NSLU2 für dBox-Stream

Hallo Gemeinde,

ich möchte von der dBox auf die Platte an der NSLU2 Filme aufnehmen und wiedergeben. Bisher habe ich das mit dem PC via "Jack The Grabber" getan. Ich bin "fortgeschrittener Windows-User", habe aber keinen Schimmer von Linux & CO. Für das Flashen der dBox und der NSLU2 hat es aber dank der Foren und HowTo's gereicht. Jetzt bin ich aber am Ende und am Verzweifeln. Ich bekomme einfach nicht den NFS-Server zum Laufen. Die NSLU2 läuft mit Firmware V2.3R63-uNSLUng-6.8-beta, FTP- & Webserver funktionieren aber ich schaffe es einfach nicht mit der dBox Verzeichnisse zu mounten.

Meine Fragen:

1. Ich habe mehrere HowTo's "probiert", gibt es Unterschiede der jeweiligen Firmwareversionen zu beachten? Ich bräuchte halt eine idiotensichere Anleitung für V2.3R63-uNSLUng-6.8-beta

2. Wie kann ich testen, ob die Installation von "nfs-utils" erfolgreich war, gibt es sowas wie einen ping? Ich möchte irgendwie den Fehler lokalisieren.

3. Ich habe jetzt schon soviel experimentiert (vielleicht auch kaputtexperimentiert), wie kann ich die NSLU2 auf "Werkseinstellung" zurücksetzen?

4. Ich habe gern mal bei www.wiki.tuxbox.org reingeschaut. Weiß jemand, warum oder wielange die Seite offline ist?

Ihr braucht sicherlich mehr Infos von der NSLU2. Ich weß nur nicht, was für den Profi für die Diagnose wichtig ist. Bitte die Befehle mitposten.


Gruß und Dank

Anzeigen

ToMa

Fortgeschrittener

Beiträge: 253

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Ostwestfalen

Beruf: FISI

  • Nachricht senden

2

06.01.2007, 18:37

Hallo,

zu 1: Ich denke die ist eigentlich ausreichend und sollte im großen und ganzen ok sein:
http://wiki.nslu2-info.de/pmwiki.php/HowTo/StreamDbox2

zu 2: Läuft denn der nfs Server?
Was sagt folgender Befehl?
ps -ax
Taucht der nfs Server da auf?

zu 3: Falls das wirklich sein muss (was ich bezweifel) kannst Du komplett neu flashen.

zu 4: Ich hoffe sie ist bald wieder online, aber ich weiss es nicht.

Poste mal den Inhalt Deiner exports, passwd und profile Datei.
(alle in opt/etc)

Welche Berechtigung hat die exports, passwd und profile Datei?
ls -la /opt/etc/

Wie mountest Du auf der dbox2?


ToMa

Anzeigen

3

06.01.2007, 19:39

Hallo ToMa,

vielen Dank für die schnelle Antwort. Hier die Daten:

ps -ax:

Welcome to Unslung V2.3R63-uNSLUng-6.8-beta

---------- NOTE: THIS SYSTEM IS CURRENTLY UNSLUNG ----------


BusyBox v0.60.4 (2005.03.22-06:52+0000) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

# ps -ax
PID TTY Uid Size State Command
1 root 1212 S /bin/init
2 root 0 S [keventd]
3 root 0 S [ksoftirqd_CPU0]
4 root 0 S [kswapd]
5 root 0 S [bdflush]
6 root 0 S [kupdated]
7 root 0 S [mtdblockd]
8 root 0 S [khubd]
9 root 0 S [jffs2_gcd_mtd4]
10 root 0 S [usb-storage-0]
11 root 0 S [scsi_eh_0]
13 root 0 S [sd-mc-thread]
27 root 0 S [kjournald]
50 root 0 D [ixp425_csr]
51 root 0 S [ixp425 ixp0]
54 ttyS0 root 1916 S /bin/sh
55 root 1936 S /sbin/syslogd -n
56 root 1924 S /sbin/klogd -n
151 root 0 S [kjournald]
213 root 9904 S upnpd &>/dev/null
223 root 9904 S upnpd &>/dev/null
224 root 9904 S upnpd &>/dev/null
228 root 9904 S upnpd &>/dev/null
229 root 9904 S upnpd &>/dev/null
325 root 2140 S /usr/sbin/thttpd -C /etc/thttpd.conf
349 root 6152 S /usr/sbin/smbd -D
351 root 6152 S /usr/sbin/smbd -D
352 root 4812 S /usr/sbin/nmbd -D
377 root 1952 S /usr/sbin/QuickSet
381 root 1904 S /usr/sbin/USB_Detect
385 root 1900 S /usr/sbin/USB_Detect
391 root 1884 S /usr/sbin/onetouch_detect
392 root 1884 S /usr/sbin/onetouch_detect
406 root 1216 S /usr/sbin/crond
412 root 1928 S /usr/sbin/CheckResetButton
414 root 1196 S /usr/sbin/CheckPowerButton
416 root 1196 S /usr/sbin/do_umount
460 bin 1224 S /opt/sbin/portmap
475 root 1448 S /opt/sbin/statd
478 root 0 S [nfsd]
480 root 0 S [lockd]
481 root 0 S [rpciod]
482 root 1492 S /opt/sbin/mountd
500 root 2140 S /usr/sbin/thttpd -C /etc/thttpd.conf
514 root 1276 S /bin/inetd
515 root 9904 S upnpd &>/dev/null
517 root 1256 S /usr/sbin/telnetd
518 ttyp0 root 1928 S -sh
519 ttyp0 root 1984 R ps -ax
#

/etc/passwdroot:Kx7JCTfwGEVBY:0:0:root:/root:/bin/sh
bin:x:1:1:bin:/bin:
lp:x:4:7:lp:/share/spool:
mail:x:8:12:mail:/var/spool/mail:
ftp:x:14:50:FTP User:/:
nobody:x:99:99:Nobody:/:
ourtelnetrescueuser:sPuRQwXaya5YE:100:100::/home/user:/bin/sh
guest:xqnMpE/plEnFs:501:501::/home/user/guest:/dev/null
admin:cgwvsHpJSf6XU:502:501::/home/user/admin:/dev/null

dbox:sc0MOzD8dVGa6:2000:501::/share/hdd/data/dbox:/dev/null
webserver:sc0MOzD8dVGa6:2001:501::sc3B6pVbVCgxc:/dev/null

/etc/exports

/share/hdd/data 192.168.0.0/255.255.0.0(rw,sync,no_root_squash)
/share/hdd/conf 192.168.0.0/255.255.0.0(ro,sync,no_root_squash)
/share/flash/data 192.168.0.0/255.255.0.0(rw,sync,no_root_squash)
/share/flash/conf 192.168.0.0/255.255.0.0(ro,sync,no_root_squash)
/share/hdd/data/dbox 192.168.1.24<rw,no_root_squash,anonuid=0,anongid=0)

/etc/profile

PATH=/opt/bin:/opt/sbin:${PATH}

ls -la /opt/etc/

drwxr-xr-x 5 root root 4096 Dec 16 01:25 .
drwxr-xr-x 14 root root 4096 Jan 6 18:33 ..
drwxr-xr-x 3 root root 4096 Dec 2 00:01 apache2
-rw-r--r-- 1 root root 338 Jan 6 16:24 exports
drwxr-xr-x 2 root root 4096 Jan 6 16:52 init.d
drwxr-xr-x 2 root root 4096 Jan 6 18:33 php.d
-rw-r--r-- 1 root root 38759 Dec 2 00:01 php.ini

dBox

Typ NFS
Server IP 192.168.1.77
Verzeichnis/Freigabe /share/hdd/data/dbox
lokales Verzeichnis /mnt/movies
Beim Start mounten Ja
Mount-Optionen rw,soft,udp
Mount-Optionen nolock,rsize=8192,wsize=8192
Benutzername admin
Passwort
Mac Adresse 11:22:33:44:55:66

Was mir noch so einfällt:
- User "dbox" mit Heimverzeichnis angelegt
- die Platte ist im Netzwerk vorhanden und beschreibbar
- achso, auf den Ordner share/hdd/data/ habe ich im Netzwerk keinen Zugriff. Vielleicht hat das noch Bedeutung


Gruß & Dank

ToMa

Fortgeschrittener

Beiträge: 253

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Ostwestfalen

Beruf: FISI

  • Nachricht senden

4

06.01.2007, 20:22

Hallo,


also in der exports ist auf jeden Fall schon mal nen < statt ner ( eingebaut !
Leerzeichen entfernen am Ende der Zeile vor der Klammer(zu).
Die anongid und anonuid ist auch nicht korrekt.
Die sollten so sein:
anongid=501,anonuid=2000
Beim mounten auf der dbox musst Du dann auch den richtigen Benutzer (dbox) eintragen und das Passwort was der Benutzer dbox hat, anstatt admin.
Ausserdem zum Abspielen und Aufnehmen einen eigenen Mountpoint, siehe Wiki.
Probier erstmal, aber an den Einstellungen 8192 beim mounten muss auch noch was gemacht werden.

(Siehe Wiki -> mii-diag)


ToMa

5

07.01.2007, 02:33

Sämtliche Änderungen haben nichts gebracht. Letztendlich habe ich von vorn angefangen. Das Verzeichnis dbox/movie konnte ich nun auch mounten und die Aufnahme funktioniert einwand- und ruckelfrei. Jetzt wollte ich noch das Verzeichnis dbox/music für MP3-Wiedergabe mounten, das funktionierte allerdings nicht. Nun ja, Die Aufnahme war mir wichtig und die funktioniert. Wenn jemand eine Idee hat, nur zu. Ansonsten will ich es dabei belassen, hatte schon 180 Puls :).

Eine Frage habe ich noch. Bei der dBox gibt es die Option "Vorlage für Dateinamen". Hier ist standardmäßig "%c_%i_%d_%t" eingtragen. Was bedeuten die Angaben und wie kann ich z.B. EPG-Informationen hier einbinden, damit bei den Aufnahmen der Filmtitel, Sender, Datum o.Ä. erscheint. Jetzt heißen die Aufnahmen z.B. "%c_%i_2007-01-07_014501.001.ts".


Gruß & Dank für die schnelle Hilfe

ToMa

Fortgeschrittener

Beiträge: 253

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Ostwestfalen

Beruf: FISI

  • Nachricht senden

6

07.01.2007, 11:29

Guten Morgen,

%T ist für den Titel
%C ist für den Kanal
%d ist für das Datum
%t ist für die Zeit

Also könntest Du %T_%C_%d verwenden.

Groß/Kleinschrift beachten.

ToMa

7

07.01.2007, 12:58

Hallo ToMa,

danke für die Info. Als ich die Angaben korrigieren wollte, habe ich im Menü der dBox die Legende hierfür auch entdeckt. "Wer lesen kann ist mächtig".

Jetzt wollte ich dieses Thema als (gelöst) kennzeichnen, hat aber nicht geklappt. Rechts neben "NFS Installation auf NSLU2 für dBox-Stream" doppelklicken funktioniert nicht. Weder im Firefox noch im IE.


Gruß & Dank

ToMa

Fortgeschrittener

Beiträge: 253

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Ostwestfalen

Beruf: FISI

  • Nachricht senden

8

07.01.2007, 13:07

Zitat von »dBoxer;21678«


Jetzt wollte ich dieses Thema als (gelöst) kennzeichnen, hat aber nicht geklappt. Rechts neben "NFS Installation auf NSLU2 für dBox-Stream" doppelklicken funktioniert nicht. Weder im Firefox noch im IE.


Irgendwo im Wiki dieses Forums findest Du folgendes:

Um die Übersichtlichkeit im Forum zu verbessern, bitten wir Euch darum gelöste Themen wie folgt zu kennzeichnen. Nachdem ein Thema erledigt ist, geht Ihr in das entsprechende Forum und sucht den Beitrag heraus. Anschließend klickt Ihr einfach in den Titel des Beitrages und schreibt (gelöst) davor.

ToMa

9

07.01.2007, 14:49

jetzt hat es geklappt. Ich glaube, ich war einfach nicht eingeloggt.

Social Bookmarks