Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

jaluanda

Anfänger

  • »jaluanda« ist der Autor dieses Themas

Beiträge: 21

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

1

Donnerstag, 14. Dezember 2006, 17:49

(Netzwerk-) Drucker möglich an der Slug?

Hallo,

2 Fragen an alle:

1. hat jemand schon einen Drucker an Port 1 als Netzwerkdrucker erfolgreich installieren können? Habe die Aufgabe, einen HP Laserjet 2300 für 5 Windows XP-Clients als Netzwerkdrucker bereitzustellen. Geht das überhaupt? Gibt es dafür brauchbare (deutschsprachige) Anleitungen?

2. Kann ich den Drucker auch mittels USB-Hub mit einer weiteren Festplatte (evtl. EXT3) am Port 1 betreiben?


Danke schon mal für Antworten und Links.

Andreas

Anzeigen

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

2

Donnerstag, 14. Dezember 2006, 20:59

N'Abend,

Du möchtest CUPS als Schlagwort für die Forumssuchfunktion verwenden.

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Anzeigen

jaluanda

Anfänger

  • »jaluanda« ist der Autor dieses Themas

Beiträge: 21

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

3

Freitag, 15. Dezember 2006, 17:30

Hallo,

habe ich schon gemacht, jedoch mit mäßigem Erfolg.
Siehe http://www.nslu2-info.de/showthread.php?…&highlight=cups oder http://www.nslu2-info.de/showthread.php?…&highlight=cups oder http://www.nslu2-info.de/showthread.php?…&highlight=cups.
Nach http://www.nslu2-linux.org/wiki/HowTo/AddPrinter habe ich die Sache als erstes einrichten wollen.

Keines der Threads konnte mit helfen. Habe folegendes gemacht:

ipkg install cups

ipkg install cups-doc

ipkg install cups-doc-de

touch /opt/etc/cups/ssl/server.key

touch /opt/etc/cups/ssl/server.crt

ipkg install openssl

/opt/bin/openssl req -new -x509 -keyout /opt/etc/cups/ssl/server.key -out /opt/etc/cups/ssl/server.crt -days 365 -nodes

Die Fragen bin ich dann mit Enter durchgegangen.
Dann im Brwoser http://192.168.2.77:631 aufgerufen - Ergebnis
403 Forbidden

Dann den langen Befehl noch mal aufgerufen, die Fragen anders beantwort. Browser - das gleiche Ergebnis.

Ich bekomme also keinen Zugriff auf das Webinterface. Was kann ich machen? Auch mit https://192.168.2.77:631 habe ich keinen Erfolg, obwohl zumindest die Mitteilung mit dem Zertifikat kommt, die ich mit Ja bestätige.

Mit dem Befehl /opt/bin/openssl req -new -x509 -keyout /opt/etc/cups/ssl/server.key -out /opt/etc/cups/ssl/server.crt -days 365 -nodes wird wohl ein Zertifikat erstellt, oder?

Muss ich noch irgendwelche conf-Dateien ändern oder so? Als Webserver hatte ich vorher schon mal apache installiert. Macht der evtl. Probleme?

Gruß
Andreas

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

4

Freitag, 15. Dezember 2006, 18:32

N'Abend,

in der Datei /opt/etc/cups/cupsd.conf ist an 2 Stellen die verwendete Netzwerk Adresse anzupassen (Allow from Bla)...

bye
JrB
"Supporting joe users worldwide" <- that's our motto


jaluanda

Anfänger

  • »jaluanda« ist der Autor dieses Themas

Beiträge: 21

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

5

Montag, 18. Dezember 2006, 15:25

Hi,

danke. Hatte ich denn durch probieren auch rausbekommen - läuft auch gut. Hatte mit ein Zertifikat erstellt, das ich auch brauche, um einen Drucker einzurichten.

Das klappt auch - sogar mit ppd-Datei. Er (hp2300) steht dann als eingerichtet im Cups-UI. Auch in WinXP habe ich ihn als http://192.168.2.77/printers/hp2300, wird dort als bereit dargestellt, ein Druckauftrag wird auch weggeschickt. Im CUPS-UI steht er dann als Fehler. Habe in der printers.conf den DeviceURI auf parallel:/dev/lp0 gestellt - leider ohne Erfolg. Welche Attribute müssen dort gesetzt sein? Wie kann ich einen Probedruck direkt aus der Slug anstossen (Telnet)? Die Möglickeit der Testseite im UI geht leider auch nicht. Habe im Forum gelesen, dass das normal sein kann und der Ausdruck von Windows trotzdem klappen würde.

Achso: den bereits eingerichteten Drucker habe ich noch drin. Der benutzt - meine ich - auch den /dev/lp0. Hat das damit auch zu tun? Auch ein Drucken auf den HP990C ohne irgendwelche anderweitig eingerichteten Drucker bringt keinen Erfolg.

Hast du eine Idee?

Danke
Andreas

Armin

Anfänger

Beiträge: 17

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

6

Freitag, 29. Dezember 2006, 20:50

Hi,

habe ein ähnliches Problem.
Auf meiner Platte mit CUPS 1.2.4 läuft alle bestens. URI ist dort parallel:/dev/lp0.

Jetzt habe ich noch einen USB-Stick hochgezogen und dort CUPS installiert. Das ist nunmehr 1.2.7. Dort steht als URI usb:/dev/lp0.

Der Drucker ist laut lpc stat korrekt eingerichtet:

hp990c:
printer is on device 'parallel' speed -1
queuing is enabled
printing is enabled
no entries
daemon present


lpq liefert:

hp990c is ready
no entries

Ein direktes Drucken auf /dev/lp0 funktioniert.Sobald man einen Auftrag an den Drucker absetzt erscheint im Web-IF die Meldung

Printer not connected; will retry in 30 seconds... Alle Jobs bleiben in der Queue und werden nicht abgearbeitet.


Hatte schon probiert, als URI file:/dev/usb/lp0 anzugeben (habe ich als Lösung für TurboPrint gegogelt). Leider unterstützt der Filemode keine RAW-Drucker.


Hat jemand da ne Idee!?
Grüßle und Tschöh!
Armin

Armin

Anfänger

Beiträge: 17

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

7

Freitag, 29. Dezember 2006, 21:08

Habe gerade mein Problem selber gelöst.

Zunächst habe ich mit

chmod u+s /opt/sbin/cupsd

gemäß Howto die Berechtigungen angepaßt und danach CUPS neu gestartet.

Das alleine hat nicht geholfen.

Danach die URI nochmal auf parallel:/dev/lp0 im Web-IF geändert. Und plötzlich lief der Job los.

Keine Ahnung, was da los war.

Grüßle und Tschöh!
Armin

jaluanda

Anfänger

  • »jaluanda« ist der Autor dieses Themas

Beiträge: 21

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

8

Samstag, 13. Januar 2007, 14:03

Hallo,

Du schreibst "gemäss HowTo" -welches meinst Du? Wo gibt es das? Hast Du einen Link?

Andreas

9

Samstag, 20. Januar 2007, 14:07

Hallo zusammen.

Aus der Bugliste von http://www.cups.org/str.php?L2194+P0+S-2+C0+I0+E0+Q

Zitat


First off, I can include log files (and I will) but they're not going to help out at all; the problem that I am having does not log.

I can configure USB printing just fine via the web interface. However, once the printer is setup, it does not print. It kicks off the Ghostscript process, and kicks off the USB back-end, and does nothing. The USB backend then becomes idle and will not die on signals 9 or 15, and I find that I have to send it a signal 11 to actually kill it.

This on FreeBSD 6.2, CUPS 1.2.7, ESP Ghostscript 8.15.3.

The printer /almost/ works using the “file” backend, but it is unreliable and needs a lot of hand-holding. If a print job is cancelled, the printer does not print subsequent jobs correctly, and I have to restart the printer. When I turn the printer off, its USB device node disappears and CUPS appears to bail out. So, when I cancel a job, in reality I have to cancel a job, power-cycle the printer, and then restart CUPS.

If you need anything I will try to provide it. I don't know why the USB back-end isn't working—I can cat files to the printer just fine (PCL files; it's a PCL printer that speaks PCL 5 and PCL/XL).


Im Augenblick scheint man mit der 1.2.4 besser beraten zu sein....
Gruss,
Der Highlander

Armin

Anfänger

Beiträge: 17

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

10

Samstag, 20. Januar 2007, 20:28

Bei Jaluanda druckt's jetzt auch! ;-)


Allerdings haben wir jetzt beide das Problem, dass die Duplexeinheit des Druckers nicht angesprochen wird. (LAserjet und Deskjet). Hat da jemand einen Lösung!?

Grüßle und Tschöh!
Armin

Social Bookmarks