Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

JanHH

Anfänger

  • »JanHH« ist der Autor dieses Themas

Beiträge: 10

Wohnort: Hamburg

Beruf: Student

  • Nachricht senden

1

Dienstag, 7. November 2006, 19:16

smb Konfiguration mit USB-Stick & HD --> doppelte shares

Hallo !
Ich hab gerade unslung 6.8 installiert, und benutze einen usb-stick als main drive und eine usb-HD als Datenspeicher.
Nachdem ich über das web-interface mehrere user angelegt habe, die ihre shares auf
dem HD haben, tauchten plötzlich zusätzliche shares auf ( username + tilde +1), welche angeblich auf dem usb-stick liegen sollen.
Da es äußerst nervig ist, diese im FTP-Zugriff zu sehen, wolle ich sie wieder
verschwinden lassen.
Ich probierte :
- löschen der "komischen" shares ==> "gewollte" shares nicht mehr erreichbar
- einfügen von "browsable=no" in /etc/samba/user_smb.conf ==> kein Erfolg
- einfügen von "browsable=no" an allen *smb.conf ==> kein Erfolg

...es scheint irgendwie nicht zu funktionieren.
Bei mir funktionierte "browsable=no" auch nicht bei den public shares.

Darüber hinaus bleibt "touch /.ext3flash" ebenfalls ohne Auswirkung ( swap immer noch in Benutzung, timestamps hab ich nicht geprüft).

Könnt Ihr mir bitte weiterhelfen ? Ich bin mit meinem Latein am Ende...:confused:

Viele Grüße & "Danke" schonmal...
JanHH

Anzeigen

JanHH

Anfänger

  • »JanHH« ist der Autor dieses Themas

Beiträge: 10

Wohnort: Hamburg

Beruf: Student

  • Nachricht senden

2

Dienstag, 7. November 2006, 22:24

Problem gelöst :

Ich denke mal, daß noch andere user über o.g. Problematik stolpern werden,
von daher hier der Link zur Lösung :

http://www.nslu2-linux.org/wiki/HowTo/Us…isksInUnslung68

Anzeigen

Dennis

Anfänger

Beiträge: 28

Wohnort: Hennigsdorf (b Berlin)

Beruf: Netzwerkadministrator/Firewalladministrator

  • Nachricht senden

3

Sonntag, 12. November 2006, 17:08

Hallo zusammen!

Ich habe ein ähnliches Problem, aber das Workaround konnte mir dabei nicht helfen!

Nutze die Wunderkiste bisher nur als Server von Netzwerkdiensten wie DHCP.
D.h., es gibt bisher noch keine Freigaben, mit Ausnahmen der Standardfreigaben "disk 1" und "admin 1".

So, jedesmal, wenn sich ein PC nun im Netzwerk anmeldet, dann werden automatisch Freigaben mit dessen Namen erzeugt und es entsteht im Netz ein Namenskonflikt. Daher ist die Netzwerkumgebung von Windows auch komplett leer.
Beispiel: PC "Lilly" fährt hoch, bekommt per DHCP die IP. Windows meldet, dass der Name bereits schon vergeben ist. Wenn andere Benutzer auf \\Lilly zugreifen wollen, so fragt Win nach Benutzer und Passwort... z.B.: Benutzer1(Profil auf Lilly) und Passwort ist "".
Das nächste Promt zeigt dann als Benutzername "NSLUG\Benutzer1" (wobei NSLUG der Host-Name von der nslu2 ist)

Dadurch klappen auch keine Druckerfreigaben mehr, da ja nicht nach IPs, sondern nach Host-Namen gesucht wird.

Bin mir sicher, dass ich wahrscheinlich etwas falsch konfiguriert habe, bloß weiß ich nicht genau, wo ich anfangen soll zu suchen. Das Problem besteht auch dann, wenn ich den Samba kille.

Kennt jemand das Problem und seine Ursachen?

Dennis

Anfänger

Beiträge: 28

Wohnort: Hennigsdorf (b Berlin)

Beruf: Netzwerkadministrator/Firewalladministrator

  • Nachricht senden

4

Donnerstag, 16. November 2006, 23:22

Könnte mir denn wenigstens jemand die Ordnerstruktur der NSLU2 mit unslung 6.0 erklären? Wo liegen die eigentlichen Config-Dateien? Allein die smb.conf finde ich über 8 mal... und wie starte ich den Samba neu, welche ist die richtige bin?

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

5

Donnerstag, 16. November 2006, 23:54

N'Abend,

die richtige ist /etc/samba/smb.conf, nur sie wird bei jedem start neu geschrieben... -> Du möchtest www.nslu2-linux.org -> howtos lesen.

Wenn Du Namenskonflikte hast, solltest Du evtl. mal Deine DNS-/Wins-Resolution überarbeiten.

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Dennis

Anfänger

Beiträge: 28

Wohnort: Hennigsdorf (b Berlin)

Beruf: Netzwerkadministrator/Firewalladministrator

  • Nachricht senden

6

Freitag, 17. November 2006, 00:24

Hallo, danke erstmal für die Antwort.

Punkt 1... wie werden die Einstellungen vom Webinterface dann permanent gemacht?

Punkt 2... habe ich schon vorher ausführlich durchgeschaut, würde sonst nicht das Forum belästigen, wenn ich nicht schon damit durch wäre. Auch Google hab' ich schon durch.


Punkt 3... als DNS-Server ist der DSL-Router eingetragen, wird per DHCP mitgegeben... aber der ist nur für Adressauflösungen im WAN zuständig, Namen im LAN soll irgendwann (wenn es denn überhaupt mal Namen gibt, dieses Problem hier verhindert das ja) die Box auflösen.
Thema DHCP-Config: Welche Parameter müssen denn genau angegeben werden, damit die anzumeldenden PCs keine Namen übertragen bekommen? Vielleicht liegt es ja daran...

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

7

Freitag, 17. November 2006, 18:02

Tach,

wenn Du Einstellungen treffen möchtest, welche nicht vom WebInterface angeboten werden, dann solltest Du das http://www.nslu2-linux.org/wiki/Unslung/DiversionScripts lesen.

Es ist sicher eine nette Idee, wenn Du Deine /opt/etc/dhcpd.conf mal postest.

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Dennis

Anfänger

Beiträge: 28

Wohnort: Hennigsdorf (b Berlin)

Beruf: Netzwerkadministrator/Firewalladministrator

  • Nachricht senden

8

Freitag, 24. November 2006, 22:05

Hi,

sorry, dass es ein wenig länger gedauert hat. So, hier hängt nun meine dhcp-Config mit dran.
Zur Erklärung: die Hosts mit _w sind wireless, die Hosts mit _l sind Interfaces mit LAN-Anschluss per Cat5-Ethernetkabel.

Die beschriebe Variante wegen dem Restart schaue ich mir an... beim Überfliegen des Forums habe ich grade noch einen weiteren Beitrag gefunden, der so ähnlich klingt, da schau ich auch noch mal rein.

Wenn jemand neue Infos wegen der Config hat, dann bitte posten... :D das Problem nervt so :(!
»Dennis« hat folgende Datei angehängt:
  • dhcpd.conf.txt (1,06 kB - 10 mal heruntergeladen - zuletzt: 17. Oktober 2009, 15:40)

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

9

Samstag, 25. November 2006, 18:12

N'Abend,

Hm, ...automatische Freigaben mit dessen Namen... , was genau meinst Du damit? Wenn Du uPnP nicht unbedingt brauchst, schalte es auf der NSLU und wenn möglich im gesamten Netz (incl. Router) mal ab.
Die DHCP Conf sieht nicht schlecht aus (falls Router und DNS ein Gerät sind).

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Dennis

Anfänger

Beiträge: 28

Wohnort: Hennigsdorf (b Berlin)

Beruf: Netzwerkadministrator/Firewalladministrator

  • Nachricht senden

10

Freitag, 22. Dezember 2006, 11:21

Hallo, inzwischen würde ein weiterer Thread eröffnet, in dem die Lösung präsentiert wurde:

http://www.nslu2-info.de/showthread.php?t=4895

Hab es selbst noch nicht getestet, aber hilfreich ist der Link auf jeden Fall!

Noch eine Frage: Ich nutze unslung bisher auf einem USB-Stick an Port 1, hab jetzt eine HDD an Port 2 drangehangen, er erkennt sie nicht. Laut der Beschreibung soll ich Festplatten ja auch an den Port 1 hängen.

Frage: Kann ich die gesamte Config vom Stick auf die Platte verschieben und dann booten? Oder gibt es auch eine Möglichkeit Stick auf 1 und HDD auf 2 zu betreiben?

11

Samstag, 23. Dezember 2006, 12:04

Hallo!

Wie ist denn Deine Platte formatiert?
NTFS, FAT oder EXT3 (also NSLU2 bzw Linux)?

Davon hängen die Möglichkeiten ab.

Siehe auch:
http://www.nslu2-linux.org/wiki/Unslung/R63DiskBehaviour

Whatever

Dennis

Anfänger

Beiträge: 28

Wohnort: Hennigsdorf (b Berlin)

Beruf: Netzwerkadministrator/Firewalladministrator

  • Nachricht senden

12

Dienstag, 26. Dezember 2006, 13:08

Hallo,

der Stick mit unslung ist EXT3-formatiert, die Festplatte habe ich nach FAT formatiert, damit ich sie ab und an auch mal abnehmen kann, wenn ich Daten brauche und nicht im Netzwerk bin. Den Aufwand mit NTFS an der NSLU2 wollte ich nicht machen.

Übringens kommen nach Änderung der smb.conf keine Fehler mehr... Der Tipp scheint zu helfen!

PS: Frohe Weihnachten euch allen!

Social Bookmarks