Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

13.09.2006, 18:19

(gelöst) Packages nicht im Pfad!?

Hallo,

mein uNSLUg-Werdegang ist bisher 5.5 and dann 6.8 mit jeweils einer Disk am Port 2. Nun wollte ich mich vergrößern und das Root auf einen USB-Stick am Port1 und die Shares auf eine Maxtor OneTouchIII mit Spin-Down auf Port2 legen (jeweils jungfräulich).

Daher habe ich die Slug erneut mit "/sbin/unsling -nopw disk1" nun auf den ext3 formatierten Flash an Port1. Im Webinterface sieht das auch soweit ganz gut aus:

uNSLUng status: Unslung to disk1, /dev/sdb1

Nachdem ich nun einige Pakete installiert habe (u.a. less), macht mich stutzig, dass dies offensichtlich nicht im Pfad ist, z.B.

# cat t.txt
Hello World
# less t.txt
less: No such file or directory

# env
USER=root
MAIL=/var/spool/mail/root
HOME=/root
LOGNAME=root
PATH=/sbin:/bin:/usr/sbin:/usr/bin
SHELL=/bin/sh
PWD=/root

Habe ich was verpasst oder bin ich z.Z. nur völlig neben der Spur?!
--
DuG
Oliver

Anzeigen

Eiffel

Profi

Beiträge: 619

Beruf: SAP Anwendungsbetreuer

  • Nachricht senden

2

13.09.2006, 20:44

ne das ist leider normal
du must den pfad noch um /opt/bin und so erweitern

Anzeigen

3

14.09.2006, 11:13

Ah, OK. In meiner Naivität dachte ich beim Installieren der Pakete via ipkg würden sie so angelegt, dass sie automatisch im Pfad sind. Wahrscheinlich habe ich den Hinweis in der Installationsnaleitung überlesen - sorry
--
DuG
Oliver

Eiffel

Profi

Beiträge: 619

Beruf: SAP Anwendungsbetreuer

  • Nachricht senden

4

14.09.2006, 15:21

hehe ne das steht blöder weise nirgends
und die macher des images wolltens nicht einbaun
weil es wohl probleme geben soll wenn man in der PFAD Variable
pfade drin hat die es noch nicht gibt

5

18.09.2006, 10:55

Jetzt bin ich doch echt verwirrt. Aufgrund anderer Probleme habe ich den Linksys komplett neu geunslugt (Port1 1GB USB-Stick rootfs, Port2 500GB Maxtor OneTouch 3 nur Shares).

Nun habe ich ohne weiteres Zutun wieder alle nachinstallierten Packages im Pfad!?

# env
SSH_CLIENT=<ip> 1231 22
USER=root
MAIL=/var/mail/root
HOME=/root
SSH_TTY=/dev/ttyp0
LOGNAME=root
TERM=vt100
PATH=/opt/sbin:/opt/bin:/usr/sbin:/usr/bin:/sbin:/bin
SHELL=/bin/sh
PWD=/root
SSH_CONNECTION=<sip> 1231 <dip> 22

Eiffel

Profi

Beiträge: 619

Beruf: SAP Anwendungsbetreuer

  • Nachricht senden

6

18.09.2006, 11:05

hm ich vermute mal das die Path-definition bei dir auf der Platte an einer stelle liegt die durch das erneute unslingen nicht betroffen war

7

18.09.2006, 11:19

Ne! Wie ich gerade feststelle, ist der Unterschied ob man per telnet oder ssh (openssh auf uNSLUg) hereinkommt. Bei der Anmeldung mit telnet fehlt er immer noch:

# env
USER=root
MAIL=/var/spool/mail/root
HOME=/root
LOGNAME=root
PATH=/sbin:/bin:/usr/sbin:/usr/bin
SHELL=/bin/sh
PWD=/root

Social Bookmarks