Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

xjonx

Schüler

  • »xjonx« ist der Autor dieses Themas

Beiträge: 49

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

1

05.09.2006, 10:40

CUPS (druckt nicht)

hey leutz,

also: cups ist installiert. weboberfläche läuft.
drucker habe ich manuell mit der weboberfläche
eingerichtet (Epson C64 wird laut den Listen unterstützt)
und ich konnte auch nen job schicken, der aber nach 3,75 %
idle wird und dann nichts mehr passiert.
testseite drucken spukt den "application/postscript" fehler aus.

die led an der slug (disk1) leuchtet nicht!

ausgabe lsusb:

Quellcode

1
2
3
4
5
6
7
8
[10:29:25]root@jServer:/root>lsusb
Unknown line at line 1809
Duplicate HUT Usage Spec at line 2650
Bus 003 Device 001: ID 0000:0000 Virtual Hub
Bus 002 Device 001: ID 0000:0000 Virtual Hub
Bus 001 Device 001: ID 0000:0000 Virtual Hub
Bus 001 Device 002: ID 0457:0151
[10:29:30]root@jServer:/root>

ausgabe printers.conf:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
# Printer configuration file for CUPS v1.2.2
# Written by cupsd on 2006-09-04 13:07
<DefaultPrinter EPSON_Stylus_C64_LPT_1>
Info EPSON Stylus C64
Location Local Printer
DeviceURI parallel:/dev/lp0
State Idle
StateTime 1157366948
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
AllowUser all
OpPolicy default
ErrorPolicy stop-printer
</Printer>


ich habs ebenso mal mit usb:/dev/lp0 probiert.
was gibt es noch?

Anzeigen

xjonx

Schüler

  • »xjonx« ist der Autor dieses Themas

Beiträge: 49

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

2

07.09.2006, 01:05

och bitte, hleft mir doch!

Anzeigen

3

07.09.2006, 17:41

[LEFT]Was sagt denn

Quellcode

1
lpq /dev/lp0

[/LEFT]
Gruss,
Der Highlander

xjonx

Schüler

  • »xjonx« ist der Autor dieses Themas

Beiträge: 49

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

4

07.09.2006, 23:13

wo soll ich das einsetzen? ich weiß damit jetzt nichts anzufangen: sorry.

5

08.09.2006, 18:53

In der Telnetsitzung, genauso wie Du lsusb eingegeben hast.
Sollte eingentlich irgendwas wie folgt ergeben:

root@NSLU2~> lpq /dev/lp0
hplj1020 is ready
no entries

Falls nicht hast Du den usb-Port für den Drucker nicht korrekt
mit mknod /dev/lp0 c 180 0 konfiguriert:
  1. On the command prompt run insmod /opt/lib/modules/printer.o - it will complain about tainted modules. Life is hard, boys and girls, so ignore it.
  2. Check with lsmod that printer.o has been loaded
  3. Create the printer device using mknod /dev/lp0 c 180 0
  4. Check that /dev/lp0 exists
Quelle http://www.nslu2-linux.org/wiki/HowTo/AddPrinter

Cups 1.2.2 unterstützt keine URIs mit usb:/dev/lp0, sondern nur noch parallel:/dev/lp0
Gruss,
Der Highlander

Social Bookmarks