Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Sonntag, 21. Mai 2006, 17:22

(gelöst) Probleme mit Subversion

Hallo zusammen,

als Linuxeinsteiger tue ich mich etwas schwer mit der Installation von subversion. Folgendes habe ich bisher durchgeführt:

1) Installation von Subversion mittels IPKG
2) Über das Webinterface einen User "svnrep" mit privatem share angelegt.
3) Per telnet die /etc/inetd.conf erweitert um folgenden Eintrag:

Quellcode

1
svn stream tcp nowait svnrep /opt/bin/svnserve svnserve -i -r /share/flash/data/svnrep

4) Die /etc/services erweitert um folgenden Eintrag

Quellcode

1
2
svn 3690/tcp
svn 3690/udp

5) Ein repository angelegt per:

Quellcode

1
svnadmin create /share/flash/data/svnrep/test

6) Unter Windows dann versucht per svn auf dieses Repository zuzugreifen:

Quellcode

1
svn checkout svn://192.168.1.77/test
Bekomme aber nur einen Fehler "svn: Fehlerhafte Netzwerkdaten".

Habe ich etwas vergessen?

Bin über jeden Tipp dankbar.

Grüße, Michael

Anzeigen

2

Sonntag, 28. Mai 2006, 12:10

Hi zusammen,

Problem hat sich erledigt. Der unter 3) beschriebene Eintrag in der /etc/inetd.conf enthielt ein svnserve zuviel. Richtig lautet der Eintrag also

Quellcode

1
svn stream tcp nowait svnrep /opt/bin/svnserve -i -r /share/flash/data/svnrep

Weiterhin habe ich die Rechte für das Verzeichnis /share/flash/data/svnrep und alles was darunterliegt per chown dem User svnrep zugeordnet.

Grüße, Michael

Anzeigen

Social Bookmarks