Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Freitag, 28. April 2006, 23:32

Ready/Status-LED bleibt gelb nach Booten

Die Ready/Status-LED bleibt gelb nach dem Booten meines NSLU2 (Unslung 6.8 Beta).
Disk 1 ist frei, an Disk 2 hängt eine USB-HDD, welche korrekt als ext3 formatiert dargestellt, lesbar und beschreibbar ist.
Telnet klappt, alle Pings ebenfalls.

In welche Logs muss ich schauen, um die Ursache für die nicht-grüne Ready/Status-LED zu ermitteln?

Vielen Dank!
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

Anzeigen

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

2

Freitag, 28. April 2006, 23:42

hm, dmesg ... ;)

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Anzeigen

3

Freitag, 28. April 2006, 23:51

Lässt sich aus diesem Log erkenen, weshalb die Ready/Status-LED seit dem Unslingen nicht grün, sondern gelb ist?

Was bedeuten insbesondere die vielen Zeilen, die sich nur im Offset unterscheiden?

Quellcode

1
Unknown but compatible feature node (0x2005) found at offset 0x00000000
»ao« hat folgende Datei angehängt:
  • dmesg.txt (7,71 kB - 9 mal heruntergeladen - zuletzt: 17. Oktober 2009, 15:40)
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

4

Donnerstag, 18. Mai 2006, 20:25

Hallo, lässt sich sagen, weshalb die Ready/Status-LED hier gelb statt grün ist?
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

5

Donnerstag, 18. Mai 2006, 21:33

N'Abend,

Piept die NSLU eigentlich, wenn Sie mit dem booten fertig ist?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


6

Donnerstag, 18. Mai 2006, 21:40

Ja, ein kurzer Piep - jeweils beim Ausschalten und beim Einschalten bzw. Rebooten.
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

7

Donnerstag, 18. Mai 2006, 22:08

N'Abend,

Und was geschieht, wenn Du /usr/bin/Set_Led ready eingibst?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


8

Samstag, 20. Mai 2006, 10:07

Zitat von »caplink811«

Und was geschieht, wenn Du /usr/bin/Set_Led ready eingibst?
Außer einem neuen Prompt, gar nichts. Die LED bleibt gelb.
Alternativ habe ich mal Set_Led s_blinking versucht, aber da kam auch nach einer Weile kein Prompt mehr (LED unverändert), so dass ich mit Strg-C abgebrochen habe.

EDIT:
Nach einem Reboot piepst das NSLU2 so: piep-------piep--piep--piep
Und dann im 15-Sekunden-Abstand piep--piep--piep, und immer so weiter. Die LED ist gelb.

Login per SSH (putty) geht - dmesg-Output habe ich angehängt.
Nach dem SSH-Login und dem Erstellen des Outputs hat das NSLU2 aufgehört zu piepsen.

Was ist denn da los? Danke für Deine Hilfe!
»ao« hat folgende Datei angehängt:
  • dmesg.txt (7,69 kB - 5 mal heruntergeladen - zuletzt: 24. Oktober 2009, 21:00)
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

9

Montag, 22. Mai 2006, 12:13

@agent orange

Hallo !
den offset bereich definiert man in der ..flash.c beim compilieren eines Images !

Hier mal die akt. mtd part table v Unslung_6.8b

PHP-Quelltext

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
/* partition_info gives details on the logical partitions that the split the
 * single flash device into. If the size if zero we use up to the end of the
 * device. */
static struct mtd_partition partition_info[]= {{name"BR bootloader",        // raw
                              size128 1024, 
                              offset0,                  
                              mask_flagsMTD_WRITEABLE},
                                                     {name"PPC bootloader",        // flfs
                              size128 1024, 
                              offsetMTDPART_OFS_APPEND, 
                              mask_flags0},
                                                     {name"Kernel",            // idxfs
                              size768 1024, 
                              offsetMTDPART_OFS_APPEND, 
                              mask_flags0},
                                                     {name"System",            // jffs
                              sizeMTDPART_SIZ_FULL, 
                              offsetMTDPART_OFS_APPEND, 
                              mask_flags0}};



PHP-Quelltext

1
2
3
4
5
6
7
dev:    size   erasesize  name
mtd000040000 00020000 "RedBoot"
mtd100020000 00020000 "SysConf"
mtd200100000 00020000 "Kernel"
mtd300020000 00020000 "Ramdisk"
mtd400660000 00020000 "Flashdisk"
mtd500020000 00020000 "FIS directory"

warum auch immer vermute ich das deine mtd part table defekt ist deshalb auch der offset fehler im log !

Wenn der Fehler seit anbeginn bestanden hat würde ich versuchen nocheinmal die FW downzuladen von off HP, und neu zu flashen !


das ist nur eine wage vermutung von mir !!! ;)
kann auch sein das ich daneben liege ........ sonst frag mal einen Developer !

lg Tpol

10

Montag, 22. Mai 2006, 20:44

Wow, ich verstehe nur Bahnhof... :confused: Das mit dem Offset habe ich wirklich nicht verstanden - noch weniger Deine code snippets. :o

Was meinst Du mit "die FW downzuladen von off HP"? Sorry, dass ich mich gerade etwas däppert anstelle, aber meinst Du einfach nochmal runterladen, ja?

Danke für Dein Feedback - ein neuer Flash wäre ja nicht so schlimm, wenn ich dabei nicht alle Daten verlieren würde. Aber davon muss ich wohl ausgehen, oder bleiben Partitionen 2+3 dabei unberührt?
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

11

Montag, 22. Mai 2006, 21:56

Das Offset-Phänomen scheint im Unslung-Betrieb unerheblich zu sein - siehe dort.

Aber dass die LED gelb statt grün bleibt, ist schon seltsam. Hat sonst niemand eine Idee?
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

12

Montag, 22. Mai 2006, 21:58

Zitat

Was meinst Du mit "die FW downzuladen von off HP"? Sorry, dass ich mich gerade etwas däppert anstelle, aber meinst Du einfach nochmal runterladen, ja?
Jep es kann sein das du die Firmware (FW) ja nicht von der ofiz. http://www.unslung.org/ Seite runtergeladen hast, oder aber auch beim download was schief gegangen ist, oder beim flashen selbst !

wie auch immer spiel ja auch keine rolle mehr !

ich würd deine USB HDD bei seite legen die FW downloaden ,nochmals neu flashen und dann mit einem usb Stick unslingen.

wenn das klappt kannst du dir noch immer gedanken machen was du mit deinen Daten auf der USB HDD machst.

beim unslingen selbst bleiben part. 2+3 erhalten jedoch würde ich wenn alles klappt die HDD neu formatieren.

lg Tpol


Ps.Der offset bereich ist imo jener zwischenraum der einzelnen part table im flash zwischen 00020000 00800000 könnte man definieren wird aber in der regel mit 0 ausgegeben oder angehängt ! laienhaft ausgedrückt ;)

Social Bookmarks