Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Donnerstag, 13. April 2006, 16:06

Platte mountet nicht mehr nach NSLU2 reboot

Hallo,
ich hoffe mir kann jemand bei dem folgenden Problem helfen. Musste die NSLU2 abstecken; da sie sich aber mit dem Power-Knopf nicht ausschalten lies (lief aber vorher problemlos), zog ich den Netzstecker..

nun startet die NSLU2 zwar klaglos; hängt auch im netz; mountet aber die festplatte nicht mehr.
folgenden infos habe ich noch:

- kann nach telnet login und platte einschalten diese auf tmpmnt mounten (vgl. http://www.nslu2-info.de/showthread.php?t=3422); mit ls sehe ich alle meine daten noch.

- habe Firmware V2.3R29-uNSLU***5.5-beta
- platte ist eine seagate 250, die bisher lange zeit klaglos funktioniert hat

nunr meine bitte um Hilfe bzw. falls ich die firmware nochmal draufspielen soll, wie kann ich die daten/userlaufwerke auf der platte erhalten (habe nämlich keine 2.platte um die menge zu sichern....). Sind diese mittel unsling alle weg?

danke gleich mal vorweg für jede hilfe!

Anzeigen

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

2

Donnerstag, 13. April 2006, 16:56

Tach,

ist ja schonmal nicht schlecht, das Du die Datenpartition mauell mounten kannst...

- .dongle ist auf /dev/sda2 vorhanden?
- .sda1root ist auf /dev/sda1 vorhanden?
- es laufen 2 USB_Detect Prozesse?
- fsck durchgeführt?

Fragen über Fragen...

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Anzeigen

3

Donnerstag, 13. April 2006, 17:14

Hi,

danke für die schnelle reply,

also zu den fragen:

- dongle ist auf /dev/sda2 vorhanden?
- .sda1root ist auf /dev/sda1 vorhanden?

..... bekomme ich den fehler, dass auf dev wegen zugriffsrechten (permission denied) nicht zugegriffen werden kann (eingeloggt als root /uNSLUng)

- fsck noch nicht; kannst Du mir hier einen tipp geben wie ich das (espzielle optionen?) starte?

- USB detect prozesse:
was ich herauslesen kann laufen zumindest 467 und 468 (onetouch heisst die platte) - falls dies die angesprochenen prozesse sind:
ps -A
PID TTY Uid Size State Command
1 root 1212 S /bin/init
2 root 0 S [keventd]
3 root 0 S [ksoftirqd_CPU0]
4 root 0 S [kswapd]
5 root 0 S [bdflush]
6 root 0 S [kupdated]
7 root 0 S [mtdblockd]
8 root 0 S [khubd]
9 root 0 Z [jffs2_gcd_mtd4]
213 root 0 S [jffs2_gcd_mtd4]
221 root 0 D [ixp425_csr]
222 root 0 S [ixp425 ixp0]
225 ttyS0 root 1916 S /bin/sh
227 root 1936 S /sbin/syslogd -n
228 root 1924 S /sbin/klogd -n
404 root 2112 S /usr/sbin/thttpd -C /etc/thttpd.conf
428 root 3896 S /usr/sbin/smbd -D
430 root 3116 S /usr/sbin/nmbd -D
467 root 1864 S /usr/sbin/onetouch_detect
468 root 1864 S /usr/sbin/onetouch_detect
480 root 1216 S /usr/sbin/crond
486 root 1908 S /usr/sbin/CheckResetButton
488 root 1196 S /usr/sbin/CheckPowerButton
490 root 1196 S /usr/sbin/do_umount
523 root 0 S [usb-storage-1]
524 root 0 S [scsi_eh_1]
537 root 2116 S /usr/sbin/thttpd -C /etc/thttpd.conf
551 root 1276 S /bin/inetd
552 root 1256 S /usr/sbin/telnetd
553 ttyp0 root 1920 S -sh
557 ttyp0 root 1984 R ps -A

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

4

Donnerstag, 13. April 2006, 17:32

Tach,

Wenn USB_Detect nicht läuft, wird die Platte nicht automagisch gemountet.

- boote ohne Platte, und logge Dich als root ein (PW=uNSLUng)
- suche, finde und lösche USB_det.pid in den Verzeichnissen /var/run und /var.state/run
- ausschalten, Platte stecken, neu starten

Hat es geholfen?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


5

Donnerstag, 13. April 2006, 17:49

SUUPER!!! Vielen Dank, funkt alles wieder klaglos! :):):):)

Nun eine allerletzte Frage noch: ich habe zwischenzeitliche die festplatte versucht sowohl an meine PC als auch mac (mit ext3 treibern jeweils ) zu mounten; bekam aber bei beiden fehlermeldungen (pc: drive not formated; win: Festplatte möglw. beschädigt.)

gibts da eine möglichkeit das zu überprüfen, weil auf der nslu2 läuft die platte ja (jetzt wieder) problemlos.
(Hintergrund ist, dass ich nämlich auf ntfs langsam umsteigen möchte um dieses ext3 loszuwerden; hierzu muss ich aber irgendwie die daten auch vorher runterkriegen, und per netzwerk ist das zu langsam...)

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

6

Donnerstag, 13. April 2006, 17:53

Tach,

Warum, ein NAS ist ein NAS ist ein NAS, und bei einem solchigen interessiert das Filesystem nicht.

Wenn Du eine Knoppix CD zur Hand hast, solltest Du mal von dieser booten, und dann die NSLU Festplatte an Deinen Rechner hängen, und mal einen fsck.ext3 überdie Partitionen laufen lassen. Das würde auch an der NSLU gehen, ist aber etwas tricky (und m.E. ist das LInksys fsck.ext3 fehlerhaft).

bye
JrB
"Supporting joe users worldwide" <- that's our motto


7

Donnerstag, 13. April 2006, 18:25

ja das stimmt schon; aber um hier und da größere Dateien nicht ubers netz (wln) senden zu müssen, ist es einfach angenehmer die platte kurzfristig direkt an einen pc/mac anzuschließen.

und da ist ntfs um einiges praktischer.... und mit unslung 6 sollte das ja auch gehen...

knoppix habe ich darum (kein linux) auch nicht ...

auf alle fälle; danke nochmal für die hilfe!

8

Sonntag, 16. April 2006, 00:26

@clchris

Hallo,

wenn Du nur von Windows aus LESEN willst, dann kannste ja mal das probieren: http://www.fs-driver.org/index.html

Hab damit insgesamt schon ca 100GB von einer USB2.0 Platte (mit EXT3-Partition) auf meinen Windows Rechner kopiert. Ohne Probleme!

Gruß
Sinclair

Social Bookmarks