Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Samstag, 8. April 2006, 18:26

Unslung auf Microdrive 1GB ?

Hallo miteinander

ich habe mir letztens den NSLU-2 zugelegt und mit der originalen Firmware
gute Erfahrungen gemacht.
Da mir vorher aber nicht ganz klar war, das ich meine
USB-Platte dafür formatieren müsste die

1. Randvoll ist :p

2. Keinen Platz habe die Daten wegzusichern

3. Die Platte nicht andauernd laufen lassen will (Stromverbrauch)


habe ich ein "altes" 1GB Microdrive "FAT32" am Kartenleser an der NSLU-2 angeschlossen, und diese wurde auch wunderbar erkannt.
Ich hatte zwar Bedenken, ob das Microdrive die zulässigen 500ma
nicht überschreitet, aber nach einigen erfolgreichen Versuchen,
habe ich dazu entschlossen, das Drive als Systemplatte für
Unslung 5.5 beta zu verwenden.

Was mich übrigens wundert, das ich dazu im Internet kaum was dazu finde, ausser einem Amerikaner, der ein 2GB Drive damit laufen hat.

Flugs geflasht. Soo jetzt der Schlamassel:

# fdisk /dev/sda

Unable to read /dev/sda
#

dmesg

Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
USB Mass Storage support registered.
i2c-dev.o: Registered 'IXP425 I2C Adapter' as minor 0
i2c-core.o: adapter IXP425 I2C Adapter registered as adapter 0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 2048 bind 4096)
IP-Config: No network devices available.
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
NetWinder Floating Point Emulator V0.97 (double precision)
VFS: Mounted root (jffs2 filesystem).
Freeing init memory: 244K
hub.c: new USB device 00:01.2-1, assigned address 2
Protocol: Transparent SCSI
before kernel thread
*** detect:usb-storage
* scsi_register: usb-storage-1,
* scsi_reg, hostno:1 prot is 49
* scsi_reg, retval->host_no:1
scsi1 : SCSI emulation for USB Mass Storage devices
! scan_scsis
*** 49
31 port connect!!!!!
Vendor: Generic Model: USB SD Reader Rev: 1.00
Type: Direct-Access ANSI SCSI revision: 02
the host no is 1
* sd_attach:0
Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
sda: Unit Not Ready, sense:
Info fld=0x0, Current 00:00: sns = f0 2
ASC=3a ASCQ= 0
Raw sense data:0xf0 0x02 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0xaa 0x55 0x42 0x3a 0x00 0x00 0x00 0x00 0x00
sda : READ CAPACITY failed.
sda : status = 1, message = 00, host = 0, driver = 08
Info fld=0x0, Current sd00:00: sns = f0 2
ASC=3a ASCQ= 0
Raw sense data:0xf0 0x02 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0xaa 0x55 0x42 0x3a 0x00 0x00 0x00 0x00 0x00
sda : block size assumed to be 512 bytes, disk size 1GB.
Partition check:
/dev/scsi/host1/bus0/target0/lun0: I/O error: dev 08:00, sector 0
I/O error: dev 08:00, sector 0
unable to read partition table
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2
Module init.
ixp425_eth:
Initializing IXP425 NPE Ethernet driver software v. 1.1
ixp425_eth: CPU clock speed (approx) = 0 MHz
[error] ixEthMiiPhyScan : unexpected Mii PHY ID 00008201
ixp425_eth: ixp0 is using the PHY at address 1
ixp425_eth: ixp1 is using the PHY at address 0
ixp425_eth: ixEthMiiLinkStatus failed on PHY0.
Can't determine
the auto negotiated parameters. Using default values.
enable_irq(22) unbalanced from c39451bc
X1226: I2C based RTC driver.
i2c-core.o: driver X1226 registered.
X1226: found X1226 on IXP425 I2C Adapter
i2c-core.o: client [X1226] registered to adapter [IXP425 I2C Adapter](pos. 0).
atr is 1f
sda: Unit Not Ready, sense:
Info fld=0x0, Current 00:00: sns = f0 2
ASC=3a ASCQ= 0
Raw sense data:0xf0 0x02 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0xaa 0x55 0x42 0x3a 0x00 0x00 0x00 0x00 0x00
sda : READ CAPACITY failed.
sda : status = 1, message = 00, host = 0, driver = 08
Info fld=0x0, Current sd00:00: sns = f0 2
ASC=3a ASCQ= 0
Raw sense data:0xf0 0x02 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0xaa 0x55 0x42 0x3a 0x00 0x00 0x00 0x00 0x00
sda : block size assumed to be 512 bytes, disk size 1GB.
sda: test WP failed, assume Write Enabled
/dev/scsi/host1/bus0/target0/lun0: I/O error: dev 08:00, sector 0
I/O error: dev 08:00, sector 0
unable to read partition table
sda: Unit Not Ready, sense:
Info fld=0x0, Current 00:00: sns = f0 2
ASC=3a ASCQ= 0
Raw sense data:0xf0 0x02 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0xaa 0x55 0x42 0x3a 0x00 0x00 0x00 0x00 0x00
sda : READ CAPACITY failed.
sda : status = 1, message = 00, host = 0, driver = 08
Info fld=0x0, Current sd00:00: sns = f0 2
ASC=3a ASCQ= 0
Raw sense data:0xf0 0x02 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0xaa 0x55 0x42 0x3a 0x00 0x00 0x00 0x00 0x00
sda : block size assumed to be 512 bytes, disk size 1GB.
sda: test WP failed, assume Write Enabled
/dev/scsi/host1/bus0/target0/lun0: I/O error: dev 08:00, sector 0
I/O error: dev 08:00, sector 0
unable to read partition table
sda: Unit Not Ready, sense:
Info fld=0x0, Current 00:00: sns = f0 2
ASC=3a ASCQ= 0
Raw sense data:0xf0 0x02 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0xaa 0x55 0x42 0x3a 0x00 0x00 0x00 0x00 0x00
sda : READ CAPACITY failed.
sda : status = 1, message = 00, host = 0, driver = 08
Info fld=0x0, Current sd00:00: sns = f0 2
ASC=3a ASCQ= 0
Raw sense data:0xf0 0x02 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0xaa 0x55 0x42 0x3a 0x00 0x00 0x00 0x00 0x00
sda : block size assumed to be 512 bytes, disk size 1GB.
sda: test WP failed, assume Write Enabled
/dev/scsi/host1/bus0/target0/lun0: I/O error: dev 08:00, sector 0
I/O error: dev 08:00, sector 0
unable to read partition table
sda: Unit Not Ready, sense:
Info fld=0x0, Current 00:00: sns = f0 2
ASC=3a ASCQ= 0
Raw sense data:0xf0 0x02 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0xaa 0x55 0x42 0x3a 0x00 0x00 0x00 0x00 0x00
sda : READ CAPACITY failed.
sda : status = 1, message = 00, host = 0, driver = 08
Info fld=0x0, Current sd00:00: sns = f0 2
ASC=3a ASCQ= 0
Raw sense data:0xf0 0x02 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0xaa 0x55 0x42 0x3a 0x00 0x00 0x00 0x00 0x00
sda : block size assumed to be 512 bytes, disk size 1GB.
sda: test WP failed, assume Write Enabled
/dev/scsi/host1/bus0/target0/lun0: I/O error: dev 08:00, sector 0
I/O error: dev 08:00, sector 0
unable to read partition table
sda: Unit Not Ready, sense:
Info fld=0x0, Current 00:00: sns = f0 2
ASC=3a ASCQ= 0
Raw sense data:0xf0 0x02 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0xaa 0x55 0x42 0x3a 0x00 0x00 0x00 0x00 0x00
sda : READ CAPACITY failed.
sda : status = 1, message = 00, host = 0, driver = 08
Info fld=0x0, Current sd00:00: sns = f0 2
ASC=3a ASCQ= 0
Raw sense data:0xf0 0x02 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0xaa 0x55 0x42 0x3a 0x00 0x00 0x00 0x00 0x00
sda : block size assumed to be 512 bytes, disk size 1GB.
sda: test WP failed, assume Write Enabled
/dev/scsi/host1/bus0/target0/lun0: I/O error: dev 08:00, sector 0
I/O error: dev 08:00, sector 0
unable to read partition table
I/O error: dev 08:00, sector 0
I/O error: dev 08:00, sector 0
#

Egal ob ich die NSLU-2 mit der Platte boote, oder ohne.
Der I/O Error kommt immer.

Weiß vielleicht jemand von euch woran das liegen könnte ?


Gruß Ingo

Anzeigen

trapperjohn

Fortgeschrittener

Beiträge: 558

Wohnort: Bremen

Beruf: SW-Entwickler

  • Nachricht senden

2

Samstag, 8. April 2006, 18:39

Ich hatte immer so komische I/O Fehler, wenn ich das 2,5" Festplattengehäuse mit nur einem USB-Stecker ans Notebook angeschlossen hatte. Mit beiden Steckern hats dann geklappt - die Stromaufnahme der Platte war wohl doch zu viel. Evtl. hier das gleiche Problem? Kannst du dem Microdrive irgendwie per Netzteil mehr Saft gönnen?
Gruß,
Flo

Anzeigen

3

Samstag, 8. April 2006, 18:54

Hallo !

danke für den Tip !

Habe das Drive an einem USB-Hub mit aktiver Stromversorgung angestöpselt.
Daran wird wahrscheinlich nicht liegen !

Log -->

<44>Jan 1 01:46:09 klogd: sda : block size assumed to be 512 bytes, disk size 1GB.
<44>Jan 1 01:46:09 klogd: sda: test WP failed, assume Write Enabled
<46>Jan 1 01:46:09 klogd: /dev/scsi/host1/bus0/target0/lun0: I/O error: dev 08:00, sector 0
<44>Jan 1 01:46:09 klogd: I/O error: dev 08:00, sector 0
<44>Jan 1 01:46:09 klogd: unable to read partition table

Social Bookmarks