Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

vimes

Anfänger

  • »vimes« ist der Autor dieses Themas

Beiträge: 10

Firmwareversion / your current Firmware: Unslung 3.18

Wohnort: Augsburg

  • Nachricht senden

1

Montag, 7. März 2005, 17:49

Data Backup

Hallo Forum,

nachdem es mir mit eurer Hilfe erfolgreich gelungen ist meine kleinen Notebook Festplatten an der Slug in Betrieb zu nehmen, hab ich leider schon das nächste Problem:
Neben Twonky Vision (läuft) und SSH (läuft auch) wollte ich gerne noch die Backup-Features nutzen. Deswegen hab ich einen Backup-Job angelegt und diesen manuell zum Testen mit einem Klick auf "Backup Now" gestartet. Der Job lief auch wunderbar durch, nur leider läuft er immer noch. Das heißt die Admin-Oberfläche ist der Meinung er läuft noch. Ich bekomme den Job leider nicht mehr verändert und kann ihn auch nicht löschen. Es kommt jedes Mal die Meldung "Error: The Job is executing, cannot update or delete it."

Kann mir vielleicht jemand sagen wo der entsprechende Eintrag diesbezügich ist? Die Prozessliste ist leer bzw. nicht leer aber enthält keinen backup Eintrag. Ich hab echt keine Ahnung wo ich noch suchen sollte.
Auch Ausschalten und Einschalten bringt leider nichts.

Das Backup soll von einer Samba-Freigabe eines Linux Servers auf die Slug erfolgen.

Schon mal Danke für eure Tipps.

Chris

Anzeigen

vimes

Anfänger

  • »vimes« ist der Autor dieses Themas

Beiträge: 10

Firmwareversion / your current Firmware: Unslung 3.18

Wohnort: Augsburg

  • Nachricht senden

2

Dienstag, 8. März 2005, 13:23

Weiß denn wirklich niemand irgendetwas über die Backup-Abläufe? Selbst nach einer ganzen Nacht in der die NSLU ausgeschaltet war, besteht das Problem nach wie vor.

Chris

Anzeigen

cip-b

Anfänger

Beiträge: 1

Firmwareversion / your current Firmware: originale Firmware 2.3r29

  • Nachricht senden

3

Mittwoch, 9. März 2005, 19:36

HowTo from

http://www.nslu2-linux.org/wiki/Main/FAQ

22. After installing the Unslung firmware, the disk 1 to disk 2 backup doesn't work anymore The original Linksys backup binary has problems with symbolic links, the backup can be made working again using rsync.
See http://www.nslu2-linux.org/wiki/HowTo/Fi…UnslungFirmware

Vieleicht hilft das weiter :-)

Gruß
cip-b

emptee

Anfänger

Beiträge: 9

Firmwareversion / your current Firmware: Unslung 3.18

Wohnort: Dortmund

Beruf: Dipl.-Inform.

  • Nachricht senden

4

Mittwoch, 9. März 2005, 19:49

Ich denke, das hilft ihm nicht weiter und hat auch nichts mit seinem Problem zu tun.

Das im Wiki beschriebene Problem beim "internen" Backup von Disk 1 auf Disk 2 dreht sich um die symbolischen Links, die das Kopierprogramm verwirren.

Das führt zu einem simplen Segmentation Fault des backup - Programms, die Reste des Skripts (drivertodrivercp) laufen jedoch weiter und heben auch alle bestehenden Lockdateien auf.

Lasst euch also nicht verwirren: Das Kopieren von extern auf die Slug oder von der Slug nach extern geht trotz unslung WEITERHIN PROBLEMLOS.

Eine Hilfe für das hier geschilderte Problem habe ich bisher auch nicht.

Problemanalyseansatz:

Eine Idee wäre, das eigentliche Backup-CGI (sh_backup.cgi) auf der Kommandozeile mal mit der Hand aufzurufen (dabei müssen einige Umgebungsvariablen (u.a. REQUEST_METHOD, CONTENT_LENGTH gesetzt werden, da es sich eigentlich um ein CGI-Programm handelt, weiterhin sollte man zumindest rudimentär verstanden haben, wie CGI-Programme funktionieren ;-).

Den Aufruf vielleicht noch mittels strace tracen, um zu gucken, wovon die Fehlermeldung verursacht wird.

Grüße, Mario
Meine NSLU2:
Nr.1: Fileserver 2 x 120 GB, Printserver, Mediaserver mit Twonkyvision
Nr.2: Entwicklungsbox mit nativer Toolchain, außerdem NNTP-Server mit leafnode und DNS-Server

vimes

Anfänger

  • »vimes« ist der Autor dieses Themas

Beiträge: 10

Firmwareversion / your current Firmware: Unslung 3.18

Wohnort: Augsburg

  • Nachricht senden

5

Sonntag, 13. März 2005, 23:04

Also was ich bis jetzt rausgefunden habe ist, dass das Problem unabhängig von den angeschlossenen Platten ist.
Nachdem ich eine neue Platte angeschlossen hatte (die alte war komplett abgehängt), war der fehlerhafte Eintrag nach wie vor in der Jobliste und läßt sich immer noch nicht löschen - die Fehlermeldung bleibt die gleiche.

Ein anderer Backupjob der problemlos läuft und der auch nicht gesperrt ist, steht wunderbar in der Crontab. Bloß finden kann ich diesen Job nirgends. Irgendwo muß doch gespeichert sein was wohin kopiert werden soll, aber wo???

Birdy

Anfänger

Beiträge: 35

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

6

Mittwoch, 16. März 2005, 09:47

Ich wollte gestern das Backup ebenfalls ausprobieren und stehe jetz vor dem
gleichen Problem, dass ich den Job nicht löschen oder ändern kann, da er noch läuft (auch nach Neustart).

Fall jemand eine Lösung hat....

Bis dann

Birdy

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

7

Montag, 21. März 2005, 10:30

Moin,

schau mal ins Verzeichnis /mnt/backup, dort sollten für jeden Backup Job, der gerade läuft, Status Dateien angelegt worden sein...
... selbige solltest Du löschen können, und damit wieder Ruhe haben.

bye
JrB

vimes

Anfänger

  • »vimes« ist der Autor dieses Themas

Beiträge: 10

Firmwareversion / your current Firmware: Unslung 3.18

Wohnort: Augsburg

  • Nachricht senden

8

Montag, 21. März 2005, 10:44

Super, vielen Dank. Das war's. Ich hab so ziemlich jedes Verzeichnis auf der NSLU inspiziert, aber das hab ich übersehen.

Man muss einfach die Datei mit der Endung .pid und das dazugehörige Verzeichnis löschen - und dann läßt sich der Job wieder aus der Admin-Oberfläche löschen.

Noch mal Danke,
Chris

Social Bookmarks