Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Montag, 14. Januar 2008, 21:26

Umlaute werden nicht dargestellt

Hallo,

auf meiner NSLU2 (OpenSlug 3.10b) werden die Umlaute und das ß in Dateinamen nicht korrekt angezeigt, sondern z.B. so:
"f_r" statt "für"
"k?nstlich" statt "künstlich"
"Gef?hrten" statt "Gefährten"
"T?rme" statt "Türme"
"G_tter" statt "Götter" etc.

Woran liegt das und wie kann ich das korrigieren?
Vielen Dank für Eure Hilfe!

PS: Es gibt hier zwar bereits einen Thread, aber ich habe es leider nicht verstanden, und leider ist der Thread bereits geschlossen, so dass ich dort keine Fragen stellen kann.


Die Suche schon benuzt?: ja

Art der Firmware: OpenSlug 3.10b

wird ein externer Datenträger genutzt, wenn ja, was für eine Art: Maxtor OneTouch II+III
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

Anzeigen

ToMa

Fortgeschrittener

Beiträge: 253

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Ostwestfalen

Beruf: FISI

  • Nachricht senden

2

Mittwoch, 16. Januar 2008, 16:32

Hallo,

im Samba unter Windows, in der Shell oder wo?

ToMa

Anzeigen

3

Mittwoch, 16. Januar 2008, 20:04

O.g. falsche Darstellung findet sich in der Shell (ssh) auf der NSLU2.
Unter Samba (OS X) sieht es ein bißchen anders aus (z.B. "f_r" statt "für", d.h. alle Umlaute werden durch ein "_" ersetzt"), aber trotzdem falsch.
Unter Windows kann ich es leider nicht testen.

Achja, erwähnenswert ist, dass die Dateien auf der NSLU2 mittels NFS von einem DVB-T Receiver kommen (Siemens Gigaset M740 AV). Wenn ich mich auf der M740 einlogge und in mein auf der NSLU2 gemountetes Verzeichnis wechsle, wo die Aufnahmen liegen, werden die Dateien wie im ersten Beitrag oben beschrieben falsch dargestellt.
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

ToMa

Fortgeschrittener

Beiträge: 253

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Ostwestfalen

Beruf: FISI

  • Nachricht senden

4

Donnerstag, 17. Januar 2008, 09:19

Hallo,

für die Shell sollte Dir doch eigentlich ein:
dpkg-reconfigure locales
mit der richtigen Auswahl helfen.
In Samba (3.0.xx) hat bei mir folgendes unter [global] geholfen:

dos charset = CP850
unix charset = CP850
display charset = iso-8859-15

ToMa

5

Donnerstag, 17. Januar 2008, 20:30

Zitat von »ToMa;29665«

für die Shell sollte Dir doch eigentlich ein:
dpkg-reconfigure locales
mit der richtigen Auswahl helfen.
Den Befehl gibt's auf meinen NSLU2 (OpenSlug 3.10b) nicht.

Zitat von »ToMa;29665«

In Samba (3.0.xx) hat bei mir folgendes unter [global] geholfen:

dos charset = CP850
unix charset = CP850
display charset = iso-8859-15

ToMa

Ok, da steht bei mir:

Quellcode

1
2
3
dos charset = ASCII
unix charset = UTF8
display charset = LOCALE
Nachdem ich Deine Werte im Swat eingegeben habe (noch ohne SMBD-Neustart, hat aber eigentlich auch nix mit dem Browser zu tun), werden diese Werte in Swat (Tool zum SMB-Konfigurieren; Browser ist Firefox 2.0.0.11) chinesisch dargestellt! Irre...
Ich glaube, das mache ich lieber mal rückgängig. ;)

EDIT:
Mist, jetzt kann ich mich nicht mehr unter Swat (NSLU-IP:901) anmelden: Die Authorisierung mit "root" und root-PW schlägt fehl.
Was ist denn jetzt passiert?! :mad:
Mit ssh komme ich noch drauf, aber Swat-Anmeldung geht nicht mehr - und zwar nach der Umstellung o.g. Parameter.
Mittels ssh auf der NSLU2 habe ich die globals auf ihre Original-Werte gesetzt und die Kiste neu gebootet. Und siehe da, es geht wieder.

Im Firefox wird der "Bürger" korrekt dargestellt, direkt auf der NSLU2 aber als "B?rger". Hmm, wie löst man das Problem, ohne Chinesisch?
»ao« hat folgendes Bild angehängt:
  • Bild 1.png
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

ToMa

Fortgeschrittener

Beiträge: 253

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Ostwestfalen

Beruf: FISI

  • Nachricht senden

6

Donnerstag, 17. Januar 2008, 21:12

Ist mir rätselhaft.
So anders kann doch OpenSlug nicht sein, oder?

ToMa

7

Sonntag, 20. Januar 2008, 21:24

Gemäß dieser Anleitung habe ich alle Einstellungen vorgenommen (de_de), so dass Umlaute angezeigt werden sollten.
Allerdings ergibt 'touch ä' => '??' (statt Datei namens 'ä') auf der shell (Login via ssh).
Wenn ich mich mittels ssh auf der NSLU2 einlogge und mit der shell o.g. Problem habe, hat das doch nichts mit Samba zu tun, oder?
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

ToMa

Fortgeschrittener

Beiträge: 253

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Ostwestfalen

Beruf: FISI

  • Nachricht senden

8

Montag, 21. Januar 2008, 08:54

Genau, das hat mit Samba nichts zu tun.
Keine Ahnung wo und wie du es in OpenSlug korrigieren kannst.
Unter Debian würde ich die locales konfigurieren und /etc/profile prüfen.

ToMa.

djk1o

Fortgeschrittener

Beiträge: 332

Wohnort: Berlin

Beruf: Programmierer/Designer

  • Nachricht senden

9

Montag, 21. Januar 2008, 09:45

Quellcode

1
2
aptitude install locales console-data console-tools console-common
dpkg-reconfigure locales console-data console-tools console-common
NSLU2 (Debian Etch) 266MHz - fantec LD-U35U2 (160GB Maxtor) - 2,5" Samsung 100GB - Canon iP5200 - Acer Bluetooth - gLCD - NFS (dbox2) - Samba (2x Notebook; 1 PC) - CUPS - rTorrent (xmlrpc) - ntp - lighttp + php

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

10

Montag, 21. Januar 2008, 10:52

Wer lesen kann (hier - den Thread) ist klar im Vorteil...
"Supporting joe users worldwide" <- that's our motto


11

Montag, 21. Januar 2008, 12:16

Sorry, verstehe nicht, was Du damit meinst. :o
Die Ursache meines Problems verstehe ich auch nicht. Hast Du noch eine Idee?
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

12

Montag, 21. Januar 2008, 15:32

@ao: caplink hatte es nicht mit dir, sondern mit dem zwar nett gemeinten, aber falschen Post, der hier dpkg und apt-get ins Spiel bringt, was es aber nicht für OpenSlug gibt....

Gruss,
EvilDevil

13

Montag, 21. Januar 2008, 15:53

Achso, klar, das hatte ich einfach überlesen, weil ich sowieso schon 'ipkg install' im Kopf hatte. ;)

Also werde ich mich mal weiter mit NFS beschäftigen, denn so wie ich es verstehe, besteht das Problem ja wohl darin, oder?

Oder anders gefragt:
Wenn ich bereits in der shell (ssh auf der NSLU2) Dateinamen mit korrumpierten Umlauten lese, liegt es nicht an Samba, richtig?

Dann hat es evtl. mit der shell-Umgebung zu tun, oder eben mit NFS. :confused:
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

djk1o

Fortgeschrittener

Beiträge: 332

Wohnort: Berlin

Beruf: Programmierer/Designer

  • Nachricht senden

14

Montag, 21. Januar 2008, 23:04

es gibt kein aptitude oder so? warum steht das ganze dann in der debian apteilung? egal, es wird ja wohl was vergleichbares geben um diese pakete zu installieren, oder gibts die auch nicht?

...komische firmware.... *brabbel*
NSLU2 (Debian Etch) 266MHz - fantec LD-U35U2 (160GB Maxtor) - 2,5" Samsung 100GB - Canon iP5200 - Acer Bluetooth - gLCD - NFS (dbox2) - Samba (2x Notebook; 1 PC) - CUPS - rTorrent (xmlrpc) - ntp - lighttp + php

15

Dienstag, 22. Januar 2008, 06:37

Es steht ja nicht direkt bei Debian, sondern bei OpenSlug. Das war zwar nicht sonderlich gut gewählt, aber es war damals inhaltlich schon näher an DebianSlug als an uNSLUng... ;)

OpenSlug nutzt übrigens ipkg
ipkg install blabla
ipkg remove blabla
Aber es gibt eben kein ipkg-reconfigure usw

Gruss,
EvilDevil

djk1o

Fortgeschrittener

Beiträge: 332

Wohnort: Berlin

Beruf: Programmierer/Designer

  • Nachricht senden

16

Mittwoch, 23. Januar 2008, 23:58

achso? interessant, kann man opensalug nicht vom debian-bereich trennen ;)
manchmal halte ich mich ewig mit suchen auf wo was neues steht und übersehe das openslug immer ;)

ipkg agiert also ähnlich wie aptitude, dann sollte es doch ein dpkg ähnliches teil geben?
wo ist nochmal die liste? www.nslu2-linux.org? ich schau mal rein.
NSLU2 (Debian Etch) 266MHz - fantec LD-U35U2 (160GB Maxtor) - 2,5" Samsung 100GB - Canon iP5200 - Acer Bluetooth - gLCD - NFS (dbox2) - Samba (2x Notebook; 1 PC) - CUPS - rTorrent (xmlrpc) - ntp - lighttp + php

17

Donnerstag, 24. Januar 2008, 06:47

Hi,

zur schnellen Suche von neuen Beiträgen eignet sich der 2. (Heutige Beiträge) bzw 4. Link (Neue Beiträge) von oben rechts(wenn man aus/eingeloggt ist).
ipkg ersetzt das komplette Debian apt-get und dpkg und aptitude System. ipkg [SIZE=-1](Itsy Package Management System) vereint ein paar apt-Tools (zb apt-cache search -> ipkg search, dpkg -l -> ipkg list_installed, ...) und vermeidet viel Kram, den apt und Konsorten mit sich mitschleppen und der auf nem embedded System eher stört. Beispielsweise würde auf nem OpenWrt Router mit 4 MB Flash definitiv kein apt-basierendes System draufpassen.

Gruss,
EvilDevil
PS: Du kannst ja im Forum "Wünsche / Meckerecke" http://nslu2-info.de/forumdisplay.php?f=26 vorschlagen, OpenSlug direkt als eigenes Forum und nicht als Subforum zu verwalten.
[/SIZE]

18

Mittwoch, 5. März 2008, 20:49

Vielen Dank an alle, insbes. djk1o, hat mir sehr geholfen! Tolles Forum hier!

Hinzufügen sollte man allerdings, daß - zumindest bei mir - ein Reboot nötig war, damit die neuen Einstellungen übernommen werden... (an was erinnert mich das?? :eek:

19

Donnerstag, 6. März 2008, 17:49

Nachfrage: Wenn ich an der Konsole (putty)

Quellcode

1
date +%A
eingebe, schreibt der Befehl brav 'Donnerstag'.
Wenn ich diesen Befehl in einem Shell-Script verwende, um einen Dateinamen zu ergänzen (rotate - log), heißt die Datei blabla.Thursday.
Woran liegt das und wie kann ich es abstellen?

Edit: Wenn ich die Scripte per Hand (putty) starte, ist's ok. Wenn die Scripte von crontab gestartet werden: Thursday :confused:

20

Donnerstag, 6. März 2008, 21:24

Zitat von »heinrichh;30957«

Nachfrage: Wenn ich an der Konsole (putty)

Quellcode

1
date +%A
eingebe, schreibt der Befehl brav 'Donnerstag'.
Wenn ich diesen Befehl in einem Shell-Script verwende, um einen Dateinamen zu ergänzen (rotate - log), heißt die Datei blabla.Thursday.
Woran liegt das und wie kann ich es abstellen?

Edit: Wenn ich die Scripte per Hand (putty) starte, ist's ok. Wenn die Scripte von crontab gestartet werden: Thursday :confused:


Wenn du die Skripte in einer SSH Session ausführst, ist die LANG Umgebungsvariable auf de_DE (oder ähnlich) gesetzt

Zitat


env |grep LANG
Sollte dir den eingestellten Wert zeigen.
Wenn du nun die Skripte per crontab startest, ist LANG nicht gesetzt und date gibt das Datum dann in seinen Standardeinstellungen (LANG=C) aus.
Abhilfe ist hier: LANG=de_XXXX /pfad/zu_deinem_skript
in deine crontab einzutragen.

Gruss,
EvilDevil

Social Bookmarks