Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Samstag, 7. April 2007, 20:52

Openslug bootet nicht mehr von SDA1

Hallo,

ich hatte ca. ein halbes Jahr OpenSlug 3.1 im Einsatz:

Auf einer USB-Platte

SDA1: ca. 10 GB root
SDA 2: swap
SDA3: /opt ... hier lagen meine Daten.

Heute bootet OpenSlug in einen ReadOnly Modus. Nach Analyse von DMESG sah es so aus, als sei ein fsck fällig. Ich habe das System dann gestoppt, die USB-Platte an einen Rechner mit Knoppix gehängt und fsck laufen lassen.

In SDA1 gab es einiges zu reparieren, SDA3 lief problemlos durch.
Anschließend die Platte wieder an die SLUG gehängt ... und zu meinem großen Erstaunen wird nicht mehr vom SDA1 der Platte gebootet, sondern wohl vom internen Flash System.

df zeigt beispielsweise folgendes:

Filesystem 1k-blocks Used Available Use% Mounted on
/dev/mtdblock4 6528 5528 1000 85% /
/dev/mtdblock4 6528 5528 1000 85% /dev/.static/dev
tmpfs 10240 28 10212 0% /dev
/dev/sda1 9621848 634556 8498516 7% /media/sda1
tmpfs 15148 20 15128 0% /var
tmpfs 15148 0 15148 0% /media/ram

Ich habe dann in den FAQs geblättert und einen Artikel gefunden, nach dem man eine bestimmte .recovery Datei löschen muss. Die existiert leider auf meinem System nicht.

Any Ideas?

Gruß

Rigas

Anzeigen

Social Bookmarks