Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

13.02.2006, 18:41

Zugriffszeit auf Festplatte

Erst mal Grüss Euch!!!

Die Transfergeschwindigkeit von 2-3MB wäre mir ja noch egal, aber die Zugriffszeit auf die Festblatte oder deren Ordner ist sehr lang. Es sind ca.30-45 Sekunden und mir kommt vor je mehr auf der Disc ist um so länger dauert es.

Ist das normal?

Ich habe einen NSLU2 mit original Firmware v.2.3 R63 mit einer Seagate Baraccuda 300GB an einem D-Link DI-624+ W-Lan Router.

Anzeigen

2

13.02.2006, 21:47

"Normal" sind etwa 4-5MB/s. Die Zugriffzeit auf einen Ordner hängt stark von dem Inhalt ab. Bei ein paar tausend Dateien und eingeschalteter Vorschau kann das unter Windoof eine Weile dauern.

Anzeigen

3

01.03.2006, 22:28

Vielleicht habe ich (bei einem Bekannten) ein ähnliches Problem.

Wenn ich über den Browser (durch Eingabe der IP) auf die NSLU2 zugreife, geht es ruckzuck bis die Ordner geöffnet, bzw. deren Inhalt angezeigt wird.

Gehe ich über Windows dauert jeder neue Zugriff ewig (ca. um 60 Sekunden), und das bei beiden PC´s am Netzwerk (WinXPprof u. Win2000)! Der Zugriff der beiden PC´c untereinander auf freigegebene Ordner klappt auch einwandfrei.

Die NSLU2 mit der Festplatte habe ich zuhause getestet, einwandfrei. Hänge ich sie an das andere Netzwerk, habe ich die beschriebenen Probleme.

Es ist mir unverständlich, wieso es einen solchen Zeitunterschied gibt, je nach dem ob ich über Browser oder über Windows-Explorer zugreife, auch bei Linksys hat man keine Erklärung (außer das es wohl an den PC´s liegen muss...)

Gruß
Klaus

4

02.03.2006, 15:38

Hast Du mal geprüft, ob in den Namensauflösungdateien von Windows die NSLU2 eingetragen ist?

Das ist für SMB Zugriffe:

C:\WINDOWS\system32\drivers\etc\lmhosts

und für die normalen IP Dienste (Ping, telnet, Browser etc):

C:\WINDOWS\system32\drivers\etc\hosts

Evtl. liegt es an dem mühsehligen Broadcast der sonst erfolgt.

Whatever

5

02.03.2006, 18:12

Zitat von »whatever«

Hast Du mal geprüft, ob in den Namensauflösungdateien von Windows die NSLU2 eingetragen ist?

Das ist für SMB Zugriffe:

C:\WINDOWS\system32\drivers\etc\lmhosts

und für die normalen IP Dienste (Ping, telnet, Browser etc):

C:\WINDOWS\system32\drivers\etc\hosts

Evtl. liegt es an dem mühsehligen Broadcast der sonst erfolgt.

Whatever

Also ganz ehrlich, damit kann ich gar nichts anfangen.
In die NSLU2 habe ich gar nichts eingetragen.

Sollte ich Inforamtionen aus system32 in die NSLU2 eintragen, oder soll ich in c:windows\system32.... etwas ändern?

Wie beschrieben, die NSLU2 läuft mit meinem Rechner einwandfrei, nehe ich sie mit und schließe sie dann an den anderen beiden Rechnern (über den Switch im Router) an, hängt sie....

Gruß
Klaus

6

03.03.2006, 08:41

Hallo!

Die beiden angegebenen Dateien regeln die IP Namens Auflösung auf den Windows PCs (nicht auf der NSLU2).

Schau sie Dir mal an (z.B lmhost.sam) und lies die Kommentare durch (alle Zeilen mit # sind Kommentare).

Es genügt die "lmhost.sam" Beispiel-Datei auf "lmhost" umzukopieren und am Ende eine Zeile in der Form hinzuzufügen:
<ip-addresse-der-NSLU2> <Name-der-NSLU2> #PRE
Also als Beispiel (bitte natürlich anpassen)
192.168.1.77 goliath #PRE

Zusätzlich sollte noch in der hosts Datei (im gleichen Verzeichnis) das gleiche eingetragen werden (ohne das #PRE).
Also wieder als Beispiel
192.168.1.77 goliath

Auf der NSLU2 musst Du nichts ändern.

Was passiert denn jetzt (ohne diese Einträge), wenn Du in einem "Eingabe-Aufforderung" ("DOS-") Fenster einen ping auf den NSLU2 Namen absetzt?
Also: ping goliath (bitte natürlich goliath durch den Namen deiner NSLU2 ersetzen). Sollte nämlich erstmal ein Timeout kommen.

--> Der ping sollte dann nach den oben getätigten Einträgen gehen und ich vermute dass dann bei deinem Bekannten auch die Zugriffe über den Namen genauso schnell sind wie über die IP.

Whatever

7

03.03.2006, 10:41

Danke für die Infos.

Gepingt hatten wir schon (Vorschlag der Linksys-Hotline).

Die Antwortzeiten, wenn man die IP der NSLU2 pingt, betragen ca 15ms (über Router).
Wir haben dann noch die NSLU2 direkt an einen Rechner gehängt, da kam dann 1-2ms raus.

Pingen geht also, die Dateien lassen sich ja über die Weboberfläche der NSLU2 auch blitzschnell erreichen und auch öffnen.

Die selben Dateien über das Windoff-Netzwerk, und alle Aktionen erfolgen mit deuticher Verzögerung, also 30sek - 1Minute!

Greife ich über Windows-Netzwerk auf einen anderen Rechner im Netzwerk zu (freigegebene Ordner) geht auch das blitzschnell......

Gruß
Klaus

8

03.03.2006, 14:48

Die Frage ist halt, ob Du beim Ping anstatt der IP auch den Namen angeben kannst.

Das Windows-Netz basiert ja zunächst auf \\servername\share und der Servername muss erst in eine IP umgewandelt werden.

Von dem was Du weiter oben geschrieben hattest, vermute ich dass es bei dieser Namensauflösung zu den Verzögerungen kommt. Deshalb mein Vorschlag die hosts bzw. lmhosts Dateien zu editieren.

Whatever

9

04.03.2006, 13:16

Jetzt verstehe ich was du meinst, gerade habe ich mal meine NSLU2 geping, diesmal mit dem Servernamen, und das klappt, 1ms. Aber bei mir funktioniert ja auch alles. Jetzt werde ich also die andere NSLU2 wieder einpacken und bei meinem Bekannten ebenfalls den Servernamen pingen, wenn es dann diese Verzögerungen gibt, würde es an der Auflösung des Servernamens in die IP liegen, und dann müssten wir editieren...

Das Ergebnis werde ich auf jeden Fall hier posten, wäre ja interessant, ob der ursprüngliche Fragensteller sein Problem gelöst hat, und wenn ja, wie.

Gruß und Danke
Klaus

10

04.03.2006, 17:05

Grüss Euch!

Eine Lösung habe ich nicht.

Ich habe den NSLU2 auch an einem D-Link 624+ W-Lan Router hängen.
Bei mir ist es so das der Festplattenzugriff aus der Netzwerkumgebung ca. 1 min 20 und der zugriff auf Unterordner ca. 40sek. dauert.

Jetzt habe ich das versucht was Whatever vorgeschlagen hat und muss feststellen das es bei mir nichts bringt. Laut Pingtest <1ms. Der NSLU2 ist zwar mit 266MHz schneller geworden, aber nicht erwenenswert, ausser beim Kopieren jetzt ca. 45Mbits/s

Mir kommt vor je mehr auf der Platte ist um so länger dauert es. Ich klaub das die Rechenleistung und der RAM für die Übermittlung der Ordner und Dateiinformationen zu wenig ist.

Für mich heist das NSLU2 Adieu, Mini ITX Willkommen.

LG Bertl

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

11

04.03.2006, 17:21

Tach,

Hm, hast Du in Deinem Router auch uPNP abgeschaltet, und in der NSLU2 ebenso ?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


12

05.03.2006, 11:52

@Bertl

Wir haben zwei NSLU2 und zwei HD´s dazu, eine habe ich zu Hause, eine gehört einem Bekannten von mir.

Hier bei mir gibt es keine Probleme, ich habe alle meine "Eigenen Dateien" mit allen Unter und Unteruterordnern draufkopiert (fast 1 GByte) direkt über eine Verknüpfung auf dem Desktop, bei ersten Kontakt mit der NSLU2 gebe ich meine Benutzerdaten ein, und dann ist das fast wie ein lokaler Ordner, auch auf meinem Win98SE PC gibt es keinerlei Probleme.

Das zweite Gerät habe ich auch hier bei mir getestet, keine Probleme, rattenschnell.

Mit der Arbeitsgeschwindigkeit des NSLU2-Prozessor hat das also nichts zu tun.

NSLU2 mit der dazu gehörenden Festplatte an das andere Netzwerk und nix geht mehr.... ca. 1Minute bis das Ding reagiert. Und wie gesagt, direkt über die IP und die Oberfläche der NSLU gehts ja auch ruckzuck.

Mit den Problemen bei der Übersetzung des Namens in eine IP das leuchtet mir ein, leider habe ich davon keine Ahnung. Erst mal werde ich nun die NSLU2 wieder ins Problemnetz mitnehmen und den Namen pingen. Auch werde ich mein Notebook mitnehmen um zu sehen, ob es dort genau so läuft wie hier. Und dann werde ich mal versuchen zu verstehen, wie und wo denn nun der Name übersetzt wird.

Frage: Kann ich nicht eine Verknüpfung in Windows mit einem Netzwerkordner machen und dabei direkt die IPverwenden (anstatt des Servernamens), dann müsste das Problem doch auch gelöst sein, oder?

Gruß
Klaus

13

05.03.2006, 16:19

Grüsse

@caplink811

Das mit den uPNP abschalten habe ich probiert, hilft nichts.

@klaussc

1GB ist gut da war er auch noch schnell, ich habe ca. 150GB drauf.

Welche Marke ist der Router mit dem Du das Problem hast, den über sieben Ecken habe ich erfahren das es noch einen gibt der das Problem hat. Der hat auch einen D-Link Router. Vielleicht ist der Router schuld.

Zusatzinfo: Ich habe ein Notebook und einen PC bei beiden diese Probleme.

LG Bertl

14

05.03.2006, 18:08

Grüsse!



Ich habs geschaft das der NSLU2 nur 20sek. zum Öffnen eines Ordners oder Datei braucht!!!

Die Lösung ist in der Netzwerkumgebung auf Ordner, in der Symbolleiste, zu klicken und dort die Netzwerkverbindung usw. mit dem + öffnen bis man zur HDD kommt. Dort macht man weiter bis man zu dem Ordner kommt den man öffnen will. Den muss man dan Doppelklicken damit man den Inhalt rechts im Fenster sieht.

Bei mir gehts neht so schlecht, könnt aber noch schneller gehen.

LG Bertl

15

09.03.2006, 17:25

Zitat von »Bertl«

Grüsse

@klaussc

1GB ist gut da war er auch noch schnell, ich habe ca. 150GB drauf.

Welche Marke ist der Router mit dem Du das Problem hast, den über sieben Ecken habe ich erfahren das es noch einen gibt der das Problem hat. Der hat auch einen D-Link Router. Vielleicht ist der Router schuld.

Zusatzinfo: Ich habe ein Notebook und einen PC bei beiden diese Probleme.

LG Bertl

Es handelt sich um einen "Netgear" http://www.netgear.de/Produkte/Router/Firewall/FWG114P/

Die Probleme treten dort auch mit beiden Rechnern auf.

Bei mir zuhause funktioniert es dagegen einwandfrei (mit XP und 98SE) allerdings habe ich eine FRITZ-Box 7050.

Gruß
Klaus

16

09.03.2006, 21:20

Hallo
Schnell ne Frage... der Datentransfer zu meiner 320gb WD-Platte (EXT3) am NSLU2 (via Router) ist extreeeeem langsam. Per FTP schaufelt das Ding mit sage und schreibe 250 bis max. 350 kb/s !! Das ist doch nicht normal oder?! Ich benutze die Firmware V2.3RA5

gruss
tinu

17

22.03.2006, 08:45

Workgroup/Domain gleich ??

Hi, auch auf die Gefahr hin, daß das Problem schon gelöst ist.

Solche eklatanten Zeitverzögerungen beobachte ich im Explorer Browsing immer dann, wenn ich mit meinem Laptop, der in der Domain/Workgroup "Firma" ist, in mein Heimnetz mit der Workgroup "Heimnetz" gehe. Alle Rechner, die in der gleichen Workgroup sind, können die Freigaben blitzschnell browsen..
Das ist auch alles logisch und nachvollziehbar, vielleicht hat euer Problem ja damit zu tun....

18

22.03.2006, 08:51

..hatte ich grad hier schon mal gepostet.... Könnte das Problem sein, wenn Client und NAS nicht in der gleichen Workgroup/Domain sind. Hört sich fast so an, wenn ich lese, daß ihr euren NAS von einem Kumpel zum nächsten tragt... dann funktioniert das Explorer Browsing nicht richtig, was ja auch logisch ist. Da habe ich dann auch Antwortzeiten von 30-60 Sekunden, bis ich den NAS browsen kann. Da helfen dann auch lmhosts und hosts Einstellungen nicht, weil Windows/netbios das quasi wie 2 getrennte Netze behandelt...

19

22.03.2006, 08:52

hupps....ich sollte mal richtig posten lernen...

20

22.03.2006, 08:57

Zum Thema FTP: bedenkt die "maximum TCP Window Size" im Windows TCP Stack! ..also die Datenmenge, die Windows auf die Leitung schickt, bis es einen Acknowledge erwartet. Tritt ganz stark bei FTP über Transatalantik Verbindungen auf, wo die Antwortzeit bei ca. 100-300 ms liegt, die Bandbreite aber hoch ist, z.B. 45Mbit/s. Da gibts dann immer dumme Gesichter, "wieeeesssooooo kriege ich keine volle Geschwindigkeit beim FTP".

Zur Zeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Social Bookmarks