Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Mittwoch, 28. März 2007, 20:21

appWeb startet nicht

Hallo!

Ich betreibe eine NSLU2 mit uNSLUng 6.8 beta. TwonkyMediaserver läuft prima, nur der Versuch appWeb zu installieren ist leider gescheitert.
Das appWeb ist Bestandteil von miniLAMP, welches ich mir bei minilamp.de gezogen hab. Da ich leider blutiger Linuxanfänger bin, hoffe ich das mir jemand den error Meldung(en) erläutern kann:

default:2 main Configuration for Mbedthis AppWeb
default:2 main --------------------------------------------
default:2 main Host: NSLU
default:2 main CPU: armv5b
default:2 main OS: LINUX
default:2 main Version: 2.1.0.1
default:2 main BuildType: RELEASE
default:2 main Started at: Wed Mar 28 20:00:56 2007
default:2 main Log rotation count: 0
default:2 main --------------------------------------------
default:2 main Set log level for all modules to 9
default:2 main Document Root for 192.168.178.77:80:
"/opt/var/appWeb/web"
default:2 main Module search path:
"/opt/lib"
default:3 main Loading DLL /opt/lib/libadminModule.so
default:2 main Activating module (Loadable) admin
default:3 main Loading DLL /opt/lib/libauthModule.so
default:2 main Activating module (Loadable) auth
default:3 main Loading DLL /opt/lib/libcgiModule.so
default:2 main Activating module (Loadable) cgi
default:3 main Loading DLL /opt/lib/libcopyModule.so
default:2 main Activating module (Loadable) copy
default:3 main Loading DLL /opt/lib/libegiModule.so
default:2 main Activating module (Loadable) egi
default:3 main Loading DLL /opt/lib/libespModule.so
default:7 main mprCreateObjVar master, 0x1d2d8
default:2 main Activating module (Loadable) esp
default:3 main Loading DLL /opt/lib/libcapiModule.so
default:2 main Activating module (Loadable) capi
default:3 main Loading DLL /opt/lib/libphp5Module.so
default:2 main Activating module (Loadable) php5
default:3 main Loading DLL /opt/lib/libsslModule.so
default:2 main Activating module (Loadable) ssl
default:3 main Loading DLL /opt/lib/libopenSslModule.so
default:2 main Activating module (Loadable) openSsl
default:2 main Add authHandler
default:2 main Add egiHandler for ".egi"
default:2 main Add cgiHandler for ".cgi .cgi-nph .bat .cmd .pl .py"
default:2 main Add espHandler for ".esp .asp"
default:2 main Add php5Handler for ".php"
default:2 main Add copyHandler
httpServer:4 main Alias: "/cgi-bin/":
"/opt/var/appWeb/web/cgi-bin/"
httpServer:4 main insertAlias: Redirect 303 from "/doc/" to "http://www.appwebserver.org/products/appWeb/doc/"
httpServer:3 main Host 192.168.178.77:80, KeepAlive: on
default:2 main Document Root for 192.168.178.77:4443:
"/opt/var/appWeb/web"
httpServer:4 main Alias: "/doc/":
"/opt/var/doc/"
httpServer:2 main ServerName set to: 192.168.178.77:80
default:5 main Starting module admin
default:5 main Starting module auth
default:5 main Starting module cgi
default:5 main Starting module copy
default:5 main Starting module egi
default:5 main Starting module esp
default:5 main Starting module capi
default:5 main Starting module php5
default:5 main Starting module ssl
default:6 main OpenSsl: Before calling RAND_load_file
default:6 main OpenSsl: After calling RAND_load_file
default:4 main SSL: 192.168.178.77:4443: Using ciphers ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
default:4 main SSL: 192.168.178.77:4443: Disabling SSLv2
default:5 main Starting module openSsl
default:5 main Starting handler adminHandler
default:5 main Starting handler authHandler
default:5 main Starting handler cgiHandler
default:5 main Starting handler copyHandler
default:5 main Starting handler egiHandler
default:5 main Starting handler espHandler
default:5 main Starting handler php5Handler
default:0 main phpModule: PHP Warning: PHP Startup: bcmath: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: bz2: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: calendar: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: dba: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: dom: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: exif: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: ftp: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: openssl: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: shmop: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: sockets: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: sysvmsg: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: sysvsem: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: sysvshm: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: xml: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: Unable to load dynamic library '/opt/lib/php/extensions/xsl.so' - /opt/lib/php/extensions/xsl.so: undefined symbol: dom_node_class_entry in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: zlib: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: mysql: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: PHP Startup: mysqli: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
in Unknown on line 0 default:0 main phpModule: PHP Warning: [eAccelerator] This build of "eAccelerator" was compiled for PHP version 5.1.4. Rebuild it for your PHP version (5.1.6) or download precompiled binaries.
in Unknown on line 0 default:0 main phpModule: PHP Fatal error: Unable to start eAccelerator module in Unknown on line 0
# ENDE error log

Vielen Dank im voraus!

Anzeigen

2

Freitag, 30. März 2007, 14:40

Hallo!

So wie es scheint, passt die von Dir verwendete PHP Version (genauer bestimmte Module wie "bcmath" u.a.) nicht mit dem im appWeb einkompilierten PHP zusammen.

Quellcode

1
2
3
4
    default:0 main  phpModule: PHP Warning:  PHP Startup: bcmath: Unable to initialize module
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP    compiled with module API=20050922, debug=0, thread-safety=1
These options need to match


Du sagst, Du hast Dir den appWeb über miniLAMP organisiert?
Das heisst, Du hast Dir das dortige Image gezogen. Das PHP und appWeb auf dem Image passen jedoch zusammen.
Was hast Du noch gemacht, nachdem Du das miniLAMP Image "down-ge-loadet" hattest?


Whatever

Anzeigen

3

Freitag, 30. März 2007, 14:44

Sehe gerade Du verwendest die appWeb Version 2.1.0.1.

Auf dem miniLAMP Image ist aber noch die ältere Version 2.0.5, da es Probleme u.a. mit der "index.html" Erkennung bei der 2.1. Version gibt.
=> Hast Du da noch einen Upgrade von appWeb gemacht? Das würde den Fehler erklären.

Whatever

4

Freitag, 30. März 2007, 15:46

Hallo Whatever!

Ja genau, ich habe (leider) den appWeb server upgegradet...

Gibt es eine Moeglichkeit downzugraden:confused:

5

Freitag, 30. März 2007, 17:59

... nicht dass ich wüsste.
Aber evtl. weiss jemand anderes da besser Bescheid als ich. Ich bin kein ipkg Profi.

Whatever
/PS: Save early, save often...

6

Samstag, 7. April 2007, 21:24

Habe das miniLAMP image noch mal neu auf meinem USB stick geschrieben.
Jetzt funzt wieder alles wunderbar.

Danke an whatever!

Aehm, hab' jetzt aber ein neues Problem... Siehe neuen thread:rolleyes:

Social Bookmarks