Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

16.09.2008, 17:58

mtr Version 0.74-1

Hi!

Habe heute mit ipkg ein upgrade gemacht und seit dem geht mtr nicht mehr mit dem Fehler:

mtr: Couldn't determine raw socket type.

Wenn ich den Quellcode richtig gefunden habe unter scheint das auch einen neue Prüfung zu sein - nutzt das noch jemand - weiß jemand wieso das jetzt nicht mehr geht?

Danke!
__________________
DS207+ mit 2x500GB Samsung HD501LJ - Raid 1

Anzeigen

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

2

16.09.2008, 20:21

AW: mtr Version 0.74-1

N'Abend,

mal mtr -a Adress -4 probiert?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Anzeigen

3

16.09.2008, 20:38

AW: mtr Version 0.74-1

Ebenso Nabend,

danke für die Antwort - aber leider scheint sich diese Version für absolut keine Parameter zu interessieren - wenn ich den Quellcode richtig verstehe ist diese komische Abfrage die zu dem Fehler führt auch das erste was passiert wenn man das Programm startet... kann ich auch mit strace nachvollziehen. Weiß echt nicht wieso sowas komisches geändert wurde. Weiß jemand wo ich noch die 0.72-Version wieder her bekommen als ipkg?

Danke!

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

4

17.09.2008, 17:08

AW: mtr Version 0.74-1

Ja...

bye
JrB

PS: Attachments scheinen noch nicht so zu klappen, deshalb http://jrbnet.de/texte/mtr_0.72-1_armeb.ipk
"Supporting joe users worldwide" <- that's our motto


5

17.09.2008, 18:04

AW: mtr Version 0.74-1

Danke - jetzt bin ich aber wohl zu doof für das hier:

install <file.ipk> Install package <file.ipk>

Egal was ich mache - er holt sich immer wieder die aktuelle Version aus dem Netz. Hmmm

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
NAS> ipkg -force-downgrade -V 3 install $PWD/mtr_0.72-1_armeb.ipk
pkg_info_preinstall_check: updating arch priority for each package
Clearing state_want and state_flag for pkg=mtr (arch_priority=0 flag=16 want=2)
pkg_info_preinstall_check: update file owner list
best installation candidate for mtr
 adding mtr to providers
  mtr arch=arm arch_priority=10 version=0.74-1
  mtr arch=armeb arch_priority=0 version=0.72-1
 Found a valid candidate for the install: mtr 0.74-1
arch arm (priority 10) supported for pkg mtr
Installing mtr (0.74-1) to root...
Downloading http://ipkg.nslu2-linux.org/feeds/optware/syno-x07/cross/unstable/mtr_0.74-1_arm.ipk

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

6

17.09.2008, 18:27

AW: mtr Version 0.74-1

Moin,

Du hast eine der großen unbeantworteten Fragen der Menschheit entdeckt... Ich kenne die Antwort auch nicht, weiß aber, das ein IPK auch nur ein tar.gz mit weiteren tar.gz drinnen ist, also kannst Du die Binary aus dem IPK extrahieren, und wohl nach /opt/sbin kopieren.

bye
JrB
"Supporting joe users worldwide" <- that's our motto


7

19.09.2008, 17:21

AW: mtr Version 0.74-1

Hatte ich versucht und das ging gar nicht könnte es daran liegen das deines für "armeb" war und nicht nur "arm"? Jedenfalls wollte er das bin patu nicht starten. :-(
Ich habe ein: ARM926EJ-Sid(wb) rev 0 (v5l) wenn das hilft?
Hat denn sonst keiner ein Problem mit dem paket in der Version? Wo kann ich denn noch gucken damit es bei mir evtl. auch in der 0.74 läuft?

8

19.09.2008, 20:17

AW: mtr Version 0.74-1

Ha - bei dem Entwickler hat man meine Fehlermeldung auch erhört:

Zitat

The 0.74 version stops with: Couldn't determine raw socket type. if your kernel doesn't support IPV6. I suggest you upgrade to 0.75 (released today)


Wer kann das kompelieren für eine DS207+ ? Ich bin da irgendwie nicht so der Krack :-o

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

9

19.09.2008, 20:49

AW: mtr Version 0.74-1

N'Abend,

ich werde mich etwas geisseln müssen, ich habe Deinen Footer nicht gelesen, und NSLU2 angenommen...

bye
JrB

PS: Wenn Du mir die richtige Plattform verrätst kann ich das auch kompilieren
"Supporting joe users worldwide" <- that's our motto


10

19.09.2008, 21:05

AW: mtr Version 0.74-1

Was musst Du denn genau wissen?

# uname -a
Linux NAS 2.6.15 #717 Fri Sep 5 00:53:18 CST 2008 armv5tejl unknown

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

11

20.09.2008, 22:01

AW: mtr Version 0.74-1

N'Abend,

V0.75, ich weiß nicht ob die Plattform stimmt...

Hochladen klappt wieder nicht, also wie gehabt, http://jrbnet.de/texte/mtr.zip

bye
JrB
"Supporting joe users worldwide" <- that's our motto


12

20.09.2008, 22:25

AW: mtr Version 0.74-1

Danke, es lässt sich zwar starten aber kommt mit:

Couldn't get fd's flags: Bad file descriptor

Rechte sind identisch zu der Version davor - also mit s-bit für user. Welche fd er nicht findet sagt er ja leider nicht :-o

Social Bookmarks