Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

08.11.2007, 14:22

IPKG beinhaltet nicht alle Pakete

Hallo!

Ich hoffe es ist mir niemand böse, wenn ich als Neuling direkt einen neuen Thread eröffne, aber ich finde seit Tagen keine Lösung für mein glaube ich gar nicht so kompliziertes Problem.

Ich finde das apache Paket in meiner ipkg-liste, ipkg findet es zum installieren aber nicht. Woran liegt das?

Ich mache folgendes:

ipkg updaten -> check

Quellcode

1
2
3
4
5
6
7
8
9
root@Slug:/etc# ipkg update
Downloading http://ipkg.nslu2-linux.org/feeds/openslug/native/3.10-beta/Packages
Updated list of available packages in /var/lib/ipkg/rbm
Downloading http://ipkg.nslu2-linux.org/feeds/slugos-lag/cross/3.10-beta/Packages.gz
Inflating http://ipkg.nslu2-linux.org/feeds/slugos-lag/cross/3.10-beta/Packages.gz
Updated list of available packages in /var/lib/ipkg/cross
Downloading http://ipkg.nslu2-linux.org/feeds/slugos-lag/native/3.10-beta/Packages.gz
Inflating http://ipkg.nslu2-linux.org/feeds/slugos-lag/native/3.10-beta/Packages.gz
Updated list of available packages in /var/lib/ipkg/native


liste durchsuchen -> check

Quellcode

1
2
3
4
5
6
7
root@Slug:/etc# ipkg list | egrep apache
apache - 2.0.54-r4 - Version 2.0.54-r4 of package apache
apache-dev - 2.0.54-r4 - Version 2.0.54-r4 of package apache
apache-doc - 2.0.54-r4 - Version 2.0.54-r4 of package apache
libapr-0-0 - 2.0.54-r4 - Version 2.0.54-r4 of package apache
libaprutil-0-0 - 2.0.54-r4 - Version 2.0.54-r4 of package apache
perl-module-cgi-apache - 5.8.7-r15 - perl module cgi-apache


apache installieren -> fehler?

Quellcode

1
2
3
4
5
6
root@Slug:/etc# ipkg install apache
Nothing to be done
An error ocurred, return value: 4.
Collected errors:
Cannot find package apache.
Check the spelling or perhaps run 'ipkg update'


Ich würde mich sehr freuen, wenn mich jemand kurz mit der Nase auf meinen Fehler stoßen könnte, denn der tipp von ipkg ich soll mal nen update machen ist nicht sehr hilfreich ;)

Danke :)

VG slowmo

Anzeigen

Eiffel

Profi

Beiträge: 619

Beruf: SAP Anwendungsbetreuer

  • Nachricht senden

2

14.11.2007, 14:04

probier mal
ipkg install unslung-feeds
ipkg update
ipkg install apache

ipkg list | grep pache zeigt bei mir zZ folgendes an
apache - 2.2.6-4 - The most popular web server on the internet
apache-manual - 2.2.6-4 - Online documentation for the apache webserver
apr - 1.2.11-1 - Apache Portable Runtime library
apr-util - 1.2.10-4 - Apache Portable Runtime utilities library
mod-fastcgi - 2.4.2-3 - mod_fastcgi is an Apache module providing language independent, scalable, open extension to CGI.
mod-python - 3.3.1-1 - Mod_python is an Apache server module that integrates with the Python language.
mod-wsgi - 1.0-1 - An Apache module that provides a WSGI compliant interface for hosting Python based web applications within Apache.
php-apache - 5.2.4-1 - The php scripting language, built as an apache module

Anzeigen

Social Bookmarks