Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Paule

Anfänger

  • »Paule« ist der Autor dieses Themas

Beiträge: 46

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

1

25.10.2007, 11:33

FTP läuft nicht (mehr)

Aufgrund eines Festplatten-Crashes mußte ich mein System wieder in Gang bringen.
Habe eine neue HDD angeschlossen, formatiert und unsling durchgeführt. Danach habe ich verschiedene ipkg-Pakete installiert. Unter anderem auch vsftpd.
Mit dieser Anleitung habe ich den Autostart aktiviert. Beim ersten mal hat das auch tatsächlich geklappt.

Ich habe, also ich noch per FTP mit der NSLU2 verbunden war mit dem Linux-Editor vi die Datei /share/hdd/conf/passwd geöffnet, aber nichts geändert. Seit dem komm ich nicht mehr per FTP auf die Slug. Im Client steht zwar "Connected to NSLU2", aber danach passiert nichts mehr. Reboot hat auch nichts gebracht.

Gruß

Anzeigen

Paule

Anfänger

  • »Paule« ist der Autor dieses Themas

Beiträge: 46

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

2

25.10.2007, 13:52

Folgende Prozesse laufen:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
# ps -w
  PID  Uid        VSZ Stat Command
    1 root       1212 S   /bin/init
    2 root            SW  [keventd]
    3 root            SWN [ksoftirqd_CPU0]
    4 root            SW  [kswapd]
    5 root            SW  [bdflush]
    6 root            SW  [kupdated]
    7 root            SW  [mtdblockd]
    8 root            SW  [khubd]
    9 root            SWN [jffs2_gcd_mtd4]
   10 root            SW  [usb-storage-1]
   11 root            SW  [scsi_eh_1]
   29 root            SW  [kjournald]
   53 root            DW  [ixp425_csr]
   54 root            SW  [ixp425 ixp0]
   57 root       1916 S   /bin/sh
   58 root       1936 S   /sbin/syslogd -n
   59 root       1924 S   /sbin/klogd -n
  151 root            SW  [kjournald]
  203 root       9884 S   upnpd &>/dev/null
  211 root       9884 S   upnpd &>/dev/null
  212 root       9884 S   upnpd &>/dev/null
  215 root       9884 S   upnpd &>/dev/null
  216 root       9884 S   upnpd &>/dev/null
  217 root       9884 S   upnpd &>/dev/null
  313 root       2120 S   /usr/sbin/thttpd -C /etc/thttpd.conf
  337 root       3920 S   /usr/sbin/smbd -D
  339 root       3128 S   /usr/sbin/nmbd -D
  377 root       1864 S   /usr/sbin/onetouch_detect
  378 root       1864 S   /usr/sbin/onetouch_detect
  390 root       1296 S   /usr/sbin/crond
  396 root       1908 S   /usr/sbin/CheckResetButton
  398 root       1196 S   /usr/sbin/CheckPowerButton
  400 root       1196 S   /usr/sbin/do_umount
  434 root       2280 S   /opt/sbin/xinetd
  441 bin        1224 S   /opt/sbin/portmap
  456 root       1336 S   /opt/sbin/statd
  460 root            SW  [nfsd]
  462 root            SW  [lockd]
  463 root            SW  [rpciod]
  464 root       1480 S   /opt/sbin/mountd
  488 root       1256 S   telnetd
  489 root       2232 S   -sh
  498 root       4368 S   /usr/sbin/smbd -D
  502 root       2296 R   ps -w
#

# df
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/sda1            307489140   1109840 303255384   0% /share/hdd/data
/dev/sda2               116661      4150    111307   4% /share/hdd/conf
df: swap: No such file or directory


Vielleicht hilft's ja weiter...

Hier der Beleg dafür, daß ich tatsächlich eingeloggt war heute:

Quellcode

1
2
3
# tail -f /opt/var/log/vsftpd.log
Thu Oct 25 10:30:02 2007 [pid 430] CONNECT: Client "192.168.1.1"
Thu Oct 25 10:30:02 2007 [pid 429] [dbox] OK LOGIN: Client "192.168.1.1"

Seither funzt es ned mehr *heul*

Anzeigen

Paule

Anfänger

  • »Paule« ist der Autor dieses Themas

Beiträge: 46

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

3

29.10.2007, 17:13

*räusper*

Niemand, der mir nen heißen Tipp geben könnte???

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

4

29.10.2007, 17:58

Tach,

evtl. erstmal den Swap wieder aktivieren, dann upnp deaktivieren (braucht eh keiner), und dann die Enttscheidung treffen, wie Du den FTP Daemonen eigentlich startest...

In der von Dir genannten Anleitung wird er über den Linksys Inetd gestartet, auf Deinem System läuft aber ein XInetd, der anscheinend nicht richtig konfiguriert ist...

bye
JrB

PS: Hinweise zur XInetd Konfiguration http://jrbnet.de/joomla/content/view/32/1/
"Supporting joe users worldwide" <- that's our motto


Paule

Anfänger

  • »Paule« ist der Autor dieses Themas

Beiträge: 46

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

5

31.10.2007, 09:13

Nachdem nichts mehr lief, habe ich Unslung 6.8 geflasht und nochmal unsling ausgeführt. Die Platte hängt jetzt an Port 2 (wie in der readme beschrieben).

Habe dann vsftpd nach der selben Anleitung nochmal installiert. Jetzt stelle ich folgenden Effekt fest. Wenn ich die Slug boote und dann per FTP drauf will, klappt es nicht. Aktiviere ich Telnet per http://192.168.1.77/Management/telnet.cgi, geht plötzlich auch FTP. Deaktiviere ich Telnet wieder, klappt FTP immer noch. Das klappt so lange, bis ich die Slug neu boote. Dann muß ich erst Telnet aktiviere, damit FTP läuft.

Komisch, komisch...

Kleine Verständnisfrage:
Ist es richtig, wenn ich die HDD an Port 2 habe, daß die Pfade nicht /share/hdd, sondern /share/flash sind???

Gruß
-Paule

Social Bookmarks