Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

yauser

Anfänger

  • »yauser« ist der Autor dieses Themas

Beiträge: 6

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

1

15.08.2007, 10:31

ipkg paket installieren <file> - niedrigere version

moin moin!

motivation:
ich möchte gerne ein rtorrent in der version 0.6.4 mit der zugehörigen libtorrent 10.4.0 installieren...

hintergrund:
auf meinem ALT tracker ist nur diese Version freigegeben
die aktuellste rtorrent version hatte ich schon installiert,
habe diese mit

Quellcode

1
2
ipkg remove rtorrent
ipkg remove libtorrent
auch schon wieder entfernt - es lief alles...

dateien:
http://ipkg.nslu2-linux.org/feeds/optwar…2/cross/stable/
libtorrent_0.10.4-1_armeb.ipk
rtorrent_0.6.4-2_armeb.ipk

problem:
es wird immer die neuste version runtergeladen.

bisherige vorgehehensweise:
der ipkg hilfe und google-suchen habe ich entnommen, dass man entweder eine bestimmte file installieren kann oder eine webressource angeben kann, leider klappt beides nicht direkt, denn er holt sich per wget immer die aktuelle version:

versuch mit lokaler datei:

Quellcode

1
2
3
4
5
ipkg install /tmp/libtorrent_0.10.4-1_armeb.ipk http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/libtorrent_0.10.4-1_armeb.ipk
Downloading http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/libtorrent_0.10.4-1_armeb.ipk
Installing libtorrent (0.11.5-1) to root...
Downloading http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/libtorrent_0.11.5-1_armeb.ipk
ipkg Configuring libtorrent
versuch mit web-ressource

Quellcode

1
2
3
4
5
ipkg install http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/libtorrent_0.10.4-1_armeb.ipk
Downloading http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/libtorrent_0.10.4-1_armeb.ipk
Installing libtorrent (0.11.5-1) to root...
Downloading http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/libtorrent_0.11.5-1_armeb.ipk
ipkg Configuring libtorrent
ich habe auch beide varianten mit der option

Quellcode

1
-force-downgrade 
probiert um zu erzwingen das er diese version nimmt, fehlanzeige :(
der paramter

Quellcode

1
-o[ffline] <root_dir> 
klang nett, aber schient meiens erachtens nur dazu da zu sein, ein alternatives ipkg verzeichnis auszuwählen, wenn ich dort nämlich etwas anderes als "/" angeben, dann findet er die libs nicht mehr...
ich habe auch probiert in meiner slug den gateway und dns zu entfernen, damit ipkg eventuell merkt, dass er nicht online ist, aber das merkt das sonst doch sehr coole prog nicht, dann läuft wget - verständlicherweise- auf einen fehler, da er auch versucht die akteulle version abzuholen.

nachdem ich nun schon sehr lange (>2 Stunden) ipkg install und remove befehle reingeklimpert habe, dachte ich ich brauche mal professionellen rat, google brachte mich leider nicht weiter und die hilfe gibt auch nicht mehr her ?!
erbitte dringend unterstützung, danke

gruß,
yauser

Anzeigen

Amitage

Anfänger

Beiträge: 22

Verwendetes NAS-Device: Nslu2

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

2

15.08.2007, 20:16

Hi :)

Bei mir gings ohne Probs ich hab mir die lib hier runtergeladen http://ipkg.nslu2-linux.org/feeds/unslung/cross/

dann auf die Slug ins home verzeichnis kopiert
und installiert


und fertig

[IMG]http://www.picture-hoster.de/preview.php?file=239354da73cfdd0e0d8fa6a92.jpg[/IMG]



[IMG]http://www.picture-hoster.de/preview.php?file=565d8111c83f01c37a4033945.jpg[/IMG]

Anzeigen

yauser

Anfänger

  • »yauser« ist der Autor dieses Themas

Beiträge: 6

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

3

15.08.2007, 21:34

mhhh und wieso gehts denn bei mir nicht :(

welche ipkg version hast du?

meine: ipkg version 0.99.154

ne idee?


hier mal die ipkg info ausgabe:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
ipkg info libtorrent
Package: libtorrent
Version: 0.11.5-1
Depends: openssl, libsigc++
Status: unknown ok not-installed
Section: libs
Architecture: armeb
maintainer: NSLU2 Linux <nslu2-linux@yahoogroups.com>
MD5Sum: 4fbc98454fb56e13d7cd3fba423d8e00
Size: 358277
Filename: libtorrent_0.11.5-1_armeb.ipk
Source: [URL]http://libtorrent.rakshasa.no/downloads//libtorrent-0.11.5.tar.gz[/URL]
Description: libtorrent is a BitTorrent library with a focus on high performance and good code.

Package: libtorrent
Version: 0.10.4-1
Depends: openssl, libsigc++
Status: install prefer not-installed
Architecture: armeb


die libtorrent_0.10.4-1_armeb.ipk lag im aktuellen verzeichnis

also er findet beide pakete und nimmt das erste (wohl aus seinem ipkg verzeichnis)
nun die preisfrage: wie bekomem ich ihn dazu die zweite version (das lokale paket) zu installieren. ich hoffe du weisst was dazu *hoff*

yauser

Anfänger

  • »yauser« ist der Autor dieses Themas

Beiträge: 6

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

4

16.08.2007, 01:00

ok, also ich hab rtorrent nun am laufen, nach weiteren studnen des experimentierens mit ipkg hab ich rtorrent, libtorrent und libcurl deinsalliert und

libcurl_7.15.5-2_armeb.ipkg
libtorrent_0.10.4-1_armeb.ipk
rtorrent_0.6.4-2_armeb.ipkg

runtergeladen und in tar.gz umbenannt,
dann den inhalt entpackt alles in mein opt verzeichnis geschoben

schlimemr gehts nimmer, quick n dirty und wird wohl probleme geben, sobald ich die libcurl für nen anderes plugin brauche und mir die dateien beim upodate plattgeschrieben werden, aber als workaround reicht es mir erstmal


Amitage

Anfänger

Beiträge: 22

Verwendetes NAS-Device: Nslu2

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

5

17.08.2007, 18:01

Hi
Meine: ipkg version 0.99.148

Vielleicht liegts daran

Social Bookmarks