Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

sandy.cheeks

Anfänger

  • »sandy.cheeks« ist der Autor dieses Themas

Beiträge: 1

Firmwareversion / your current Firmware: Unslung 3.16

  • Nachricht senden

1

20.09.2006, 20:25

appWeb will einfach nicht

Hallo zusammen,

ich bin ein ziemlicher Newbie was die SLUG betrifft.
Bei meinen Problemen bin ich schon desöfteren hier im Forum fündig geworden - echt super.

Hoffentlich könnt Ihr mir auch bei meinem ersten wirklichen Problem helfen.

Nachdem ich meine nSLU2 erfolgreich zu einem uNSLUng überreden konnte wollte ich appWeb installieren. Doch leider erhalte ich immer folgenden error.log:

default:2 main Configuration for Mbedthis AppWeb
default:2 main --------------------------------------------
default:2 main Host: SLUG
default:2 main CPU: armv5b
default:2 main OS: LINUX
default:2 main Version: 2.0.5.7
default:2 main BuildType: RELEASE
default:2 main Started at: Wed Sep 20 19:19:12 2006
default:2 main Log rotation count: 0
default:2 main --------------------------------------------
default:2 main Set log level for all modules to 2
default:2 main Document Root for Main Server:
"/opt/var/appWeb/web"
default:2 main Module search path:
"/opt/lib"
default:2 main Activating module (Loadable) admin
default:2 main Activating module (Loadable) auth
default:2 main Activating module (Loadable) cgi
default:2 main Activating module (Loadable) copy
default:2 main Activating module (Loadable) egi
default:2 main Activating module (Loadable) esp
default:2 main Activating module (Loadable) capi
default:1 main Error: Can't load /opt/lib/libphp5Module.so
Reason: "libsasl2.so.2: cannot open shared object file: No such file or directory"
default:1 main Error: Bad directive "LoadModule" at line 79 in /opt/var/appWeb/appWeb.conf
default:1 main Error: Can't configure server using /opt/var/appWeb/appWeb.conf
default:1 main Error: Can't configure the server, exiting.

Die libphp5Module.so liegt brav in Ihrem Verzeichnis.
Die libsasl2.so.2 kann ich nirgendwo finden.

Whats wrong?

1000THX für Eure Hilfe.
sandy.cheeks


P.S.

hier noch die appWeb.conf:

ServerRoot "/opt/var/appWeb"
ErrorLog logs/error.log
LogLevel 2
DocumentRoot "./web"
Listen 80
Listen 4443
ThreadLimit 4
TypesConfig mime.types
LoadModulePath /opt/lib
LoadModule admin libadminModule
LoadModule auth libauthModule
LoadModule cgi libcgiModule
LoadModule copy libcopyModule
LoadModule egi libegiModule
LoadModule esp libespModule
LoadModule capi libcapiModule
LoadModule php5 libphp5Module
LoadModule ssl libsslModule
LoadModule openSsl libopenSslModule
AddHandler authHandler
AddHandler egiHandler .egi
AddHandler cgiHandler .cgi .cgi-nph .bat .cmd .pl .py
AddHandler espHandler .esp .asp
AddHandler php5Handler .php
AddHandler copyHandler
Action application/x-appWeb-perl /usr/bin/perl
Action application/x-appWeb-python /usr/bin/python
<Location /esp>
SetHandler espHandler
</Location>

<Location /egi>
SetHandler egiHandler
</Location>
<Location /cgi-bin>
Alias /cgi-bin/ "$DOCUMENT_ROOT/cgi-bin/"
SetHandler cgiHandler
</Location>
Redirect seeother /doc/ "http://www.appwebserver.org/products/appWeb/doc/"
CustomLog logs/access.log "%h %l %u %t \"%r\" %>s %b"
KeepAlive on
KeepAliveTimeout 30
MaxKeepAliveRequests 200
Timeout 60
Group nobody
User nobody
DirectoryIndex index.html
<VirtualHost *:4443>
DocumentRoot "./web"
SSLEngine on
SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
SSLProtocol ALL -SSLV2
SSLCertificateFile "$SERVER_ROOT/server.crt"
SSLCertificateKeyFile "$SERVER_ROOT/server.key.pem"
Alias /doc/ "../doc/"
</VirtualHost>

Anzeigen

2

21.09.2006, 10:20

hallo

Ich bin kein Spezialist aber hast einen symlink zur php.ini ins appWeb Verzeichniss gelegt. Sonst verarbeitet appweb die php.ini nicht.

Anzeigen

3

03.10.2006, 07:41

Hi,

Das Problem ist ein fehlendes Paket. AppWeb sollte die Paketabhähngigkeit eigentlich im IPKG verwalten, aber irgendwie fehlt ein Paket.

Was fehlt ist die cyrus-sasl library:
The cyrus-sasl package contains the Cyrus implementation of SASL.
SASL is the Simple Authentication and Security Layer, a method for
adding authentication support to connection-based protocols.
Jedenfalls musst Du folgendes Paket installieren: cyrus-sasl
Ich glaube dort besteht eine weitere Abhängigkeit zu: gdbm

Also einfach:

ipkg install gdbm
ipkg install cyrus-sasl

dann sollte es funktionieren.

Viele Grüße,
DickCable

4

08.10.2006, 14:33

Ich hatte das selbe Problem. DA fehlt wohl die dependency im ipkg zweig für unslung. Dann klappte es wie am Schnürchen :)
...ich sag's zwar, weiss es aber nicht!

Social Bookmarks