Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Tomekx

Schüler

  • »Tomekx« ist der Autor dieses Themas

Beiträge: 73

Wohnort: Leipzig

Beruf: Boss mehrerer IT-Firmen

  • Nachricht senden

1

29.03.2006, 12:15

mc installiert -- aber nicht gefunden

Hallo,


ich habe mc installiert -- und zwar so:

Quellcode

1
2
3
wget http://ipkg.nslu2-linux.org/feeds/unslung/cross/mc_4.1.35-2_armeb.ipk 
ipkg install mc_4.1.35-2_armeb.ipk 
(this assumes you already have ncurses installed)


genau so ... und wenn ich nun mc starten will, dann kommt:

Quellcode

1
2
root@nslu2:/etc# mc
-sh: mc: not found


Wo ist das problem?? vor dem Monitor -- oder im nslu2??

bitte um RAT -- ciao

Anzeigen

annatolo

Schüler

Beiträge: 56

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

2

29.03.2006, 12:22

Vor dem Monitor...

bitte hier schauen (vor allem Punkt 3.) http://wiki.nslu2-info.de/pmwiki.php/HowTo/MidnightCommander

Anzeigen

Eiffel

Profi

Beiträge: 619

Beruf: SAP Anwendungsbetreuer

  • Nachricht senden

3

29.03.2006, 12:23

prüf mal ob /opt/bin in deiner PATH Variable steht ansonsten mal erweitern dann klappts auch mit dem mc ;-)

Tomekx

Schüler

  • »Tomekx« ist der Autor dieses Themas

Beiträge: 73

Wohnort: Leipzig

Beruf: Boss mehrerer IT-Firmen

  • Nachricht senden

4

30.03.2006, 13:44

ok -- alles klar -- wenn ich nun mc eingebe, dann startet auch scheinbar mc.

Problem ist aber, dass das terminal leer ist und nur oben der cursor blinkt -- lässt sich aber auch nicht mit strg+c abbrechen

scheinbar ist irgend etwas mit mc nicht in Ordnung!

was kann das sein??

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

5

30.03.2006, 16:09

Tach,

hast Du einen Terminaltyp eingestellt, und wenn ja, welchen ?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Tomekx

Schüler

  • »Tomekx« ist der Autor dieses Themas

Beiträge: 73

Wohnort: Leipzig

Beruf: Boss mehrerer IT-Firmen

  • Nachricht senden

6

30.03.2006, 22:05

ich verwende auf meinem rechner ubuntu und da das gnome-terminal

damit logge ich mich per ssh auf den nslu2 ... kann das daran liegen??

wenn nun mc startet, dann startet er scheinbar auch, jedoch wie oben beschrieben, das Terminal wird schwarz und der Cursor blinkt oben links.

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

7

30.03.2006, 22:25

N'Abend,

Davon ausgehend, das ipkg beim installieren von mc gleich termcap und ncurses mitinstalliert hat, setze in /etc/profiles einen Terminaltyp, z-B. TERM=pterm-xcolor sollte funktonieren.
S.a. http://wiki.nslu2-info.de/pmwiki.php/HowTo/MidnightCommander

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Tomekx

Schüler

  • »Tomekx« ist der Autor dieses Themas

Beiträge: 73

Wohnort: Leipzig

Beruf: Boss mehrerer IT-Firmen

  • Nachricht senden

8

30.03.2006, 22:34

genau das hab ich auch gemacht -- /etc/profiles um diese Zeile erweitert!

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

9

30.03.2006, 22:54

und auch exportiert ?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Tomekx

Schüler

  • »Tomekx« ist der Autor dieses Themas

Beiträge: 73

Wohnort: Leipzig

Beruf: Boss mehrerer IT-Firmen

  • Nachricht senden

10

31.03.2006, 06:29

sorry, aber damit kann ich nichts anfangen - kannst du es mir bitte kurz erläutern

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

11

31.03.2006, 14:46

Tach,

Ich meinte,

TERM = bla-typ
export TERM

Und überprüfe auch (mittels ipkg list_installed) ob ncurses und termcap installiert sind.

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Social Bookmarks