Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Hilde

Anfänger

  • »Hilde« ist der Autor dieses Themas

Beiträge: 12

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

1

31.03.2005, 20:49

Midnight Commander Problem

Hallo,

habe midnight commander installiert.
Ich muss aber jedesmal nach neustart die Umgebungsvariabeln in der Eingabeaufforderung neu setzen, obwohl ich nach Anleitung in der etc/profile die Variablen gesetzt habe

export PS1="\[\033[1;33m\]\u@\h\[\033[0;37m\]:/ > "
test -f /opt/bin/bash && exec /opt/bin/bash
TERMINFO=/opt/lib/terminfo
TERM=xterm-pcolor
export TERMINFO TERM

Was mach ich falsch?

Gruß Hilde

Anzeigen

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

2

31.03.2005, 21:37

N'Abend,

Zitat von »Hilde«


export PS1="\[\033[1;33m\]\u@\h\[\033[0;37m\]:/ > "
test -f /opt/bin/bash && exec /opt/bin/bash
TERMINFO=/opt/lib/terminfo
TERM=xterm-pcolor
export TERMINFO TERM


Aus dem Bauch raus, Dein Prompt sieht aus, wie exportiert, stimmt's?
Und dann startest Du die Shell und dann exportierst Du TERMINFO und TERM ins Nirgendwo... Exportiere TERM und TERMINFO bevor Du über exec die Shell hochziehst.

bye
JrB

Anzeigen

3

01.04.2005, 08:47

Zitat von »Hilde«


test -f /opt/bin/bash && exec /opt/bin/bash
Wird das so empfohlen? IMO ist das ziemlich schlecht auf der Slug eine zweite Shell aus der Login-Shell zu starten. Das verbraucht doch nur unnötige Resourcen auf der kleinen Kiste. Besser wäre ein entsprechender Eintrag in /etc/passwd. Damit würde auch gleichzeitig dein Problem mit den exportierten Variablen verschwinden.
pTweety

Social Bookmarks