Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

11.07.2005, 14:05

Apache sollte gleichzeitig http und https verwenden

Hallo,

ich habe ein "kleines" Problem.

Ich habe gestern Apache mit PHP und MySQL (und phpmyadmin) eingerichtet.
Das lief alles auch ganz super; habe dann noch apache auf port 80 geschoben und das linksys webinterface auf port 8000 (die beiden haben also getauscht)

Heute habe ich mich dann an die Einrichtung von SSL in Apache gemacht.
Hab das ganze nach der Anleitung gemacht: http://www.nslu2-linux.org/wiki/HowTo/EnableHTTPSforApache

Passt auch...
... ich kann die Apache startseite mit https://192.168.0.30/ aufrufen

Das Problem dabei ist nur:
Ich erreiche http://192.168.0.30/ nicht mehr !!

Ich habe dann nochmal die standart konfigurationsfiles zurückgespielt, dann noch den port geändert, den servernamen... das wars eigentlich auch schon...
... das selbe Ergebnis!

Wie schaffe ich es, dass Apache gleichzeitig http und https verbindungen verwalten kann??

Niko

Anzeigen

2

10.06.2006, 10:32

Apache HTTP & HTTPS gleichzeitig bockt mit KeepAlive

Hi,

ich war zwar eher auf der Suche nach einer Lösung für dieses Problem. Ist bei mir auch so, dass nur HTTP funktioniert, bei einem -D SSL hingegen nur noch HTTPS aber alles über HTTP hängt dann.
Witzigerweise nur bei den üblichen Browsern, via telnet ein GET / HTTP/1.0 oder lynx kommt man doch auf den HTTP-Port.

Nach etwas rumexperimentieren habe ich dann rausgefunden, dass HTTP+HTTPS funktioniert sobald man in der httpd.conf die KeepAlives auf "off" stellt. Erklären kann ich mir das noch nicht ganz, weil es ja funktioniert, wenn man den Apache ohne SSL nutzt, aber zumindest ein workaround.

Versuche momentan an den Thread und Keepalive-Einstellungen rumzudrehen. Bisher hat aber eine Reduzierung der Keepalives, Timeouts usw. noch nicht geholfen.

Ideen?
Gruss
mech

Anzeigen

Social Bookmarks