Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Energiequant

Anfänger

  • »Energiequant« ist der Autor dieses Themas

Beiträge: 7

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

1

23.10.2008, 01:31

pfeifende Slug, USB will nicht mehr

Ich tippe in meinem Fall mal auf eines der bekannten Probleme mit der Stromversorgung (Netzteil oder Elko). Worüber ich aber absolut nichts finden kann ist ein hohes Pfeifen, das meine Slug beim Booten (auch ohne USB oder LAN) oder kurz nach dem Anstecken eines USB-Sticks für ca. eine halbe Minute von sich gibt. Dieses ist mir erst zeitgleich mit dem zunächst sporadischen, dann permanenten Ausfall des USBs aufgefallen.

Unter SlugOS bekomme ich Kernel-Meldungen, daß angeblich ein 5 Port-Hub und ein Hub mit ungültiger Portzahl erkannt werden (an den Ports der Slug ist dabei nichts angeschlossen). Wenn ich USB-Sticks anschließe, gibt es nur das Pfeifen, sonst nichts (auch keine Meldung in dmesg, Strom liegt aber an den Ports an). Versuche ich mit USB-Sticks zu booten, gehen diese (erkennbar an der LED des Sticks) etwa zeitgleich mit dem abrupten Ende des Pfeifens aus. Ich habe auch schon versucht, die Module ohci_hcd und ehci_hcd nachträglich zu entfernen und wieder einzuhängen. Das Ergebnis beim Einhängen sind Segmentation Faults oder Hänger des Terminals, begleitet vom Pfeifen. Direkt nach dem Flashen von SlugOS bleibt die Slug auch gern pfeifend im Bootvorgang hängen, spätere Starts funktionieren problemlos; meine eigene Firmware bootet immer soweit wie möglich durch.

An SlugOS liegt es nicht; dasselbe Image lief vor ca. einem Monat noch problemlos und da ich nebenher versuche Gentoo darauf zum Laufen zu bringen kann ich sagen, daß auch dieses nur die fehlerhaften Hubs meldet.

Irgendwelche Ideen? Habe einen passenden Stecker für ein Netzteil gefunden, muss aber noch die Polarität prüfen bevor ich das ausprobiere. Ich befürchte nur, ein anderes Netzteil allein wird das Problem nicht lösen?

Die Slug steht hier erst seit Juli und wurde abgesehen von der Firmware noch nicht modifiziert oder geöffnet. Würde es Sinn machen, zu versuchen, sie (mit wiederaufgespielter Original-Firmware) einzuschicken oder sollte ich sie eher selbst öffnen und nach defekten Elkos oder anderen offensichtlichen Fehlern suchen? Bügelt Linksys bei einer Reparatur mit irgendwelchen Updates/Tools über die Firmware/den Bootloader, sodaß ich danach nur noch die originale Firmware nutzen könnte?

Kann der auf dem Schirm meines Netzwerkkabels anliegende Strom von ca. 1,3A (leider unvermeidbar) zu diesen Fehlern geführt haben? Ich habe gelesen, daß diese Probleme normalerweise erst nach ~1 Jahr auftreten.


Hier noch ein Auszug aus dmesg mit der fehlerhaften USB-Konfiguration:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
<6>ehci_hcd 0000:00:01.2: EHCI Host Controller
<6>ehci_hcd 0000:00:01.2: new USB bus registered, assigned bus number 1
<7>ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver
<6>ehci_hcd 0000:00:01.2: irq 26, io mem 0x48002000
<6>ehci_hcd 0000:00:01.2: USB 2.0 started, EHCI 20.60, driver 10 Dec 2004
<6>usb usb1: configuration #1 chosen from 1 choice
<6>hub 1-0:1.0: USB hub found
<6>hub 1-0:1.0: 5 ports detected
<6>IXP4XX Q Manager 0.2.1 initialized.
<6>ohci_hcd 0000:00:01.0: OHCI Host Controller
<6>ohci_hcd 0000:00:01.0: new USB bus registered, assigned bus number 2
<6>ohci_hcd 0000:00:01.0: irq 28, io mem 0x48000000
<6>usb usb2: configuration #1 chosen from 1 choice
<6>hub 2-0:1.0: USB hub found
<3>hub 2-0:1.0: config failed, hub has too many ports! (err -19)
<6>ohci_hcd 0000:00:01.1: OHCI Host Controller
<6>ohci_hcd 0000:00:01.1: new USB bus registered, assigned bus number 3
<6>ohci_hcd 0000:00:01.1: irq 27, io mem 0x48001000

Anzeigen

2

23.10.2008, 13:17

AW: pfeifende Slug, USB will nicht mehr

Für mich klingt das sehr nach einem Hardwareproblem. Insofern solltest Du es m.E. mit Original-FW und Einsenden versuchen.

Zitat

Kann der auf dem Schirm meines Netzwerkkabels anliegende Strom von ca. 1,3A (leider unvermeidbar) zu diesen Fehlern geführt haben?
Würde ich nicht ausschließen wollen. Wenn ich mich nicht täusche, liegt die Grenze für Power over Ethernet bei 350 mA. Ich weiß ja nicht, wofür Du den Strom brauchst, aber gesund klingt das nicht...

Gruß,
Thomas

Anzeigen

Energiequant

Anfänger

  • »Energiequant« ist der Autor dieses Themas

Beiträge: 7

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

3

23.10.2008, 13:28

AW: pfeifende Slug, USB will nicht mehr

Zitat von »Archivar;33264«

Würde ich nicht ausschließen wollen. Wenn ich mich nicht täusche, liegt die Grenze für Power over Ethernet bei 350 mA. Ich weiß ja nicht, wofür Du den Strom brauchst, aber gesund klingt das nicht...


Den Strom brauche und will ich nicht; da die Steckdosen in der Wohnung aber nur über "klassische Nullung" statt über eine echte Erdung verfügen und ich das Netzwerk über zwei Zimmer und damit scheinbar zwei Phasen laufen habe, liegt immer dieser Fehlerstrom an den verbundenen Geräten. Habe auch den Verdacht daß deshalb so wahnsinnig viele Netzwerkkarten bei mir hops gehen. Die Ursache des Problems lässt sich aber leider nicht so schnell aus der Welt schaffen, also muss ich damit leben. Eine komplette Sanierung der Wohnung wäre deutlich teuer als die defekten Geräte gelegentlich zu erneuern.

Zurück zur Slug: Gibt es denn Erfahrungen, ob die Slug anschließend "gesperrt" zurückkommt oder kann ich nach einer Reparatur/einem Austausch normal damit weitermachen? Tauscht Linksys neuere Geräte (266MHz) u.U. gegen ältere (untertaktete auf 133) aus?

Edit: Lese ich das grad richtig; die Slug muss extra in die USA verschickt werden?! Hat Linksys dafür keine Adresse innerhalb der EU oder noch besser direkt in Deutschland?

4

23.10.2008, 14:06

AW: pfeifende Slug, USB will nicht mehr

Zitat

Die Slug steht hier erst seit Juli

Zitat

Lese ich das grad richtig; die Slug muss extra in die USA verschickt werden?! Hat Linksys dafür keine Adresse innerhalb der EU oder noch besser direkt in Deutschland?

Innerhalb der gesetzlichen Gewährleistungspflicht ist der Händler zuständig, bei dem Du die Slug gekauft hast - das gilt auch für Online-Händler. Von dem Strom auf dem Netzwerkkabel würde ich dem nicht unbedingt etwas sagen - eine nicht sachgemäße Nutzung muss Dir ggf. nachgewiesen und nicht bloß unterstellt werden.

Zitat

Zurück zur Slug: Gibt es denn Erfahrungen, ob die Slug anschließend "gesperrt" zurückkommt oder kann ich nach einer Reparatur/einem Austausch normal damit weitermachen? Tauscht Linksys neuere Geräte (266MHz) u.U. gegen ältere (untertaktete auf 133) aus?

Eigene Erfahrung habe ich nicht dabei aber ich tippe mal, dass Du eine Slug im Neuzustand bekommst. Die müsste sich dann auf dem üblichen Weg flashen lassen.

Gruß,

Thomas

Energiequant

Anfänger

  • »Energiequant« ist der Autor dieses Themas

Beiträge: 7

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

5

23.10.2008, 17:13

AW: pfeifende Slug, USB will nicht mehr

Okay, falls sonst niemand mehr eine andere Idee hat, werde ich das dann mal am Montag zum Händler bringen.

Danke schonmal.

Energiequant

Anfänger

  • »Energiequant« ist der Autor dieses Themas

Beiträge: 7

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

6

26.10.2008, 21:39

AW: pfeifende Slug, USB will nicht mehr

Da hab ich jetzt doch noch ein Problem - nach dem Flashen der Originalfirmware sind leider noch falsche Einstellungen vorhanden; u.a. fehlt die Versionsnummer. Ich denke das könnte Probleme geben. :/

Wie flashe ich denn richtig, sodaß nicht auffällt, daß was anderes drauf war? SysConf-Bereich wie hier beschrieben löschen und Firmware nochmal einspielen? Besonderer Parameter für Upslug2? Eine gebrickte Slug ist genauso unnütz wie eine blockierte, kaputte oder von einem Umtausch zurückgewiesene. Was mach ich damit die mit hoher Wahrscheinlichkeit durchkommt? :confused: (da der Fehler garantiert nicht durch eine Fremdfirmware verursacht wurde sondern offenbar ein reiner Hardwarefehler vom Board ist, sehe ich mich nach meiner Definition in der Garantie, auch wenn seitens Linksys natürlich ein anderer Wind weht)

Wenn das nicht geht würde ich die Slug doch eher selbst öffnen und nachsehen, ob ich einen offensichtlichen Fehler (platzender Elko o.ä.) finde. Ich befürchte nur, daß mir zu einer eigenständigen Reparatur Wissen und Erfahrung fehlen.

7

26.10.2008, 21:59

AW: pfeifende Slug, USB will nicht mehr

Folgendes ohne Gewähr:
Linksys hat ja seinerseits verschiedene Varianten der Firmware herausgebracht. Wenn Du also die aktuellste Version von der Webseite herunterlädst und flasht, dürfte die Versionsnummer kein Problem sein, denn falsches Flashen ist ja (bislang und hoffentlich auch weiterhin) nicht das Problem.
Da ich auf meinen Arbeits-PCs Windows benutze, habe ich bisher zweimal ohne Probleme mit dem Sercomm-Tool die Slug neu geflasht (allerdings mit der jeweils aktuellen Unslung-Version, nicht mit der Original-FW, aber die ähneln sich ja). Leider weiß ich nicht, was nach dem Flashen der Firmware ggf. noch an Resten der vorherigen FW im Flashspeicher zu finden ist, aber glaubst Du wirklich, dass sich jemand die Mühe macht, das zu prüfen? Ich würde ja bereits gegenüber dem Händler auf Besserung (=Reparatur/Umtausch) bzw. Wandlung (=Geld zurück) bestehen.
In den letzten Jahren habe ich gerade Läden wie Saturn etc. bei solchen Geschichten als verhältnismäßig kulant erlebt. Unterm Strich ist ein zufriedener Kunde allemal mehr wert als einer, dem man durch ggf. mehrstündigen Einsatz von Fachpersonal nachweist, dass sein &#8364;80.-- Umtausch nicht gerechtfertigt ist. Aber das ist nur mein Erfahrungswert.

Gruß,

Thomas

Energiequant

Anfänger

  • »Energiequant« ist der Autor dieses Themas

Beiträge: 7

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

8

22.11.2008, 20:12

AW: pfeifende Slug, USB will nicht mehr

So, nach längerer Zeit hatte ich Lust das Thema doch nochmal anzugehen...

Ich hab die Linksys-FW einfach nicht richtig hinbekommen und das Gerät deshalb nicht zurückgebracht. Ich habe noch einen 1.6mm Stecker gefunden, der sogar auf mein Netzteil passte, leider keine Änderung.

Also jetzt doch mal die Slug geöffnet und das Board entnommen. Auf Verdacht auch einfach mal die Batterie für 10 Minuten entfernt und dann eine neue eingesetzt. Probleme sind immernoch dieselben; Flashen klappt, Linksys-FW meldet Fehler und kein USB, allerdings geht der Stick jetzt nicht mehr von alleine aus (was vorher nach ca. 1-2 Minuten der Fall war). SlugOS mag gar nicht mehr durchstarten: Die LEDs blinken der Reihe nach, dann Dauerlicht gelb und nichts passiert mehr. Stick bleibt an. Gelegentlich komm ich bis zum Piepen, danach summt der Pieper munter weiter vor sich hin. (das Pfeifen kommt also zum Glück von genau dem Bauteil, das auch Geräusche von sich geben sollte *puh*)

Wär da jetzt ein Elko aufgebläht o.ä. würde ich ja evtl. in der Lage sein, die Fehlerursache zu erkennen, aber leider sieht das Board optisch top aus; zumindest für mich als Nicht-Bastler ist da nichts weiter zu erkennen.

Werde es nachher evtl. nochmal mit meinem eigenen Image probieren, vielleicht gibts halbwegs hilfreiche Kernel-Meldungen. Komisch ist, daß die Linksys-FW immer sauber booten kann und auch läuft (aber dann im Frontend falsche Daten hat und Fehler meldet) und sich nur SlugOS sehr zufällig verhält (LEDs fast immer, Piepen selten).

Fällt noch jemandem was dazu ein? Sonst würde ich gucken wie ich das Gerät loswerde (vielleicht hier im Forum als Ersatzteillager oder via eBay als "defekt, für Bastler" inseriert); vielleicht lassen sich ja noch ein paar Euro für mich rausholen. Eine zweite Slug wirds dann aber nicht mehr geben - da sehe ich mich lieber nach einer zuverlässigeren Hardware um. :(

Edit: Vielleicht kennt Ihr Euch gut genug aus, um mir einen Tip zu geben, wo ich mal mit einem Multimeter irgendwas abgreifen könnte und was ich dann messen sollte wenn alles in Ordnung wäre?

Edit2: Auch mit dem eigenen Kernel ist leider immernoch alles beim alten. (USB-Stick wird nicht gefunden)

Energiequant

Anfänger

  • »Energiequant« ist der Autor dieses Themas

Beiträge: 7

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

9

30.11.2008, 14:50

AW: pfeifende Slug, USB will nicht mehr

Irgendwo hatte ich vor Monaten mal einen kurzen Beitrag gefunden, in dem es um das Ersetzen eines bestimmten Kondensators in Zusammenhang mit USB- und Stromproblemen ging. Leider finde ich diesen Beitrag nicht mehr (eigentlich dachte ich hätte ich ihn hier im Forum oder auf nslu2-linux.org gesehen). Weiß jemand was ich meine und wo das stand? Wäre jetzt meine letzte Idee wie ich die Kiste evtl. selbst reparieren könnte.

Energiequant

Anfänger

  • »Energiequant« ist der Autor dieses Themas

Beiträge: 7

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

10

07.12.2008, 23:38

AW: pfeifende Slug, USB will nicht mehr

Ich begrab die Kiste jetzt. Vielleicht versuch ich sie doch noch umzutauschen, vielleicht lass ichs. Mal gucken ob ich auf eBay billig (bis 20&#8364;) eine abgreifen kann, sonst wars das.

Problem damit "gelöst", mir reichts...

Social Bookmarks