Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

28.03.2007, 07:02

Festplatte wird nicht mehr erkannt, USB-Chip hinüber?

Hallo, jetzt hatte ich eine schöne Woche lang mein NSLU2 mit Debian in Betrieb, vorgestern früh wollte es dann auf einmal nicht mehr starten. :mad:

Am Abend habe ich das Problem analysiert, u.a. habe ich erst eine Sicherung der bestehenden Debian-Partition auf meinem PC gemacht, dann nochmal das Debian-Installationsimage aufgespielt und mich dann gewundert, warum die 2,5"-Harddisk nicht zum Partitionieren angeboten wird, obwohl sie ordentlich vom NSLU2 mit Strom versorgt wird und sich hörbar dreht (wenn man das Ohr direkt draufhält, ansonsten ist sie nahezu unhörbar).
Nachdem das nichts half, habe ich wieder die Original-Firmware von Linksys aufgespielt und diese gestartet. Auch hier wurde die Harddisk nicht gefunden. Testweise dasselbe noch einmal mit einem USB-Stick in Port 2, ebenfalls nichts.

Zum Glück hatte ich schon gleich nach Erhalt des Geräts ein Log des Bootvorgangs mit der Original-Firmware über die serielle Konsole gemacht, so dass ich das mit dem aktuellen vergleichen konnte. Dabei ist mir aufgefallen, dass der folgende Text NICHT mehr beim Booten erscheint:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
usb.c: registered new driver hub
pci probe begin
ehci_hcd 00:01.2: NEC Corporation USB 2.0
ehci_hcd 00:01.2: irq 26, pci mem c3801f00
usb.c: new USB bus registered, assigned bus number 1
PCI: 00:01.2 PCI cache line size set incorrectly (0 bytes) by BIOS/FW.
PCI: 00:01.2 PCI cache line size corrected to 32.
ehci_hcd 00:01.2: USB 2.0 enabled, EHCI 1.00, driver 2003-Jun-19/2.4
Device descriptor:8 bytes received.
Device descriptor:18 bytes received.
hub.c: USB hub found
hub.c: 5 ports detected
Meine traurige Vermutung ist also, dass der USB-Chip meines NSLU2 irgendwie hinüber gegangen ist.

Kennt jemand von Euch das Problem? Kann man da noch was drehen? Gibt es eine andere Möglichkeit als das Gerät umzutauschen?

Grundsätzliche Frage: verträgt das NSLU2 es nicht, wenn man eine ausdrücklich stromsparende 2,5"-Platte (also <=500mA) ohne eigene Stromversorgung anschließt?

Anzeigen

Spooky

CO-Admin

Beiträge: 355

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

2

28.03.2007, 17:49

@Rones

An einen PC angeschlossen läuft die Platte noch ?

Nimm das NSLU2 komplett vom Strom und fahre es danach bitte ohne angesteckte Festplatte hoch. Schaue dann, ob irgendwo der USB wieder auftaucht.

Aufgrund der hohen Stromaufnahme beim Einschalten der Festplatte, kann ich nur davon abraten, eine 2,5" Festplatte vom USB Bus speisen zu lassen. Auch wenn die Werbebotschaften etwas anderes erzählen, mit den manchmal beiliegenden USB Y-Kabeln, kann es ebenso Ärger geben. Je nach 2,5" Platte, sind die Einschaltströme kurzzeitig über 1A.

Spooky
Unmögliches wird sofort erledigt, Wunder dauern etwas länger.

Anzeigen

3

28.03.2007, 21:04

Am PC angeschlossen funktioniert die Festplatte bestens, ich konnte ja auch mit partimage wunderbar eine Sicherung der Debian-Installationspartition durchführen.

Bei meinem NSLU2 habe ich sogar schon für ca. 1 Minute lang die Batterie rausgenommen, um es wirklich komplett vom Strom zu trennen. Das hat leider auch nichts gebracht.

Eben habe ich es nochmal gestartet nur mit Netzteil-, Netzwerk- und seriellem Kabel dran (also ohne jegliche USB-Geräte), da sieht der Bootvorgang leider nicht besser aus. Die NEC-USB-Hardware wird nicht angezeigt.

Wenn ich die Festplatte selbst mit einem Netzteil versorge, liefert sie lustigerweise über USB den Strom zurück zum NSLU2: selbst wenn es abgeschaltet ist und das NSLU2-Netzteil nicht angeschlossen ist, fährt das NSLU2 sofort hoch, wenn man den USB-Stecker einsteckt (oder das Netzteil der Festplatte bei schon eingestecktem USB-Stecker einschaltet). Das Verhalten ist merkwürdig und habe ich zuerst auch schon bei einem NSLU2 eines Bekannten gesehen.

4

06.06.2007, 23:13

So, eine Weile hat es gedauert, aber gestern kam endlich das Austausch-NSLU2 an, so dass ich mich jetzt hoffentlich wieder ordentlich damit befassen und das Gerät auch nutzen kann.

Social Bookmarks