Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

sankyu3

Anfänger

  • »sankyu3« ist der Autor dieses Themas

Beiträge: 6

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

1

23.02.2005, 20:51

NSLU2 hängt sich beim kopieren auf

Nach einigen Schwierigkeiten habe ich meine Festplatte formatieren können.
Vielen Dank nochmals an das Forum!

Mein Fazit:
Die NSLU2 kann man Linux Einsteigern nur bedingt empfehlen.

Nun stehe ich vor dem nächsten Problem (hoffentlich das letzte):

Beim Kopieren von größeren Dateien hängt sich die NSLU2 regelmässig auf.
Insbesondere bei Dateien von 1GB oder auch Ordner mit mehreren Unterverzeichnissen reagiert die NSLU2 nicht mehr. (Kein Kontakt über das Webinterface möglich). Kopiert man kleine Dateien hat man keine Probleme.

Erst nach einem Neustart der NSLU2 hat man wieder Zugriff.

Hat jemand eine Idee wo der Fehler liegt ?

Bios habe ich bereits aktualisiert.

Gruß und schonmal Danke für Eure Ratschläge

MM

Anzeigen

Spooky

CO-Admin

Beiträge: 355

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

2

23.02.2005, 21:57

Ist nur ein Schuss ins Blaue ...

Deaktiviere mal im Webinterface des NSLU2 "upnp". Wenn Du noch einen Router o.ä. mit "upnp" in Deinem Netzwerk haben solltest, deaktiviere es dort bitte auch, zumindest zu Testzwecken.

Spooky

Anzeigen

sankyu3

Anfänger

  • »sankyu3« ist der Autor dieses Themas

Beiträge: 6

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

3

25.02.2005, 19:13

@ spooky

hat leider nicht funktioniert. Trotzdem danke für den Tipp
Hat noch jemand eine Idee ?

gibt es Inkompatibilitäten ?

Gruß

MM

4

25.02.2005, 19:34

@sankyu3
hallo,

Zitat

gibt es Inkompatibilitäten ?

jep > beim Usb Gehäuse !!

was für eine Usb Hdd verwendest du bzw welcher chipsatz hat das usb gehäuse ?
lg Tpol

bitfitter

Anfänger

Beiträge: 3

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

5

25.02.2005, 19:37

Hab da auch noch ne Idee:

Lt. deinem Profiltext hast Du noch die FW 2.3r24 im NSLU2 laufen...wie wäre es mal mit einem Upgrade auf 2.3r25 oder 2.3r29? Vielleicht hatte ja die 2.3r24 genau in diesem Punkt ein Problem? Ich weiss aber es nicht, da ich sie sofort nach dem Neukauf mit der unslung 3.18 überschrieben habe.

Vielleichts hilfts...?

Have fun...
/bitfitter

6

25.02.2005, 19:42

@bitfitter

>änderungen in der orginalen FW ! ;)

8/3/2004

Linksys
A division of Cisco Systems, Inc.

Firmware Release Notes for NSLU2.
**************************************

Firmware Version 2.3 Release 25
1.) Fixed the Internal Clock bug that caused the NSLU2 to lose time by minutes per day


Firmware Version 2.3 Release 24

1.) Corrected the Time Stamp bug found in original firmware 2.3R21.


lg Tpol

bitfitter

Anfänger

Beiträge: 3

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

7

25.02.2005, 19:49

@Tpol

Danke für die Info.
Sieht also wohl eher nicht nach 'nem Firmwareproblem aus.
Ich selbst habe es mit der unslung auch noch nicht getestet, da ich es bisher noch nicht nötig hatte, solch große Dateien durch mein Netzwerk zu "drücken". :cool:

Zitat

>änderungen in der orginalen FW !

Nunja, die Änderungen weiss meine dbox zu schätzen... ;)

Have fun...
/bitfitter

sankyu3

Anfänger

  • »sankyu3« ist der Autor dieses Themas

Beiträge: 6

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

8

26.02.2005, 08:12

@ tpol

Ich habe gestern einiges Ausprobiert:

FW update -> kein erfolg

Anderes USB Laufwerk (von mapower (Chipsatz: ?) und raidsonic icy box (Chipsatz cypress)

Jetzt werden ich nochmal eine andere Festplatte ausprobieren.
Vielleicht ist die 300GB seagate nicht kompatibel bzw. zu groß.

Kann man an den Netzwerkeinstellungen (PC) irgendetwas falsch einstellen (PC), dass eine ungünstige Konstellation entsteht ?

Gruß und Danke für eure Tips


MM

9

26.02.2005, 08:25

@sankyu3

Zitat

und raidsonic icy box (Chipsatz cypress)

verwende unbedingt anfangs bis deine Probleme gelöst sind den cypress Chipsatz !

Zitat

Kann man an den Netzwerkeinstellungen (PC) irgendetwas falsch einstellen

"Grundsätzlich" nicht >die Ip´s sollten natürlich in der selben Range sein samt Subnetmask aber das ist eigentlich klar !
Wenn du noch die selbe Workgroup verwendest sollte grundsätzlich alles flutschen!

cu tpol


Ps.Schreib mal dein Netzwerk system hier mit allen geräten/Ip s auf !

Ps.verbinde die NSLU2 direkt mal mit dem Pc um gewisse Fehler von vornerein auszuschalten !

Ps.Du kannst vor dem Kopieren einen Portscan der Nslu durchführen und nach dem kopier-abbruch wieder und vergleichen, weiss zwar nicht ob das was bringt aber ein versuch ist das allemal wert !

10

04.03.2005, 20:02

Versuch's trotzdem mal mit der rc29!

cu
Gargi
---Trible-Slug---
Slug overclocked to 266MHz, running Apache, PHP, mySQL and vsftp

emptee

Anfänger

Beiträge: 9

Firmwareversion / your current Firmware: Unslung 3.18

Wohnort: Dortmund

Beruf: Dipl.-Inform.

  • Nachricht senden

11

07.03.2005, 21:38

Tja, ich habe hier auch eine NSLU2, die sich reproduzierbar an einem 5-Port-Switch von Netgear älterer Bauart aufhängt.

Alles abschalten von upnp im gesamten Netz und andere Experimente haben nichts gebracht, auch andere USB-Plattengehäuse nicht.

Nun habe ich der NSLU2 einen 2. Switch spendiert, der zwischen ihr und dem 5-Port-Switch hängt, und seitdem läuft sie wochenlang ohne Probleme.

Stecke ich sie dann testweise direkt an den 5-Port-Switch, hängt sie spätestens nach 1h.

Richtig bizarr wird es dadurch, daß meine andere NSLU2 völlig problemlos an dem gleichen 5-Port-Switch betrieben werden kann.

Ich versuche das gar nicht mehr weiter aufzuklären und bin froh, daß ich eine sicher ablauffähige Konfiguration hinbekommen habe.

Das Problem, daß manche NSLU2 an manchen Switches und Routern nachvollziehbar abstürzen, ist aber auch schon in der englischen NSLU2-Yahoo-Group besprochen worden. Dort haben sich die meisten Betroffenen dann auch mit einem anderen/zusätzlichen Switch beholfen.

Hast Du das schon mal versucht?

Grüße, Mario
Meine NSLU2:
Nr.1: Fileserver 2 x 120 GB, Printserver, Mediaserver mit Twonkyvision
Nr.2: Entwicklungsbox mit nativer Toolchain, außerdem NNTP-Server mit leafnode und DNS-Server

sankyu3

Anfänger

  • »sankyu3« ist der Autor dieses Themas

Beiträge: 6

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

12

12.03.2005, 16:43

Ich habe die Unit erstmal zurückgeschickt. Ich hatte die Sch... gestrichen voll.

Vielleicht werde ich mir später nochmal eine NSLU2 bestellen und hoffen, dass es dann funktioniert.


Zitat von »emptee«

Tja, ich habe hier auch eine NSLU2, die sich reproduzierbar an einem 5-Port-Switch von Netgear älterer Bauart aufhängt.

Alles abschalten von upnp im gesamten Netz und andere Experimente haben nichts gebracht, auch andere USB-Plattengehäuse nicht.

Stecke ich sie dann testweise direkt an den 5-Port-Switch, hängt sie spätestens nach 1h.

Richtig bizarr wird es dadurch, daß meine andere NSLU2 völlig problemlos an dem gleichen 5-Port-Switch betrieben werden kann.

Ich versuche das gar nicht mehr weiter aufzuklären und bin froh, daß ich eine sicher ablauffähige Konfiguration hinbekommen habe.

Das Problem, daß manche NSLU2 an manchen Switches und Routern nachvollziehbar abstürzen, ist aber auch schon in der englischen NSLU2-Yahoo-Group besprochen worden. Dort haben sich die meisten Betroffenen dann auch mit einem anderen/zusätzlichen Switch beholfen.

Hast Du das schon mal versucht?

Grüße, Mario


Das hatte ich auch schon probiert. Auch der direkte Anschluß an einen PC
konnte das Problem nicht lösen. Ich denke an der Unit war etwas nicht ok.
Ich werde mich mal nach einer Alternative umsehen.

Trotzdem Danke für eure Hilfe.
Gott sei dank hat Amazon die Einheit ohne
Probleme innerhalb von 14 Tagen zurückgenommen.

testdemo

Anfänger

Beiträge: 8

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

13

17.03.2005, 13:43

und funktioniert er nun ich habe nähmlich auch das problem ?

LarsB

Anfänger

Beiträge: 13

Firmwareversion / your current Firmware: originale Firmware 2.3r29

  • Nachricht senden

14

29.03.2005, 19:40

Ich habe dasselbe Problem! Ich dachte bisher, es läge an meinem techsolo TMR-3550 (Cypress-Chipsatz). In der Yahoo-Group habe ich nur 2 Laufwerke mit Cypress-Chipsatz gefunden, die angeblich funktionieren. Andereseits hat nicht jeder das Bedürfnis, Datenmengen größer 1GB zu kopieren. Außerdem wird dort für die IcyBox IB-350 ein Ali-Chipsatz genannt, und ich hätte drauf wetten können, dass die auch einen Cypress Chipsatz verwendet.

Hat jemand die Box erfolgreich mit Cypress-Chipsatz in Betrieb?

Meine Box war übrigens ebenfalls von Amazon. Vielleicht war es das Exemplar von sankyu3? Wurde am 21.03. verschickt ...

amoeller

Anfänger

Beiträge: 19

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

15

09.04.2005, 09:28

NSLU2 Read Only Dateisystem

Ich scheine auch das Problem zu haben (verwende uNSLUng-standard-3.18-beta und mtdaapd als iTunes-Server für meine Roku Soundbridge, Acer 2,5-40GB-HDD mit Stromversorgung über USB, dafür stärkeres Netzteil: 5V, 2,5A statt 2,0A): Größere Dateimengen können nicht nicht richtig kopiert werden. Nach halben mp3s bricht der Kopiervorgang ab. Das Aufrufen der Linux Shell zeigt dann, dass sich das Dateisystem in ein Read-Only-Dateisystem umgewandelt hat. Dies scheint auch nach längerem Betrieb ohne Kopier(schreib)vorgänge der Fall zu sein. Deswegen hat die Soundbridge wohl auch keine Probleme damit: In Sachen Musik-Server klappt alles wunderbar. Wenn man aber dann versucht, etwas auf die Platte zu kopieren, geht es nicht mehr.
Kann es wirklich an der kleinen HDD liegen, dass das Dateisystem auf Read-Only gesetzt wird?
Kann man evtl. erzwingen, dass die Umschaltung nicht vorgenommen wird?
Wie bestimme ich den Chipsatz meiner HDD (fertige, sehr günstige 2,5-40-GB-USB-Platte von Acer)?

amoeller

Anfänger

Beiträge: 19

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

16

09.04.2005, 10:14

HDD Read-Only

Bei http://vowe.net/archives/005706.html habe ich noch folgenden Hinweis gefunden:

Zitat


Have you had any heat issues with the Metal Gear boxes? I tried one of
those a few weeks ago with a 250-GB drive in it, and if I started writing
data to the drive, after a couple of minutes I would get a scsi error (which
the sbp2 linux driver kind of chokes on -- the journal file gets messed up,
it remounts the file system read-only on you, pretty much game over).
The box sure was cool looking, but was not cool temperature-wise (kind
of a redundant statement). I eventually had to return it and get a different
box with a built-in fan (Venus DS3). I suppose it could have been firmware
related or cable related or electronics related, but whatever it was, I couldn't
get it to work.

Das deutet in der Tat auf ein Problem mit der Festplatte hin. Hier wäre die Frage, wie man das R/W-Mounten erreichen könnte.

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

17

09.04.2005, 10:48

Tach,

Zitat von »amoeller«


Das Aufrufen der Linux Shell zeigt dann, dass sich das Dateisystem in ein Read-Only-Dateisystem umgewandelt hat. Dies scheint auch nach längerem Betrieb ohne Kopier(schreib)vorgänge der Fall zu sein.


Mal als Idee, hast Du schon rc.quota divergiert?

Lege mal in /share/hdd/conf/unslung das Divertion Script rc.quota an, mach es ausführbar, und befülle es:

#!/bin/sh
return 0

Einmal neu starten, und abwarten, ob es besser wird...

bye
JrB

LarsB

Anfänger

Beiträge: 13

Firmwareversion / your current Firmware: originale Firmware 2.3r29

  • Nachricht senden

18

09.04.2005, 11:40

Ich scheine für mein Problem nun eine Lösung gefunden zu haben: In meinem Netzwerk war ein alter WLAN-Access-Point der Fa. Typhoon (Modell 70062C, wird als Cirrus-Logic-Access-Point in WinXP erkannt) eingebunden.
Ich habe bei meinen zahlreichen Versuchen stückweise mein Netzwerk verkleinert und als ich den Access-Point entfernt hatte, klappte es mit der Kopie plötzlich.
Seit dem kann ich eigentlich zuverlässig große Datenmengen kopieren, nur in einem von 5 Versuchen hatte sich die NSLU nach den ersten 2GB wieder aufgehängt, aber diesmal so brutal, dass selbst ausschalten nicht mehr ging. Das hatte ich bei den früheren Hängern, als der Accesspoint noch im Netz hing, nicht, der Ausschalter hatte immer funktioniert.
Der Access-Point hatte sich übrigens nur mit 10Mbit ins Netz gehängt, eine Verlagerung auf einen 2. Switch verhinderte die Hänger trotzdem nicht. Im Moment vermute ich, dass das Teil sporadisch Pakete ins Netz bläst, die die NSLU stören. Dabei muss ich noch anmerken, dass ich nie Clients im WLAN hängen hatte, als es zu den Hängern kam.

Spooky

CO-Admin

Beiträge: 355

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

19

09.04.2005, 12:42

@amoeller

Einmal abgesehen von der möglichen Ursache die caplink angesprochen hat, halte ich Deine Lösung mit der 2,5" Festplatte für nicht sonderlich ratsam. Wenn Ich Dich richtig verstanden habe, hast Du der NSLU2 ein anderes Netzteil spendiert und nicht zusätzlich Deiner Platte , richtig ? Wenn ja, dann ist das sinnlos. Ein aktiver USB Port liefert nicht mehr als 500mA pro Anschluß und das ist nun mal oft zu wenig für die meisten USB Geräte , vorallem für Festplatten! Der liefert höchstens mehr Strom, dafür dann sehr kurz, wenn der Blitz einschlägt ! :D

Spooky

amoeller

Anfänger

Beiträge: 19

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

20

09.04.2005, 14:31

/share/hdd/data type ext3 (ro)

Vielen Dank für die Antworten. Ich habe inzwischen in die gleiche Richtung wie caplink geforscht: Der Auruf von mount (ohne Parameter) zeigt die Zuordnungen, und in der Tat stand dort die Zeile /dev/sda1 on /share/hadd/data type ext3 (ro). Was mich mit Hoffnung erfüllt hat, ist die Tatsache gewesen, dass die anderen Partitionen der USB-Platte mit (rw) ausgewiesen sind. Dann die Frage, wo die Zuordnungen stehen: tatsächlich in der Standarddatei /etc/fstab. Und da stand nur für sda1 ein spezieller Parameter nach defauls "usrquota". Nach Anlegen einer Kopie fstab.old habe ich diesen Eintrag entfernt, dann Reboot, dann der Tipp von caplink, habe das Skript zusätzlich ergänzt. Die Datei fstab zu ändern, bringt allerdings nichts, die wird wieder durch das Original aus dem Jahre 1970 (:confused: ) überschrieben. Auch der Vorschlag von caplink hat leider nicht geholfen. Es ist zwar einige Zeit gut gegangen - doch dann das gleiche Problem wieder...:mad:

Zum Einsatz der 2,5-Platte ist anzumerken, dass die über USB mit Energie versorgt wird. Der Hersteller gibt explizit an, dass der Strom unter 500mA liegen soll. Zusätzlich bezieht die Platte die Energie aus 2 Ports, weil über einen Splitter zusätzlich Energie aus einem 2. Port abgegriffen wird. Ich habe eine solche Lösung auch schon in der c't (8.2005, S. 147, siehe auch Text S. 145) gesehen. Das Netzteil habe ich genau wegen der max. 500mA aus der Spezifikation getauscht. Im Vergleich mit dem mitgelieferten Netzteil (NSLU2 + USB Stick) arbeitet das neue Netzteil etwas effizienter, denn wird nicht sonderlich warm. Weil der NSLU2 als Musik-Server dauernd eingeschaltet bleibt, sind für mich Energieverbrauch und Festplattengeräusche wichtige Kriterien. Es könnte also gut sein, dass meine Konstellation normalerweise wenig sinnvoll ist, in meinem Fall aber schon.

Übrigens ist die Kombination NSLU2, 2,5-HDD, mt-daapd (iTunes auf NSLU2), Roku Soundbridge M1000 (wie es auf einer englischen Site heißt) eine absolute Killer-Applikation. Wenn mir jemand diese Kombination im Paket angeboten hätte, wäre das mir mind. 100 zusätzliche Euronen wert gewesen. Vielleicht setzt ja mal jemand verschiedene interessante Konzepte als Geschäftsideen um?;)

Social Bookmarks