Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Phantomias2006

Fortgeschrittener

  • »Phantomias2006« ist der Autor dieses Themas

Beiträge: 309

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

121

Sonntag, 19. August 2007, 22:59

Hi kingofkomedy

großes lob meiner seits :D:D
gefällt mir gut wird immer besser und besser

naja und ich dachte mir damit dir nicht langweilig wird :D
Das entspricht ca. 0 MB (maximal). wie siehts denn damit aus könnte mann das nicht genau machen??

also wenn man einen link eingibt (ohne Premium user zu sein und dann auf free klickt kommt eine seite mit folgenden text...

Clusterlösung an, wenn es darum geht, tausende Benutzer gleichzeitig zu bedienen. Fangen Sie jetzt an und werden Sie ein Premium-Kunde. Du hast http://rapidshare.com/files/xxxxxxxxxxxxxxxxx.rar (100000 KB) angefordert.

könnte man das nicht gleich mit dem linkchecker verknüpfen und beide daten auslesen lassen???


nur ein vorschlag;);)



mfg
Phantomias

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

122

Montag, 20. August 2007, 06:22

Der Linkchecker prüft, das solltest du am Besten wissen, nur die Seite, wo du auf "Free" klicken musst, d.h. man müsste das Script erstmal dazu bringen, auf "Free" zu klicken. ;)

Phantomias2006

Fortgeschrittener

  • »Phantomias2006« ist der Autor dieses Themas

Beiträge: 309

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

123

Montag, 20. August 2007, 11:37

Naja das weiß ich schon aber auf der seite den der linkchecker prüft steht der free link unverschlüsselt drin sprich den braucht man einfach auslesen nur dieser link ändert sich ca. alle 5min da stehen im prinzip nur ein paar buchstaben und nummern vor den link und dann könnte man auf dieser seite das auslesen:D aber wie gesagt ist nur ein vorschlag weiß auch nicht in wie weit das dann die performance beeinträchtigt
glaub eher das das eine schnaps idee von mir war :D

aber ein anderer vorschlag downloads stoppen abbrechen löchen und wieder aufnehmen was hältst du davon??

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

124

Montag, 20. August 2007, 13:33

Zitat von »Phantomias2006;26504«

Naja das weiß ich schon aber auf der seite den der linkchecker prüft steht der free link unverschlüsselt drin sprich den braucht man einfach auslesen nur dieser link ändert sich ca. alle 5min da stehen im prinzip nur ein paar buchstaben und nummern vor den link und dann könnte man auf dieser seite das auslesen:D aber wie gesagt ist nur ein vorschlag weiß auch nicht in wie weit das dann die performance beeinträchtigt
glaub eher das das eine schnaps idee von mir war :D

aber ein anderer vorschlag downloads stoppen abbrechen löchen und wieder aufnehmen was hältst du davon??

Auf der Seite steht der Free Link unverschlüsselt drin, aber wenn ich den Link dann aufrufe, komm ich trotzdem nicht an die Filesize. ;)

Downloads löschen könnte wohl möglich sein, aber das ist momentan nicht wirklich wichtig. :D

@therealwakka: der zeitverzögerte Download wird eventuell im Lauf der Woche eingebaut, sofern es sich relativ einfach realisieren lässt. :)

Edit: ok, ich komm jetzt doch an die Filesize. ;)

Beiträge: 73

Firmwareversion / your current Firmware: originale Firmware 2.3r25

  • Nachricht senden

125

Montag, 20. August 2007, 16:30

Danke! Wäre echt praktisch!:)

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

126

Montag, 20. August 2007, 18:16

Zitat von »therealwakka;26509«

Danke! Wäre echt praktisch!:)

Der erste Test hat funktioniert. :) Ok, momentan muss man die Zeitverzögerung noch in Sekunden eingeben, aber das sollte sich noch ändern lassen. ;)

Kleiner "Nachteil": die Download-Befehle werden vorübergehend in eine "Warteschleife" gehängt und nach einem Reboot ist diese Warteschleife natürlich wieder leer.

Edit: aber bevor ich die v1.0 - Final noch länger hinausschiebe und immer wieder neue Funktionen hinzufüge, wird die Version erstmal veröffentlicht. ;) Unterschiede zu RC2: keine, es wurde nur unnötiger Code entfernt.

Edit2: @ Phantomias2006: so, die Filesize - Funktion ist in meiner Version jetzt eingebaut. Sie lässt sich aber über die config.inc.php deaktivieren. ;)

Edit: der aktuelle Download-Link befindet sich im ersten Posting dieses Threads.

Phantomias2006

Fortgeschrittener

  • »Phantomias2006« ist der Autor dieses Themas

Beiträge: 309

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

127

Montag, 20. August 2007, 23:44

na das lob ich mir mal :D
schnell mal ein vorschlag posten und wenn man von der arbeit heim kommt hat man schon ein fertiges update zum downloaden ;)

machst du das beruflich?

schönen dank und mit freundlichen grußen

Phantomias

Biomann

Schüler

Beiträge: 137

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

128

Mittwoch, 22. August 2007, 14:50

Hi!

Ich hab ein Problem, und das auf 2 Slugs mit ähnlicher Config, hab das Problem mit der aktuellsten Version wie auch mit einer der ersten weswegen ich zwischenzeitlich aufgegeben hatte.

Meine config scheint soweit zu stimmen, alles wird mir richtig angezeigt. Wenn ich jetzt einen Download einfüge und starten will hängt sich das ganze Script aber auf. Er lädt nicht runter, es wurde kein Script erstellt und eine Logfile gibt´s auch nicht. Die chmods stimmen auch soweit.

Nur wenn ich die Slug neustarte bekomm ich das Script wieder ans laufen. Aber dann reicht sogar ein Klick auf den Link "laufende Downloads" um das Teil wieder zum abstürzen zu bringen.

Ich weiß nicht mehr weiter, würde das echt sehr gerne benutzen.

Meine Config:

Unslung 6.8
Apache + Php
Pfad zum RS Downloader ist /webserver/rsdm_10/ (liegt es vielleicht dran dass mein webserver Verzeichnis im root-verzeichnis, also in / liegt?)

Ich hoffe mir kann jemand helfen das Script ist sicher super wenn´s bei mir läuft!

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

129

Mittwoch, 22. August 2007, 15:27

Wenn du schreibst "um das Teil wieder zum abstürzen zu bringen", welches Teil meinst du dann? Hängt die NSLU2 sich auf? Stürzt der Apache ab?

@Phantomias2006: ja, beruflich programmiere ich RapidShare Download Manager in den diversen Programmiersprachen. ;)

Edit: wget-ssl, etc. sind installiert?

Biomann

Schüler

Beiträge: 137

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

130

Mittwoch, 22. August 2007, 15:47

Mit Teil meine ich das Script, Apache und die NSLU laufen problemlos weiter, bloß das Script ist tot, ein erneuter aufruf bringt auch nix. Pakete sind alle installiert und unter Hilfe wird auch alles als okay angezeigt.

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

131

Mittwoch, 22. August 2007, 15:52

D.h. bei einem erneuten Aufruf versucht der Browser das Script zu laden, zeigt aber nichts an, richtig? Welche Seiten kannst du denn ohne Probleme aufrufen? Hilfe, und welche noch? url2links?

Biomann

Schüler

Beiträge: 137

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

132

Mittwoch, 22. August 2007, 16:15

nichts von alldem funktioniert mehr, apache generell und der root von apache ist aber noch erreichbar. Wenn du icq hast kann ich dir ja mal zugang geben

meine nummer ist 78936870

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

133

Mittwoch, 22. August 2007, 16:17

Schau mal (z.B. mit htop) nach, welcher Prozess da eventuell irgendwo hängt. Per ICQ kann ich dich erst heute abend kontaktieren.

Biomann

Schüler

Beiträge: 137

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

134

Mittwoch, 22. August 2007, 16:22

Wie finde ich denn mit htop heraus welcher Prozess hängt? Es ist auch kein neuer dabei, z.B. wget, eigentlich ist alles beim alten und Apache ist auch noch okay.

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

135

Mittwoch, 22. August 2007, 16:34

Starte doch mal die NSLU2 neu und schau dir dann htop an. Jetzt bring das Script zum Absturz und schau dir dann htop erneut an. Es muss ja einen Grund geben, warum das Script dann plötzlich nicht mehr laufen möchte.

Vielleicht können dir die apache-logs auch weiterhelfen.

Biomann

Schüler

Beiträge: 137

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

136

Mittwoch, 22. August 2007, 16:47

Ich werd´s jetzt einfach mal mit nem anderen Webserver testen. Welchen benutzt ihr denn?

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

137

Mittwoch, 22. August 2007, 16:50

Also ich benutze, wie wohl einige andere hier auch, appWeb. Den Indianer kennen wohl die meisten, aber er ist leider ein wenig zu hungrig was Ressourcen betrifft. ;)

Biomann

Schüler

Beiträge: 137

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

138

Mittwoch, 22. August 2007, 17:09

Mit Appweb läuft´s :D

Allerdings noch nicht ganz. Das Script stürzt nicht mehr ab, aber downloaden scheint nicht zu funktionieren. Ich füge den Link ein, klicke auf weiter, der Link wird als online angezeigt, dann geht´s weiter mit Download starten. Für einen Moment stand bei aktuelle Downloads eine 1, kurz danach nicht mehr. Sobald ich auf aktuelle downloads klicke steht da nur "keine logfiles vorhanden". Allerdings wird mir angezeigt dass mein aktueller Speed 0.01kb/s wäre. Heißt das dann er lädt trotzdem runter? Wäre ein bisschen langsam...

Biomann

Schüler

Beiträge: 137

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

139

Mittwoch, 22. August 2007, 17:11

Okay hat funktioniert. Lag wohl an dem ersten Download den ich getestet habe. Geiles Teil :D

Phantomias2006

Fortgeschrittener

  • »Phantomias2006« ist der Autor dieses Themas

Beiträge: 309

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

140

Mittwoch, 22. August 2007, 17:55

Hi

Ich hatte damals mit dem Apache das selbe prob wie du nur eben mit der ectc von warti hab das teil auch nie zum laufen gebracht bis ich appweb installiert hab wäre aber mal interessant an was da wirklich liegt hat mir ein paar schlaflose nächte gekostet:D

@kingofkomedy:Kannst du mir mal für Windoof eine C++ Version zukommen lassen:D

mfg
Phantomias

PS: hätt ich fast vergessen ich hab auch probs mit der final:

Aktueller Speed: 5.75 kB/s :D das is mir zu langsam und wird ned schneller seit gestern lade ich an 2files mit je 100mb und bin grad bei 79% fällt dir was ein dazu? ähm speedlimit is bei mir ned eingeschaltet

Zur Zeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Social Bookmarks