Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

681

Donnerstag, 10. April 2008, 21:47

Dein www-Verzeichnis liegt in /opt/share/www/ ? Liegt das beim Apache nicht normalerweise in /var/www/ ? Nun, soll mich nicht stören. ;)

Das Verzeichnis /opt/share/www/rsdm/ ist auch auf 777 gesetzt? Denn ansonsten kann vermutlich auch keine sh-Datei angelegt werden.

Beiträge: 20

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

682

Donnerstag, 10. April 2008, 21:56

Zitat von »kingofcomedy;31870«

Dein www-Verzeichnis liegt in /opt/share/www/ ? Liegt das beim Apache nicht normalerweise in /var/www/ ? Nun, soll mich nicht stören. ;)

Das Verzeichnis /opt/share/www/rsdm/ ist auch auf 777 gesetzt? Denn ansonsten kann vermutlich auch keine sh-Datei angelegt werden.


Das mit dem Verzeichnis ist schon richtig so, ist ja nen optware-package.

Auch das Verzeichnis hat 777. Das ist es ja, es passt leider alles.

Was mir noch aufgefallen ist, ich muss nachdem es hängt die Cookies löschen, ansonsten ist ein Seitenaufruf nicht mehr möglich.

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

683

Mittwoch, 16. April 2008, 11:51

Zitat von »loomes;30721«

Habe mir das Tool gerade mal installiert. Gefällt mir sehr gut. Wäre es für eins der nächsten Releases möglich in der Downloadübersicht ajax zum refreshen zu benutzen? Und dann auch nur die Balken der einzelnen Fortschritte? Das würde die Sache noch perfekter machen.

Mein interner Ajax-Test läuft schon ziemlich gut. Alle 20-30 Sekunden wird der Prozentwert neu angefragt und der Fortschrittbalken neu geladen. Das Problem: mit dem Erreichen der 100% müsste sich im linken Bereich, d.h. unter dem Dateinamen auch einiges ändern. Da stellt sich mir (bzw. stell ich Euch ;)) die Frage: reicht es nicht einfach die Balken alle 20-30 Sekunden und die komplette Seite alle X Sekunden neu zu laden? :confused:

@Frittenschmied: läuft das Script unter AppWeb jetzt fehlerfrei? :)

Phantomias2006

Fortgeschrittener

  • »Phantomias2006« ist der Autor dieses Themas

Beiträge: 309

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

684

Mittwoch, 16. April 2008, 14:45

Ja also für meinen Teil würde es ausreichen
Solange ich die Zeit x selber bestimmen kann :)
alle 20Sekunden den Balken Aktualisieren und alle 90 oder 120 die ganze Seite
hört sich recht gut an...

mfg
Phantomias

685

Mittwoch, 16. April 2008, 17:08

bevor ich das ganze nun installier, interessiert mich noch:

wie kommen meine links vom browser zur NSLU?

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

686

Mittwoch, 16. April 2008, 17:11

Auf dem normalen POST-Weg, d.h. du kopierst deine Links in das Webinterface-Formular und klickst anschliessend auf "Absenden".

@Phantomias2006: X = refreshlogs in der config.inc.php ;)

687

Mittwoch, 16. April 2008, 18:29

ach mist, oki, dann bastel ich mal weiter :)

ich bastel mir gerade python skripte (client und server) um links die ich auf dem client (mein rechner) anklicke, automatisch in eine text datei auf dem server (NSLU2) zu schreiben.

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

688

Mittwoch, 16. April 2008, 18:53

Mit welchem Hintergedanken? D.h. was soll dann auf dem Server mit der Datei gemacht werden?

689

Mittwoch, 16. April 2008, 18:56

mit dem Hintergedanken diese datei dann per skript mit wget (oder curl) zeilenweise abzuarbeiten und die links zu saugen

Das kann dann ja auch zeitgesteuert automatisch vonstatten gehen, da hab ich mir noch keine Gedanken drüber gemacht.
Am Ende des vorgangs dann noch son "for i in *.part1.rar do unrar" ;)

Is noch halbwegs theoretisch das ganze, bis auf die Client / Server Verbindung und das schreiben in ne text datei gibts noch nix.

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

690

Mittwoch, 16. April 2008, 19:10

Ok, aber wenn ich mich nicht täusche, macht mein in diesem Thread verfügbares Script eigentlich genau das. ;)

Und mir ist wieder eingefallen (ich nutze diese Funktion praktisch nie :)), dass man natürlich auch einfach nur Links in einer Datei speichern kann. Die Datei kann dann jederzeit abgearbeitet werden. :)

691

Mittwoch, 16. April 2008, 19:13

joa dann könnt ich mit meinem aktuellen Stand, mein tool einfach noch als Aufsatz nehmen und fülle dann die Datei die dein skript braucht.

Oki, ich schau mir das mal an ;)

donstephano

Anfänger

Beiträge: 16

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

692

Samstag, 19. April 2008, 19:29

Hi,

hab ein Problem beim einrichten des Tools, und zwar werden alle Ordner die außerhalb des Ordners in dem das webinterface installiert ist nicht erkannt.

z.b: wget: /opt/bin/wget ⇒ Datei nicht gefunden ...

alle ordner innerhalb des interface ordners werden jedoch erkannt:

z.b Downloadordner: "/volume1/web/rsdm_270/rs" ⇒ Ordner existiert ...
Downloadordner: "/volume1/web/rsdm_270/rs" ⇒ Ordner hat Schreibrechte ...

wo liegt der fehler, vll die benutzerrechte. hab schon ein wenig experimentiert - hat jeodch nicht geholfen.
hat das problem irgendwas mit chown zu tun wenn ja, wie stell ich chown richtig ein?
würde mich über etwas hilfe freuen.

mfg

ps: hat das das evtl. etwas mit apache zu tun? von wegen docroot, lässt sich das was machen?

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

693

Samstag, 19. April 2008, 21:16

Welchen Webserver nutzt du? Apache, richtig? :)
"open_basedir" ist in deinem Fall aktiviert. Schau dir mal folgende Seite an: http://de.php.net/manual/en/features.saf…ni.open-basedir

Ich weiss, dass letztens bereits ein User dieses Problem gehabt hat, aber ich weiss leider nicht mehr, welcher User das gewesen ist. Vielleicht meldet er sich ja mal.

donstephano

Anfänger

Beiträge: 16

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

694

Sonntag, 20. April 2008, 08:42

ja genau, benutze apache und habe den open_basedir fehler.
hab die httpd.conf schon verändert auf

<directory/>
"php_admin_value open_basedir none"
</directory>

. funktioniert aber leider immer noch nicht, ist so als wenn ich nichts vereändert habe. hab ichs vll falsch eingebunden? wenn ja wie sollte das genau in der httpd.conf aussehen.

mfg

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

695

Sonntag, 20. April 2008, 09:00

Du hast den Apache nach der Änderung neu gestartet? Erstell mal eine info.php mit folgendem Inhalt:

Quellcode

1
2
3
<?php
phpinfo();
?>

Ruf die Seite auf und schau mal nach, was im Bereich "Environment" für die PATH-Variable eingetragen ist. Vermutlich fehlt da auch der "/opt/bin" - Pfad.

donstephano

Anfänger

Beiträge: 16

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

696

Sonntag, 20. April 2008, 09:09

hi,

erstmal danke für die schnelle antwort.
ja neugestartet habe ich. bei der phpinfo() unter environment fehlt der "/opt/bin" pfad tatsächlich. kann ich da was machen?

mfg

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

697

Sonntag, 20. April 2008, 09:46

Probiere mal folgenden Befehl in der Konsole:

Quellcode

1
PATH=$PATH:/opt/bin
Ansonsten sollte auch google.de weiterhelfen können. Oder ein Apache-User, der sich hier meldet. :)

Edit: und schau auch mal hier: http://www.nslu2-info.de/showthread.php?t=6996

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

698

Sonntag, 20. April 2008, 17:43

Zitat

RSDM 2.9.6, 20.04.2008

Veraenderte Dateien: config.inc.php, header.php, index.php, logs.php, phpfe.php, rsdm_main.php, uploads.php, js/check.js, phpfe/css/phpFe.css

Neue Dateien: ajax.php, uploads_start.php, js/ajax.js, images/refresh.png, upload/formcheck.js

- Neue Variablen in der config.inc.php ($fepath, $fepath_users)

====> HINWEIS: wer das Upload- bzw. File Explorer - "Modul" nicht nutzen moechte, entfernt einfach die entsprechenden Dateien (uploads.php + uploads_start.php + upload/* bzw. phpfe.php + phpfe/*). Die Links in der Navigation werden dann automatisch nicht mehr angezeigt.

- config.inc.php -> $refreshlogs von "60" auf "180" erhoeht
+ index.php + rsdm_main.php -> Texte ergaenzt
x rsdm_main.php -> Berechnung der Downloaddauer korrigiert
x header.php + uploads.php + upload/formcheck.js -> Check, ob ueberhaupt Files zum Uploaden markiert wurden
+ header.php -> "DL- / UL-Speed" - Anzeige jetzt auch auf der uploads.php
+ header.php -> "Upload" - Link durch Icon ersetzt
x phpfe.php -> Problem mit Sortierung behoben
+ phpfe.php -> $fepath + $fepath_users zu config.inc.php hinzugefuegt (genaue Erlaeuterungen siehe config.inc.php)
+ uploads.php -> Dateien in der Warteschleife werden mit einem entsprechenden Icon gekennzeichnet
- uploads.php + uploads_start.php -> modifiziertes PHP File Explorer - Script wird jetzt als uploads.php verwendet
x logs.php -> Problem beim Loeschen von kompletten Downloads behoben
+ logs.php + ajax.php + js/ajax.js + images/refresh.png -> manueller Ajax-Refresh



RSDM 2.9, 12.04.2008

Veraenderte Dateien: auth.php, functions.inc.php, header.php, help.php, index.php, info.php, links.php, login.php, logs.php, rsdf_decode.py, rsdm_main.php, unrar.php, unrar.pl, url2links.php, js/check.js, om4/header.php, om4/index.php, om4/login.php, om4/logs.php

Neue Dateien: uploads.php, upload/*, images/plus.png, images/minus.png, images/soundfile.png, images/upload.png, images/fe.png, js/cdown.js, phpfe.php, phpfe/*

- Neue Variablen in der config.inc.php ($maxunrar, $upload_path)

====> HINWEIS: wer das Upload- bzw. File Explorer - "Modul" nicht nutzen moechte, entfernt einfach die entsprechenden Dateien (uploads.php + uploads_start.php + upload/* bzw. phpfe.php + phpfe/*). Die Links in der Navigation werden dann automatisch nicht mehr angezeigt.

+ help.php -> Infos ergaenzt
* phpfe/* + phpfe.php + info.php + images/fe.png -> PHP File Explorer
+ index.php -> "Soundfile abspielen" - Icon mit Mouse-Over fuer Anzeige der Sound-Datei
x auth.php -> USER_AGENT bzw. HTTP_USER_AGENT - Fix
x header.php + login.php + om4/* -> ein paar kleine Fehler beseitigt
x header.php -> $limitreached & $traffictoday muss nur angezeigt bzw. berechnet werden, wenn $showtraffictoday in der config.inc.php auf "1" gesetzt ist
+ header.php + js/cdown.js -> "**** refresh" - Countdown
x functions.inc.php + rsdm_main.php + unrar.php -> Problem mit bestimmten Zeichen (. und &) in unrar-Passwoertern behoben
x rsdm_main.php -> Angeforderte Dateien, die bereits runtergeladen wurden, werden wieder korrekt markiert (NICHT userspezifisch!) (siehe v2.0 RC2)
+ rsdm_main.php -> bei rsdf- und url2links-Dateien kann das Passwort automatisch erkannt werden -> "dateiname_PWD_PASSWORT.rsdf" bzw. "dateiname_PWD_PASSWORT"; Haken bei "Passwort zum Entpacken notwendig?" setzen, aber Feld leer lassen!
* upload/* + uploads.php + header.php + info.php -> Rapidshare-Upload (benoetigte "Software": GNU bash, curl, md5sum, sed)
- links.php -> Link korrigiert
+ rsdm_main.php + unrar.pl -> es werden nur noch maximal X unrar-Prozesse gleichzeitig ausgefuehrt (siehe $maxunrar in der config.inc.php)
+ logs.php -> Anzeige aktuelle Anzahl der Dateien: Downloading, Completed, To Go, Extracting (userspezifisch!) durch die entsprechenden Icons ersetzt
x logs.php -> Downloadspeed wurde unter bestimmten Umstaenden falsch berechnet (sofern $wgetdlspeed in der config.inc.php auf "1" gesetzt ist)
x logs.php -> Downloadspeed ("0.00") wurde nicht angezeigt, wenn es keine log-Files gibt (sofern $wgetdlspeed in der config.inc.php auf "1" gesetzt ist)
- help.php -> md5sum fuer rsdf_decode.py angepasst
x rsdf_decode.py -> rsdf-Dateien, die zuvor ccf-Dateien gewesen sind, koennen jetzt NOCH besser verarbeitet werden
+ rsdm_main.php -> Accesskey + Z => "Zurueck" (Accesskey unter Mozilla Firefox 2.0: Alt + Shift)
Viel Spass. :)

Edit: alte Version aus dem Anhang entfernt.

donstephano

Anfänger

Beiträge: 16

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

699

Sonntag, 20. April 2008, 18:30

hallo,

hab es dank dir fast geschafft, nur noch ein paar fehler.
und zwar:


Warning: file_get_contents(rs_premium_logs.txt) [function.file-get-contents]: failed to open stream: No such file or directory in /volume1/web/rsdm_270/header.php on line 242

Warning: exec() [function.exec]: PHP exec disable. in /volume1/web/rsdm_270/header.php on line 258
Traffic heute: Keine Verbindung zu rapidshare.com
Warning: exec() [function.exec]: PHP exec disable. in /volume1/web/rsdm_270/header.php on line 269

Warning: file_get_contents(rs_premium_info.txt) [function.file-get-contents]: failed to open stream: No such file or directory in /volume1/web/rsdm_270/header.php on line 270

Warning: exec() [function.exec]: PHP exec disable. in /volume1/web/rsdm_270/header.php on line 278

rsdf_decode.py - md5sum: Falsch!
da kann mir doch bestimmt jemand bei helfen.

mfg

ps: in meiner php.ini ist safe_mode = Off, trotzdem die fehlermeldung..

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

700

Sonntag, 20. April 2008, 18:49

Wenn der Safe-Mode in der php.ini bereits deaktiviert ist, dann schau mal in der httpd.conf nach.

Zur Zeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Social Bookmarks