Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

381

Montag, 14. Januar 2008, 21:41

meinst du einen auf meinem usb stick?
er lädt aber alles korrekt runter weil ich per hand die rechte auf 777 gesetzt habe
rsdf funzt nicht... er erstellt die txt nicht...

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

382

Montag, 14. Januar 2008, 21:43

Ok, sehe ich das richtig, dass jetzt alles bis auf rsdf funktioniert? /dev/null war das primäre Problem?

Die Schreibrechte für den RSDM-Ordner sind auf 777? Ansonsten kann die txt-Datei ggf. nicht angelegt werden.

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

383

Montag, 14. Januar 2008, 21:45

also ein problem habe ich nicht es wäre halt nur schön das rsdf klappt... denn für os x gibt es kein rsdf downloader... darum muss ich immer windows laufen lassen auf meinem macbook das nervt :-)

ja rechte sind auf 777 ... was ist eigentlich der unterschied zwischen chmod und chmod -R ?

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

384

Montag, 14. Januar 2008, 21:48

man chmod hilft ;)

Zitat

-R, --recursive
change files and directories recursively

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

385

Montag, 14. Januar 2008, 22:08

ich habe mal folgendes gemacht aber ohne erfolg
mkdir /rapidshare

ln -s /share/hdd/data/HDD_1_1_1/rapidshare /rapidshare (abstand habe ich eben fürs board vergrößert)

chmod 777 /rapidshare

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

386

Montag, 14. Januar 2008, 22:09

Das mkdir vorher solltest du weg lassen. Ansonsten wird das wohl nicht klappen. Der Sym-Link reicht vollkommen aus.

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

387

Montag, 14. Januar 2008, 22:15

nun habe ich es mal gemacht wie du es gesagt, also
ln -s /opt/share/hdd/HDD_1_1_1/rapidshare /rapidshare
es handelt sich um eine 500GB ntfs platte diese ist noch vollkommen leer bis auf einen leeren ordner namens rapidshare auf root der platte...

wenn ich es richtig verstanden habe, sollte ein ls /rapidshare nun einen leeren ordner anzeigen, es wird mir allerdings /rapidshare ausgegeben also noch ein ordner,,,,


# ln -s /share/hdd/data/HDD_1_1_1/rapidshare /rapidshare
# chmod -R 777 /rapidshare

root@Nabby:/> ls /rapidshare
/rapidshare

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

388

Montag, 14. Januar 2008, 22:18

Ok, mal langsam. Der Download klappt doch, oder nicht? Es gibt nur noch Probleme mit dem RSDF, richtig? Das Script liegt bei dir in /opt/share/hdd/HDD_1_1_1/rapidshare?

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

389

Montag, 14. Januar 2008, 22:19

nein das script liegt in /web/rsdm

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

390

Montag, 14. Januar 2008, 22:23

chmod 777 /web/rsdm

:)

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

391

Montag, 14. Januar 2008, 22:25

Die Dateien werden in folgenden Ordner runtergeladen: /rapidshare/

rsdf - Datei erfolgreich decodiert!
Name: KO.rsdf
Größe: 10718 Byte
MIME-Type: application/octet-stream
Link: KO.rsdf


Warning: fopen(KO.txt) [function.fopen]: failed to open stream: No such file or directory in /web/rsdm/rsdm_main.php on line 136

Warning: feof(): supplied argument is not a valid stream resource in /web/rsdm/rsdm_main.php on line 137

Warning: fgets(): supplied argument is not a valid stream resource in /web/rsdm/rsdm_main.php on line 139

Warning: feof(): supplied argument is not a valid stream resource in /web/rsdm/rsdm_main.php on line 137

Warning: fgets(): supplied argument is not a valid stream resource in /web/rsdm/rsdm_main.php on line 139

Warning: feof(): supplied argument is not a valid stream resource in /web/rsdm/rsdm_main.php on line 137

Warning: fgets(): supplied argument is not a valid stream resource in /web/rsdm/rsdm_main.php on line 139

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

393

Montag, 14. Januar 2008, 22:43

hast du msn oder icq?

Phantomias2006

Fortgeschrittener

  • »Phantomias2006« ist der Autor dieses Themas

Beiträge: 309

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

394

Montag, 14. Januar 2008, 23:34

und läufts jetzt??

hast du das ^M noch immer in den php datein oder hast das jetzt nicht mehr??

jensausw

Anfänger

Beiträge: 20

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

395

Dienstag, 15. Januar 2008, 00:17

N'abend.

Hab genau das gleiche Problem wie ronwaste.

Allerdings habe ich mir auf der Platte eine ext3-Partition eingerichtet, auf die ich speichere. Jetzt stimmt nur das decodieren der .rsdf nicht. Ich warte jetzt gerne mal ab, weil ich mich in den letzten Tagen zu wenig um die Familie gekümmert habe...:o

Gruß und Danke erstmal
Jens

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

396

Dienstag, 15. Januar 2008, 06:04

Ja, bei ronwaste läuft jetzt alles, also zumindest war das vor 6 Stunden der Fall, nachdem ich ein wenig auf seiner NSLU2 "rumgebastelt" habe. :D Das Problem: die Zeilen in der rsdf_decode.py waren teilweise nicht richtig eingerückt und das mag Python leider überhaupt nicht.

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

397

Dienstag, 15. Januar 2008, 14:43

Genau es geht auch nach wie vor alles ! Danke noch einmal für deine klasse Unterstützung! WOW!

ich habe nun auch noch zwei weitere Probleme beheben können und würde gerne sagen wie ich es gemacht habe.

zum Ersten wurde mir kein speed angezeigt... ich also

vnstat -tr und dann kam immer ixp0: Not enough data available yet.
also habe ich mal geschaut wo die Datenbank anlegt wenn man:

vnstat -u -i ixp0 eingibt... dies geschieht bei /opt/var/lib/vnstat/ixp0...
diese habe ich gelöscht und neu angelegt.

danach kam der Fehler erneut und ich habe die rechte auf 777 gesetzt... et voila es klappt alles! es handelte sich bei mir also nur um ein rechteproblem.


Desweiteren hatte ich ein problem weil ich meine unslung auf nem stick habe aber gerne auf die hdd schreiben will (ntfs)... ich habe mich ein wenig umgeschaut im forum und habe auch etwas gefunden:

erstmal habe ich auf FAT32 formatiert... dann hatte ich auf der Hilfeseite, dass Problem das der ordner angeblich nicht existiert oder er keine schreibrechte besitzt...
ein ausführen der vorgeschlagenen Befehle half nichts.

Ich habe nun meine Festplatte gemountet normalerweise mountet man ja in /mnt/name .... dies ist aber falsch denn man muss nach /share/(flash/hdd)/data/mnt/name mounten... ich ging bisher davon aus /share/(flash/hd)/data/mnt sei identisch mit /mnt dem ist aber nicht so... danach habe ich die rechte noch auf 777 gesetzt und nun klappt alles wunderbar!

es wird zwar ausgegeben das er beim download die rechte nicht ändern kann, aber es klappt trotzdem alles uneingeschränkt :-)

jensausw

Anfänger

Beiträge: 20

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

398

Dienstag, 15. Januar 2008, 19:24

Zitat von »ronwaste;29585«



Ich habe nun meine Festplatte gemountet normalerweise mountet man ja in /mnt/name .... dies ist aber falsch denn man muss nach /share/(flash/hdd)/data/mnt/name mounten... ich ging bisher davon aus /share/(flash/hd)/data/mnt sei identisch mit /mnt dem ist aber nicht so... danach habe ich die rechte noch auf 777 gesetzt und nun klappt alles wunderbar!

es wird zwar ausgegeben das er beim download die rechte nicht ändern kann, aber es klappt trotzdem alles uneingeschränkt :-)



/mnt ist ein Standard-Mountpoint. Theoretisch kannst du einen beliebigen Ordner erstellen - auch im root-Verzeichnis, und darin dann mounten. Hat bei mir geklappt.

Aber: Welches Format hat denn jetzt deine Partition? Fat32? Dann kannst du die doch glaub ich nur 4GB groß machen? Oder ist es tatsächlich doch NTFS? Dann sollte ich den kingofcomedy auch mal "wurschteln" lassen!!! :rolleyes:

Gruß
Jens

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

399

Dienstag, 15. Januar 2008, 22:07

ähm die 4 GB beschränkung gilt nur wir microsoft windows produkte... ich nutze hier jedoch ausschließlich mac os x... und es ist fat32

jensausw

Anfänger

Beiträge: 20

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

400

Mittwoch, 16. Januar 2008, 00:00

Zitat von »kingofcomedy;29569«



Hi,

ich glaube das Problem ist damit nicht gelöst. nach dem Löschen der Zeilen 134 - 142 passiert folgendes:

Die Dateien werden in folgenden Ordner runtergeladen: /Platte/

rsdf - Datei erfolgreich decodiert!
Name: TWrsdf.rsdf
Größe: 454 Byte

Warning: fopen(TWrsdf.txt) [function.fopen]: failed to open stream: No such file or directory in /webserver/rsdm_main.php on line 150

Warning: feof(): supplied argument is not a valid stream resource in /webserver/rsdm_main.php on line 152

Warning: fgets(): supplied argument is not a valid stream resource in /webserver/rsdm_main.php on line 154

Warning: feof(): supplied argument is not a valid stream resource in /webserver/rsdm_main.php on line 152

Warning: fgets(): supplied argument is not a valid stream resource in /webserver/rsdm_main.php on line 154


Nein, bitte nicht diese Antwort: chmod 777 /webserver
Das hab ich schon durch!!!



In welcher Zeile der rdsm:main.phpwird denn die .txt-Datei gespeichert? Ich finde es nicht?! Macht das Phyton?!

Ich gehe davon aus, dass die Datei fehlt, und nicht das Verzeichnis :D .

Hab jetzt nicht den ganzen Script der rsdm_main.php studiert, aber irgendwie wird nur plötzlich eine .txt-Datei gesucht. Aber wieso ausgerechnet eine .txt? Es wird aber nur der Inhalt der Variable $Linktxt geändert.

Lieg ich falsch? :confused:

Gibt's eine aktuellere Version der rsdm_main.php ? Hab die 1.8 direkt nach Sylvester geladen, sozusagen direkt nach dem Release...


Gruß
Jennes

Zur Zeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Social Bookmarks