Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

301

Samstag, 5. Januar 2008, 13:53

Bei mir werden die Sessions in /opt/var/lib/php/session/ gespeichert. Lösch ich alle Dateien in dem Verzeichnis, dann bin ich, so wie es auch sein sollte, ausgeloggt.

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

302

Sonntag, 6. Januar 2008, 11:45

So, ab morgen ruft wieder die Arbeit, d.h. Updates wird es dann vermutlich nur an den Wochenenden geben.

Die nächste Version wird neben den in den letzten Postings erwähnten Fixes u.a. eine einfache Option für "direkte/normale" Downloads enthalten und die logs.php wird optisch überarbeitet sein. :)

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

303

Donnerstag, 10. Januar 2008, 20:22

So, kurze Frage an die RSDM-Nutzer: wie sollen im Logs-Bereich die unrar-log-Files ausgegeben werden? So wie in Version 1.8.0, d.h. der Text soll ausgeklappt werden?! Oder lieber als PopUp? Will man sich die unrar-log-files überhaupt ansehen?

Phantomias2006

Fortgeschrittener

  • »Phantomias2006« ist der Autor dieses Themas

Beiträge: 309

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

304

Donnerstag, 10. Januar 2008, 22:52

Ich würd sagen als Text wie in der 1.8.0
Stylischer war zwar das POPUP aber ich find das
in Text form zum ausklappen besser

mfg
Phantomias

jensausw

Anfänger

Beiträge: 20

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

305

Donnerstag, 10. Januar 2008, 22:54

Hallo!

Sehr schönes Ding, was ihr hier gezaubert habt!!!

Ich habe doch ein kleines Problem:

Ich bekomme einen Ordner auf der Festplatte nicht eingestellt:

Notwendige Ordner überprüfen ...

RSDM - Webordner: "/webserver" ⇒ Ordner existiert ...
RSDM - Webordner: "/webserver" ⇒ Ordner hat Schreibrechte ...

Downloadordner: "/share/hdd/data/HDD_1_1_1/Rapidshare/slug" ⇒ Ordner existiert nicht ...

Hilfe:
  1. Pfad des Ordners in der config.inc.php anpassen
  2. Ordner erstellen ⇒ "mkdir /share/hdd/data/HDD_1_1_1/Rapidshare/slug"
Ein Tippfehler kann es nicht sein, bei dem mkdir bekomm ich die Meldung, dass der Ordner schon existiert

Und das gleiche Ergebnis bekomme ich beim unrar-Ordner.

Habt ihr da 'ne Lösung?

Gruß
Jens

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

306

Freitag, 11. Januar 2008, 06:37

Zitat von »Phantomias2006;29372«

Ich würd sagen als Text wie in der 1.8.0
Stylischer war zwar das POPUP aber ich find das
in Text form zum ausklappen besser

Mich stört dieses Ausklappen, besonders bei etwas längeren Texten, mittlerweile irgendwie. :)

Zitat von »jensausw;29374«

Downloadordner: "/share/hdd/data/HDD_1_1_1/Rapidshare/slug" ⇒ Ordner existiert nicht ...

Hilfe:
  1. Pfad des Ordners in der config.inc.php anpassen
  2. Ordner erstellen ⇒ "mkdir /share/hdd/data/HDD_1_1_1/Rapidshare/slug"
Ein Tippfehler kann es nicht sein, bei dem mkdir bekomm ich die Meldung, dass der Ordner schon existiert

Und das gleiche Ergebnis bekomme ich beim unrar-Ordner.

Habt ihr da 'ne Lösung?

Spontan kann ich mir nicht erklären, warum das Script den Ordner nicht finden kann. Eine Lösung wäre, einfach einen Ordner im Root-Verzeichnis (z.B. /rapidshare) anzulegen.

Unrar-Ordner? Da muss der Pfad zum "Unrar-Programm" genannt werden. Das sollte /opt/bin/unrar sein. Hast du denn unrar schon installiert?

jensausw

Anfänger

Beiträge: 20

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

307

Freitag, 11. Januar 2008, 21:03

Stimmt, das mit unrar ist klar, war doof...Ja, unrar ist installiert und läuft. (Hatte gedacht, dass wäre der Ordner, in der die entpackten Dateien reinkommen...Es war ja schon spät:eek:)

Nee, mit der Festpatte krieg ich es nicht hin. Ich bin jetzt kein Linux-Experte, aber kann ich nicht irgendwie ein Verzeichnis erstellen, was direkt unter dem root-Verzeichnis liegt, aber in Wirklichkeit ein Verzeichnis ist, was ganz woanders ist? Vielleicht mit der bashrc ?!

Gruß
Jens

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

308

Freitag, 11. Januar 2008, 21:20

Zitat von »jensausw;29390«

Nee, mit der Festpatte krieg ich es nicht hin. Ich bin jetzt kein Linux-Experte, aber kann ich nicht irgendwie ein Verzeichnis erstellen, was direkt unter dem root-Verzeichnis liegt, aber in Wirklichkeit ein Verzeichnis ist, was ganz woanders ist?

Da du unrar installiert hast, gehe ich mal davon aus, dass du via Telnet und/oder SSH auf die NSLU2 zugreifen kannst, richtig? Dann einfach mit "cd /" in das Hauptverzeichnis wechseln und folgenden Befehl eingeben:

ln -s /share/hdd/data/HDD_1_1_1/Rapidshare/slug /rapidshare

In der config.inc.php den $download_path einfach auf "/rapidshare" setzen. Eventuell wirst du dann noch Schreibrechte setzen müssen.

jensausw

Anfänger

Beiträge: 20

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

309

Freitag, 11. Januar 2008, 23:39

Zitat von »kingofcomedy;29391«

Da du unrar installiert hast, gehe ich mal davon aus, dass du via Telnet und/oder SSH auf die NSLU2 zugreifen kannst, richtig? Dann einfach mit "cd /" in das Hauptverzeichnis wechseln und folgenden Befehl eingeben:

ln -s /share/hdd/data/HDD_1_1_1/Rapidshare/slug /rapidshare

In der config.inc.php den $download_path einfach auf "/rapidshare" setzen. Eventuell wirst du dann noch Schreibrechte setzen müssen.


Ja, richtig, ich mach's über Telnet.

Dadurch erstelle ich einen Link auf den Ordner, der unter MidnightCommander als ~Rapidshare angezeigt wird.

$download_path = "/rapidshare" klappt hierbei auch nicht

und der Versuch
$download_path = "~rapidshare" geht auch nicht.

Der String ist ja relativ lang. Gibt's hier vielleicht eine Längenbeschränkung?

Gruß
Jens


jensausw

Anfänger

Beiträge: 20

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

310

Freitag, 11. Januar 2008, 23:59


Dann fällt mir noch was auf:

Downloadordner: "/share/hdd/data/HDD_1_1_1/Rapidshare" ⇒ Ordner existiert nicht ...

Wenn ich nur die Festplattenpartition anspreche habe ich nur

Downloadordner: "/share/hdd/data/HDD_1_1_1" ⇒ Ordner hat keine Schreibrechte ...

Also, scheint diese Adresse zu funktionieren, aber der Partition kann ich keine schreibrechte geben. (Warum eigentlich nicht?)

Gruß
Jens

jensausw

Anfänger

Beiträge: 20

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

311

Samstag, 12. Januar 2008, 00:36

Ööh, kann die Platte NTFS-Formatiert sein?:eek:
Gruß
Jennes

koepie

Anfänger

Beiträge: 2

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

312

Samstag, 12. Januar 2008, 10:08

Servus! mir gefällt dieses tool wirklich sehr!!!!
allerdings funzt es noch net vollständig...
Ich habe suse linux 10.1

Was brauche ich da von diesen Programmen :

$wget_path = "/usr/bin/wget"; // Path to wget executable
$nohup_path = "/usr/bin/nohup"; // Path to nohup executable
$unrar_path = "/usr/bin/unrar"; // Path to unrar executable
$vnstat_path = "/usr/bin/vnstat"; // Path to vnstat executable
$df_path = "/opt/bin/df"; // Path to df executable
$python_path = "/usr/bin/python"; // Path to python executable
$nice_path = "/usr/bin/nice"; // Path to nice executable
$nail_path = "/usr/bin/nail"; // Path to nail executable

?


Ich bekomme diese Fehlermeldungen wenn ich was über rsdf runterladen will
die Links werden zwar deyrypted aber ich kann sie nicht runterladen :-(

Notice: Undefined offset: 3 in /srv/www/vhosts/bgi07.ath.cx/subdomains/rsl/httpdocs/functions.inc.php on line 108

Notice: Undefined offset: 1 in /srv/www/vhosts/bgi07.ath.cx/subdomains/rsl/httpdocs/functions.inc.php on line 108

Warning: Division by zero in /srv/www/vhosts/bgi07.ath.cx/subdomains/rsl/httpdocs/functions.inc.php on line 108

Notice: Undefined offset: 3 in /srv/www/vhosts/bgi07.ath.cx/subdomains/rsl/httpdocs/functions.inc.php on line 117


Wo ist eigentlich der Donate LINK`? :-)

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

313

Samstag, 12. Januar 2008, 10:16

@jensausw: Gute Frage. Ich möchte nicht ausschliessen, dass es an der NTFS-Formatierung liegt. Frage in die Runde: nutzt jemand den RSDM mit NTFS?

@koepie: die Fehlermeldungen lassen darauf schliessen, dass der Pfad zu "df" nicht stimmt. Von den Programmen brauchst du eigentlich alle. :)
Klick mal oben rechts auf das Fragezeichen und schau dir die roten Fehlermeldungen an.

Edit: den Donate - Link wird es in der nächsten Version geben. :)

koepie

Anfänger

Beiträge: 2

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

314

Sonntag, 13. Januar 2008, 16:33

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#!/usr/bin/env python

import binascii
import base64
from Crypto.Cipher import AES
import sys
import re

# 8C 35 19 2D 96 4D C3 18 2C 6F 84 F3 25 22 39 EB 4A 32 0D 25

infile = sys.argv[1]
rs_txt = infile.replace('.rsdf', '.txt')
Key = binascii.unhexlify('8C35192D964DC3182C6F84F3252239EB4A320D2500000000')

IV = binascii.unhexlify('FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF')
IV_Cipher = AES.new(Key,AES.MODE_ECB)
IV = IV_Cipher.encrypt(IV)

obj = AES.new(Key,AES.MODE_CFB,IV)

rsdf = open(infile,'r')

data = rsdf.read()
pattern = re.compile('\\000*')
data = pattern.sub('',data)
data = binascii.unhexlify(''.join(data.split()))
data = data.splitlines()

rs_txt = file(rs_txt,'wb')

for link in data:
    link = base64.b64decode(link)
    link = obj.decrypt(link)
    rs_txt.writelines(link.replace('CCF: ','')+'\r\n')

rs_txt.close()
rsdf.close()


hab das decoder script verbessert jetzt kann man auch rsdf datein verwenden die vorher mal ccf datein waren

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

315

Sonntag, 13. Januar 2008, 16:35

er will einfach nicht...

Hallo ihr lieben Götter, ich habe meine sluggy nun seid 4 Tagen und habe alles soweit unter kontrolle... aber auch nur soweit :-)

nachem ich appWeb installiert hatte, ist mir meine 500gig platte abgereucht, dies hing nicht mit mit der installation zusammen ist halt einfach passiert. Also bin ich eine neue kaufen gegangen ... angestöpselt und noch mal alles neu gemacht auch firmware neu geflasht, damit alles wieder jut ist. Ich habe einen USB-Stick und die HDD der Stick hängt an Port2 die Platte demnach an Port1... und nun zu dem was ich eigentlich sagen wollte.

Ich nutze die neue 6.10 Version und alles aktuellen von euch vorgeschlagenen pakete. rsdm nutze ich in version 1.8


alles läuft, das webinterface wird angezeigt, er zeigt mir meine rapidshare daten, mein traffic e.t.c. wenn ich aber nun einen download starte, testet er die links, zeigt mir alles an und sagt mir dann das der download gestartet ist. in der htop liste, wird wget angezeigt e.t.c. allerdings lädt er nichts runter... ich kann auch nichts am webinterface machen solange der wget läuft kille ich diesen geht alles wie normal... allerdings passiert nichts ... ich habe auch keine großen linux kenntnisse... kann mir jemand mal die fragen stellen dich ich dann beantworte um den /die fehler zu finden? ich habe selber keinen anhaltspunkt wo ich nach was suchen muss... achso vllt ein hinweis auf der hilfe seite wird mir angezeigt das ich direkt-downloads anzeigen soll... das habe ich aber schon lange ich nutze rapidshare seid 2 jahren als premium user... ist da eventuell der fehler?


als dankeschön, würde ich gerne euren header ändern sagt mir einfach in welche richtung es gehen soll ich nehme mich dann der grafik an ... zu irgendwas muss ich ja gut sein :-)

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

316

Sonntag, 13. Januar 2008, 17:47

Anbei der auszug aus meiner Hilfe seite...
Überprüfe die config.inc.php ...

Konfigurationsdatei "config.inc.php" ⇒ Datei wurde gefunden!
Überprüfe rapidshare.com - Einstellungen

Benutzername ⇒ korrekt!

Notice: Undefined offset: 0 in /opt/var/appWeb/web/rsdm/help.php on line 73
"Direkt-Downloads" ⇒ deaktiviert! Bitte in der Rapidshare-Premiumzone aktivieren!Notwendige Ordner überprüfen ...

RSDM - Webordner: "/opt/share/www/rsdm" ⇒ Ordner existiert ...
RSDM - Webordner: "/opt/share/www/rsdm" ⇒ Ordner hat Schreibrechte ...

Downloadordner: "/rapidshare" ⇒ Ordner existiert ...
Downloadordner: "/rapidshare" ⇒ Ordner hat Schreibrechte ...
Notwendige Programme überprüfen ...

wget: /opt/bin/wget: ⇒ Datei gefunden ...
nohup: /opt/bin/nohup ⇒ Datei gefunden ...
nice: /opt/bin/nice ⇒ Datei gefunden ...
unrar: /opt/bin/unrar: ⇒ Datei gefunden ...
vnstat: /opt/bin/vnstat: ⇒ Datei gefunden ...
nail: /opt/bin/nail: ⇒ Datei gefunden ...
df: /opt/bin/df: ⇒ Datei gefunden ...
python: /opt/bin/python: ⇒ Datei gefunden ...
rsdf_decode.py: /opt/share/www/rsdm/rsdf_decode.py: ⇒ Datei gefunden...
remove.pl: /opt/share/www/rsdm/remove.pl: ⇒ Datei gefunden und Dateirechte korrekt gesetzt...



und mal der Header wie ich finde einw enig hübscher, wenn ihr wollt mache ich etwas komlett eigenes...



kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

317

Sonntag, 13. Januar 2008, 18:13

Zitat von »koepie;29437«

hab das decoder script verbessert jetzt kann man auch rsdf datein verwenden die vorher mal ccf datein waren

Das kann man mit der aktuellen Version des Decoder-Scripts auch. :) Vermutlich hängt das aber damit zusammen, mit welchem Script man die ccf- in eine rsdf-Datei umgewandelt hat. ;) Ich werde deine Änderungen mal in die neue Version einbauen. Danke.

Zitat von »ronwaste;29441«

Anbei der auszug aus meiner Hilfe seite...
Überprüfe die config.inc.php ...

Konfigurationsdatei "config.inc.php" ⇒ Datei wurde gefunden!
Überprüfe rapidshare.com - Einstellungen

Benutzername ⇒ korrekt!

Notice: Undefined offset: 0 in /opt/var/appWeb/web/rsdm/help.php on line 73
"Direkt-Downloads" ⇒ deaktiviert! Bitte in der Rapidshare-Premiumzone aktivieren!

Die Fehlermeldung sollte nicht so aussehen. Testen wir mal folgendes. In der help.php bitte Zeile #85 (exec("rm ...") auskommentieren, d.h. einfach eine Raute (#) vor die Zeile setzen und anschliessend die Datei speichern. Jetzt die Seite neu laden. In deinem RSDM-Ordner sollte jetzt eine rs_premium_logs.txt vorhanden sein. Deren Inhalt mal nach dem Wort "directstart" durchsuchen.

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

318

Sonntag, 13. Januar 2008, 18:27

Habe ich gemacht die datei wird auch erstellt, allerdings ist in dieser kein directstart zu finden ich habe auch mal nur nach start gesucht aber auch da findet er nichts

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

319

Sonntag, 13. Januar 2008, 18:36

Doofe Frage: du hast einen rapidshare.de oder rapidshare.com - Account?

Öffne mal die rs_premium_logs.txt und schau ca. ab Zeile 59, ob dort deine E-Mail-Adresse, dein Login-Alias, etc. genannt werden.

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

320

Sonntag, 13. Januar 2008, 18:36

Ich habe einen .com account ab zeile 59 sehe ich ... user name , mailaddy e.t.c.

... ich habe nun ein paar mal die logs gelöscht un neu erstellt und nun hat er folgendes gefunden:

<tr><td>Direct-downloads:</td><td><input type="checkbox" name="directstart" checked></td></tr>

Social Bookmarks