Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

341

Sonntag, 13. Januar 2008, 21:06

du hast post die tatsache, das ich die sh datei selber ausführen muss, dann aber alles klappt lässt doch irgendwie darauf schließen, dass es ein rechte problem ist... in htop steht auch dass nobody wget ausführt... wie kann ich das ändern?

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

342

Sonntag, 13. Januar 2008, 21:15

Also das Problem mit der rsdf-Datei kann ich nicht bestätigen (siehe PM) und wget läuft bei mir auch als nobody. Probier mal einen anderen Download-Ordner und schau nach, ob der RSDM-Ordner und auch der logs-Ordner auf 777 gesetzt sind.

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

343

Sonntag, 13. Januar 2008, 21:20

rechte scheinen zu stimmen, und der download funkt ja, allerdings nur wenn ich die erstellte sh selbst ausführe... es ist zum verzweifeln

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

344

Sonntag, 13. Januar 2008, 21:22

Wie rufst du die sh-Datei denn auf? Exakt mit dem gleichen Befehl, wie er auch in der rsdm_start.php zu finden ist?

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

345

Sonntag, 13. Januar 2008, 21:28

ne ich gehe in den ordner wo die sh liegt und dann ./datei.sh

ich bin dabei als root eingeloggt

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

346

Sonntag, 13. Januar 2008, 21:30

Dann probier es mal so:

/opt/bin/nohup /DEIN_WEB_PATH/DATEINAME_DER_SH_DATEI.sh >/dev/null &

Die Pfade entsprechend anpassen.

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

347

Sonntag, 13. Januar 2008, 21:35

dabei kommt raus /opt/bin/nohup: ignoring input and redirecting stderr to stdout
und die datei taucht dann im webinterface als log auf und wird auch korrekt runtergeladen

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

348

Sonntag, 13. Januar 2008, 21:40

Hmm, sehr spannend dein Problem. Und wenn du den Download über den RSDM startest, wird auch keine log-Datei erzeugt?

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

349

Sonntag, 13. Januar 2008, 21:48

das einzige was er macht, ist dass er die sh erstellt... wenn ich dann über mein terminal diese sh ausführe, bekomme ich eine logdatei und die datei wird gezogen... wenn ich einen rs ling einfüge, wird dieser überprüft... dann steht da download wurde gestartet und dann werde ich zur indes weitergeleitet... aber kein download und nichts.

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

350

Sonntag, 13. Januar 2008, 21:53

Sorry, da muss ich wieder mein Posting von vor ca. 2 Stunden zitieren:

Zitat

Spontan fällt mir keine Lösung für dich ein, aber mal abwarten was die anderen Nutzer dazu sagen.

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

351

Sonntag, 13. Januar 2008, 21:59

... das ist doch eine scheiße... sowas trifft auch immer mich... gibt es keine log wo man sieht was gerade geschiet?

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

352

Sonntag, 13. Januar 2008, 22:06

nochmal zu dem rsdf problem.. er decodiert ja korrekt.. und dann macht er angeblich eine txt... die sehe ich aber nirgends, darum sucht er sich wahrscheinlich auch einen wolf....

Phantomias2006

Fortgeschrittener

  • »Phantomias2006« ist der Autor dieses Themas

Beiträge: 309

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

353

Sonntag, 13. Januar 2008, 22:18

Hi hast du das schon probiert???

Zitat

theT
Neuer Benutzer
Registriert seit: 30.12.2007
Beiträge: 9
Renommee-Modifikator: 1


@kingofcomedy:

Es scheint mir, als gäbe es noch ein Problem mit dem Decoden von RSDF, zumindest was den Dateinamen anbelangt.

Man nehme einfach einen beliebigen RSDF Container, benenne ihn auf "Test.Container.rsdf" um und mache einen Upload in RSDM 1.8.0. Das Ergebnis ist, dass zwar das Decoden sauber funktioniert (es wird ein "Test.Container.txt" erstellt), aber RSDM anschließend ein fopen auf die Datei "Test.txt" macht.

Das Problem ist hier vergraben (siehe "rsdm_main.php", Zeile 134-142):



PHP-Code:
$zaehler_anmelden = explode('.', $_FILES["inputrsdffile"]["name"]);
$fp = fopen ( $zaehler_anmelden[0].".txt", 'r' );
while (!
feof( $fp ))
{
$zahl = fgets ( $fp, 4096 );
$zahl++;
// echo $zahl."<br>";
}
fclose($fp);


Die explode Funktion zerlegt den Dateinamen bei jedem Punkt, beim fopen wird dann genau der Teil bis zum ersten Punkt verwendet. Das Öffnen der Datei geht natürlich schief und kurioserweise bleibt er dann in der Schleife hängen.

Lösung: Zeile 134-142 löschen, da der Code obsolet ist und nicht mehr verwendet wird. Das Lesen der Links aus der ".txt" Datei ist ab Zeile 150 implementiert.

theT

kingofcomedy

Fortgeschrittener

Beiträge: 490

Verwendetes NAS-Device: Zotac ZBOX SD-ID10 + Debian Lenny

Firmwareversion / your current Firmware: Debian

Wohnort: Bielefeld

  • Nachricht senden

354

Sonntag, 13. Januar 2008, 22:30

Stimmt, der Teil ist in Version 1.8.0 noch enthalten, aber die rsdf-Datei, die ich per PM bekommen habe, hatte eh einen "normalen" Dateinamen, d.h. ohne Leerzeichen, Punkte, etc.

Phantomias2006

Fortgeschrittener

  • »Phantomias2006« ist der Autor dieses Themas

Beiträge: 309

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

355

Sonntag, 13. Januar 2008, 22:34

hmm ok

welchen webserver hast du???
welche pakete hast du Installiert nach dem aufsetzen??

mfg

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

356

Sonntag, 13. Januar 2008, 22:35

danke das auch du mir nun hilfst :-) ich habe das mal gemacht und die einzige änderung, ist dass nun der fehler in den zeilen

Warning: feof(): supplied argument is not a valid stream resource in /opt/var/appWeb/web/rsdm/rsdm_main.php on line 144

Warning: fgets(): supplied argument is not a valid stream resource in /opt/var/appWeb/web/rsdm/rsdm_main.php on line 146


und in der main noch in 142

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

357

Sonntag, 13. Januar 2008, 22:36

ich habe alles nach deiner appWeb anleitung installiert... wie ist nochmal der befehl um installierte pakete anzeigen zu lassen

Phantomias2006

Fortgeschrittener

  • »Phantomias2006« ist der Autor dieses Themas

Beiträge: 309

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

358

Sonntag, 13. Januar 2008, 22:39

und ein

chmod -R 777 /opt/var/appWeb/web/rsdm
chmod 555
/opt/var/appWeb/web/rsdm/remove.pl

hast du auch schon gemacht ???

ronwaste

Anfänger

Beiträge: 54

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

359

Sonntag, 13. Januar 2008, 22:43

japs... was haltet ihr denn davon, wenn ich mal neu unslinge und wir mal zusammen neu installen? Übrigens brauche ich noch eine anregung für den header... sofern ihr einen neuen wollt

Phantomias2006

Fortgeschrittener

  • »Phantomias2006« ist der Autor dieses Themas

Beiträge: 309

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

360

Sonntag, 13. Januar 2008, 22:46

Zitat von »ronwaste;29501«

japs... was haltet ihr denn davon, wenn ich mal neu unslinge und wir mal zusammen neu installen? Übrigens brauche ich noch eine anregung für den header... sofern ihr einen neuen wollt


Zwecks header musst mit kingofkomedy reden ;)

hmm

hast du nach der anleitung geunslingt??

http://www.mindfactory.de/forum/modem-ne…lu2-thread.html



Warning: feof(): supplied argument is not a valid stream resource in /opt/var/appWeb/web/rsdm/rsdm_main.php on line 144

Warning: fgets(): supplied argument is not a valid stream resource in /opt/var/appWeb/web/rsdm/rsdm_main.php on line 146


und in der main noch in 142

die gehören soweit ich jetzt richtig gesehen habe zum decodieren der rsdf

er schreibt aus irgendeinen grund die txt nicht

mit was bearbeitest du die files???

Social Bookmarks