Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Phantomias2006

Fortgeschrittener

Beiträge: 309

Firmwareversion / your current Firmware: Unslung 6.10

  • Nachricht senden

201

Mittwoch, 11. April 2007, 21:42

Hi jack

ich hab damals auch meine nslu nach dieser anleitung gemacht leider hab ich dieses webinterface mit apache noch nicht zum laufen gebracht also würde ich empfehlen apache runter und appweb drauf

also mal apache runter

ipkg remove apache
dann installierst mal folgende packete

ipkg install appweb
ipkg install enhanced-ctorrent
ipkg install procps
ipkg install perl
ipkg install php-gd

so nun noch schnell appweb configurieren...

1.) Per Telnet mit root rechten auf die Slug einloggen und folgendes eintippen

ipkg install appweb //kannst du auslassen haben wir ja bereits schon

2.) So jetzt Konfigurieren wir noch schnell AppWeb

vi /opt/var/appWeb/appWeb.conf

So und hier ändern wir folgende Zeilen:

DocumentRoot "./web" ß DocumentRoot "/web" Hier ist der Pfad angegeben wo die
Homepage liegt

Tipp:
Am Besten ihr lasst den Pfad (den Punkt entfernen) und erstellt einen Benutzer Namens “web“ auf dem ihr per ftp zugreifen könnt


Listen 7777 ßÄndern auf “Listen 80“ gibt den Port eures Webservers an

DirectoryIndex index.html ßDirectoryIndex index.html index.htm index.php


3.) Und als guter letzt Starten wir den Webserver neu

/opt/etc/init.d/S81appweb



4.) Um von vornherein ein paar Fehler zu vermeiden geben wir den /web Verzeichnis gleich mal vollen
Schreib- und Lese- zugriff. Dies würde ich aber nach der Testphase ändern und nur die Nötigsten rechts vergeben. Lest euch bitte zu diesen Thema Internet Seiten durch speziell dann wenn ihr eure HP ins Netz stellt und nicht nur zuhause nutzen wollt.

chmod –R 777 /web


naja im grunde müsste es jetzt funken
aja vorher einen benutzer namens web anlegen mit dem du zugriff per ftp hast

mfg Phantomias

JackDaniel

Anfänger

Beiträge: 12

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

202

Donnerstag, 12. April 2007, 07:14

@Phantomias2006

danke für die geniale anleitung, hat auf anhieb gefunzt. denke mal das viele die auf diesen thread stossen dir seeehr dankbar sein werden. ;-)

salut
jackdaniel

sollie

Anfänger

Beiträge: 58

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

203

Donnerstag, 26. April 2007, 17:59

With the new enhanced-Ctorrent 1.3, my ECTC doesnt work anymore.
Sollie.

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

204

Freitag, 27. April 2007, 22:36

I'am using this:

Quellcode

1
2
3
# ipkg list enhanced-ctorrent
enhanced-ctorrent - dnh2.2-6 - Enhanced CTorrent is a revised version of CTorrent
#


for the NSLU this is (for now) the latest version....

Please post here an example of the new torrent-output .

Werner

sollie

Anfänger

Beiträge: 58

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

205

Samstag, 28. April 2007, 07:54

Quellcode

1
enhanced-ctorrent - dnh3-7 - Enhanced CTorrent is a revised version of CTorrent


Sollie.

Solo0815

Schüler

Beiträge: 58

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

206

Samstag, 28. April 2007, 11:10

Die Änderungen können hier nachgelesen werden:
http://www.rahul.net/dholmes/ctorrent/

Es hat sich was am Output geändert und man sollte die max. UL/DL-Rate einstellen, soweit ich das jetzt überblicken konnte.

Wie kommt man an die neue CTorrent-Version? Mich hat das selbstkompilieren von Paketen bis jetzt immer abgeschreckt. Wär schön, wenn jemand die neuen dateien zippen und hochladen könnte. Noch besser wäre es mit einer neuen Version des WebUI ;)
Danke schonmal im Voraus :cool:

sollie

Anfänger

Beiträge: 58

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

207

Samstag, 28. April 2007, 11:12


warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

208

Samstag, 28. April 2007, 12:37

I think I should use more often

Quellcode

1
ipkg update 


:o

209

Dienstag, 1. Mai 2007, 17:51

Wow what a great project!
I've tried Version8beta, and was a bit tricky for me to get it working, because I've a WL700.
The comment 'Make an symlink from the /bin/sh to /opt/bin/sh' does not work, cause I don't have rights in this directory. Anyway index.php is running.
But when I start the torrent i get the error: '/opt/bin/enhanced-ctorrent1: bad directory' Tough start_torrent.sh gets the variable $1 '/opt/bin/enhanced-ctorrent' which is right.

Perhaps sollie can you post your current running version of ectc?

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

210

Dienstag, 1. Mai 2007, 21:26

Problems with the newest version of enhanced-ctorrent (EC):
The problem is the EC expects an valid input device from the keyboard. As far as I know this is an nogo with background shell script.

Therefore I wrote an email to Dennis:

Zitat

> ... But the new feature "Console I/O Management " makes me sad. This is a nice option but
> If I try to start the enhanced ctorrent via a shell script I got input errors:
>[INDENT]> >Press 'h' or '?' for help (display/control client options).
> >Input error: Inappropriate ioctl for device
> >Input error: Permission denied
[/INDENT]>
> Is it possible to introduce a new switch to disable the "Console I/O Management"
His answer:

Zitat

Starting the program from a shell script makes no difference, but
trying to start it in the background and/or with input or output
redirected might. It would help to have more details about how you
are starting it (i.e. the command line used and the program starting
it--shell/cron/etc.) and your platform.

A daemon mode is planned, which would essentially do what you ask
(which isn't literally what you want, but daemonization sounds like it
is). I'll see if I can do anything to detect redirected or closed
input as well. Most people run ctorrent in the background using
screen. The problem isn't that there's a facility to manage the
console, but appears to be in that the new version actually checks for
input whereas the previous versions did not.
Lets wait for a new version ...

Werner

sollie

Anfänger

Beiträge: 58

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

211

Mittwoch, 2. Mai 2007, 22:56

i use 8beta.

Sollie.

sollie

Anfänger

Beiträge: 58

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

212

Mittwoch, 2. Mai 2007, 23:01

Nap,

Forget the symlink, just edit all .sh files and change the first lines:

Quellcode

1
#!/bin/sh


into

Quellcode

1
#!/opt/bin/sh


Thats all.

Sollie.

PS: its allso handy to edit the start_torrent.sh file and chage the line:

Quellcode

1
/opt/bin/chmod 666 -R $2


into

Quellcode

1
/opt/bin/chmod 777 -R $2


Like that, you are able to view the downloaded movies.

213

Donnerstag, 3. Mai 2007, 23:20

Thank you very much for the configuration, that helped me a lot to exclude many sources of errors.
Finally it turned out that procps installation conflicted with busybox-links, I installed everthing new and clean and now ectc is running!

nap

sollie

Anfänger

Beiträge: 58

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

214

Samstag, 5. Mai 2007, 09:45

Warti,

I like ectc very much, but everytime ectc is trying to go back to index.php it fails (config screen, after uploading torrent etc).

Do you know whats going on.

Thanks anyway.

Sollie.

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

215

Samstag, 5. Mai 2007, 20:09

Hi Solli,

did You use lighttpd?
If so, please check if the redirect server module is enabled in
/opt/etc/lighttpd/lighttpd.conf:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
...
server.modules              = (
#                               "mod_rewrite",
[B]                               "mod_redirect",[/B]
#                               "mod_alias",
                              "mod_access",
#                               "mod_cml",
#                               "mod_trigger_b4_dl",
                              "mod_auth",
#                               "mod_status",
#                               "mod_setenv",
                              "mod_fastcgi",
....
if so and it is still not working. Please switch on error log in /opt/etc/php.ini to see what happend:

Quellcode

1
error_reporting  =  E_ALL
please check the log file:
/opt/var/log/lighttpd/error.log


MfG
Werner

sollie

Anfänger

Beiträge: 58

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

216

Samstag, 5. Mai 2007, 21:22

Warti,

You have right. I didnt enable "mod_redirect", But after i did nothing changed.

I will bring you the log.

Sollie.

sollie

Anfänger

Beiträge: 58

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

217

Samstag, 5. Mai 2007, 21:26

Hmm, nothing in log:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
2007-04-30 07:55:38: (log.c.75) server started
2007-05-01 02:20:42: (http_auth.c.854) get_password failed
2007-05-01 02:20:43: (http_auth.c.854) get_password failed
2007-05-01 02:20:47: (http_auth.c.854) get_password failed
2007-05-01 02:20:57: (http_auth.c.854) get_password failed
2007-05-01 02:21:02: (http_auth.c.854) get_password failed
2007-05-02 18:10:14: (log.c.75) server started
2007-05-02 18:24:06: (log.c.75) server started
2007-05-02 18:26:51: (log.c.75) server started
2007-05-02 18:33:21: (log.c.75) server started
2007-05-02 20:56:32: (server.c.1149) NOTE: a request for /local_index.php timed out after writing 14600 bytes. We waited 360$
2007-05-02 21:28:36: (log.c.75) server started
2007-05-02 21:34:33: (log.c.75) server started
2007-05-02 22:09:19: (log.c.135) server stopped
2007-05-02 22:11:03: (log.c.75) server started
2007-05-02 22:15:44: (log.c.75) server started
2007-05-02 22:38:38: (log.c.135) server stopped
2007-05-02 22:40:26: (log.c.75) server started
2007-05-03 17:40:17: (log.c.135) server stopped
2007-05-03 17:42:25: (log.c.75) server started
2007-05-05 09:37:04: (log.c.135) server stopped
2007-05-05 09:38:54: (log.c.75) server started
2007-05-05 17:58:31: (log.c.75) server started
2007-05-05 21:08:12: (log.c.135) server stopped
2007-05-05 21:10:18: (log.c.75) server started


Sollie.

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

218

Sonntag, 6. Mai 2007, 08:45

:confused:
Are You using FF2 or IE ? Please test both.

But anyway - I will "add" an something like:
"If you are not redirected automatically - press <here>"

MfG
Werner

sollie

Anfänger

Beiträge: 58

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

219

Sonntag, 6. Mai 2007, 09:41

Hey, cool. With firefox it worked. So its an explorer issue. I use explorer 7.
Thanks man. When you release the changes i will test it with IE7.

Sollie.

sollie

Anfänger

Beiträge: 58

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

220

Sonntag, 6. Mai 2007, 09:51

And pls remove this from readme.txt:

Quellcode

1
2
Note for ASUS wl700g users:
* Make an symlink from the /bin/sh to /opt/bin/sh


Only the /opt dir is writable on a wl700gE (Kfurge custom firmware is needed for using optware).

Change it into this, or something:
Note for ASUS wl700g users:
Edit all .sh files and change the first lines:

Code:

#!/bin/sh

into
Code:

#!/opt/bin/sh


Its also handy to edit the start_torrent.sh file and change the line:

Code:

/opt/bin/chmod 666 -R $2

into
Code:

/opt/bin/chmod 777 -R $2


Like that, you are able to view the downloaded movies.

PS: Maybe its an idea to use "#!/opt/bin/sh" as default. It doesnt effect other users (as far as i know).

Zur Zeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Social Bookmarks