Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

261

03.06.2007, 20:29

... ohh :confused:

Hast Du eine NSLU2 oder ein ASUS?
Hast Du irgendwelche Änderungen in den Skripten (*.sh) vorgenommen?
Was sagt http://<nslu-ip-adresse>/chk_config.php? (bitte nochmal ausführen)


MfG
Werner

JackDaniel

Anfänger

Beiträge: 12

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

262

03.06.2007, 21:42

1. ich hab ne slug ;)
2. nein ich hab nur die neueste version drauf
3. mein ergebnis auf chk_config

Check the ECTC Configuration

File: "./torrent_config.php" found
Check configuration of "./torrent_config.php"

$absolute_path: "/share/hdd/data/filesharing/Download" found
Try to access the $absolute_path: "/share/hdd/data/filesharing/Download"
write access successful to $absolute_path: "/share/hdd/data/filesharing/Download"
$ctorrent_path: "/opt/bin/enhanced-ctorrent" found
$ctorrent_path: "/opt/bin/enhanced-ctorrent" executeable
Check the configuration of the environment

/bin/sh: Shell exists ...
/opt/bin/perl: Perl exists ...
/opt/bin/ps: ps command exists ...

danke für deine geduld

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

263

04.06.2007, 19:16

Zitat

... danke für deine geduld
Ich nehm es persönlich das das scheiß Ding nicht läuft ...:p

Ich glaub wir sollten mit PN weitermachen ;)
Schick mir mal das Ergebnis von

Quellcode

1
ipkg list_installed 
MfG

lewbacca

Anfänger

Beiträge: 20

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

264

05.06.2007, 21:19

bei mir lädt der sich beim aufruf der index.php tot.. hab sie noch nie gesehen.. irgendwelche vorschläge?


Zitat


Check the ECTC Configuration

File: "./torrent_config.php" found
Check configuration of "./torrent_config.php"

$absolute_path: "/opt/share/www/Temp/Torrent" found
Try to access the $absolute_path: "/opt/share/www/Temp/Torrent"
write access successful to $absolute_path: "/opt/share/www/Temp/Torrent"
$ctorrent_path: "/opt/bin/enhanced-ctorrent" found
$ctorrent_path: "/opt/bin/enhanced-ctorrent" executeable
Check the configuration of the environment

/bin/sh: Shell exists ...
/opt/bin/perl: Perl exists ...
/opt/bin/ps: ps command exists ...





//EDIT: Hups sorry.. hat sich erledigt. lighttpd lädt alles schneller ;)

wiggedy

Schüler

Beiträge: 47

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

265

06.06.2007, 23:26

HAllo, schöne Idee, aber wie wäre es mit der aktuellen Datei und einer kurzen Anleitung im ersten post! Das wäre traumhaft.

lewbacca

Anfänger

Beiträge: 20

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

266

07.06.2007, 11:43

hm kann es sein dass das ganze zieeeemlich langsam is?
ich hab upload auf 5 und prioriät auf +20..
ich lade damit ein linux torrent und die nslu2 hängt sich komplett auf.. bzw, lädt irgendwie, aber ich kann nichts anderes mehr machen. is das normal?

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

267

07.06.2007, 14:31

@lewbacca:
Das große Problem der NSLU2 ist der Speicher: 32MByte sind ziemlich schwindsüchtig.
Deshalb wichtig: Cachesize auf 0!!
Priority: fast egal, hab ich auf +5 (niedriger wie normal) gestellt.

Bei mir läuft es auch bei größeren DL (Knoppix mit 4Gybte) ohne Probleme.
Sogar bis zu 2-3 DL Parallel.

Was läuft den sonst noch auf der SLUG?

@wiggedy:
Ja - gute Idee

MFG
Werner

lewbacca

Anfänger

Beiträge: 20

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

268

07.06.2007, 17:59

Zitat von »warti;25089«


Was läuft den sonst noch auf der SLUG?



openvpn, squid und asterisk



es sieht bei mir irgendwie so aus, als würde er auf den usb stick mit dem filesystem zugreifen, während er lädt und irgendwie dort cachen... cachesize is aber 0.. daher kann ich mir das nich erklären.. naja jetz hab ich erstma n anderes problem.. die index.php is komplett weiß.. ka warum^^ mh ma schaun hehe


//EDIT:

aaach entschuldige.. es lag daran dass er die ganze zeit verzweifelt php-gd gesucht hatte, was nicht installiert war^^

wiggedy

Schüler

Beiträge: 47

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

269

07.06.2007, 19:05

ich habe jetzt so langsam alle seien durch ist die beta 9 die letzte version ?

lewbacca

Anfänger

Beiträge: 20

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

270

07.06.2007, 19:36

hm das wars doch nicht.. sobald ich n torrent lade, lädt der die hauptseite nicht mehr.. als ob der torrent meinen webserver abschießen würde.. sobald ich den torrentordner lösche, funktioniert alles wieder richtig.. keine ahnung woran das liegen mag...

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

271

07.06.2007, 20:49

@lewbacca:
Welche Version vom enhanced-ctorrent hast Du?
Die aktuelle NSLU 3er Version funktioniert leider (noch) nicht.

Ich hab in einem alten Post die "alte" Binary reingestellt.

@wiggedy
Ja ist die aktuellste - ich werde "bald" einen neuen Thread aufmachen
mit der aktuellsten Version - ich hoffe Marco hat nichts dagegen.

MfG
Werner

lewbacca

Anfänger

Beiträge: 20

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

272

07.06.2007, 21:02

achsooo daran wirds liegen.. hab einfach per ipkg installiert..

wiggedy

Schüler

Beiträge: 47

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

273

08.06.2007, 15:57

danke wäre nett

darbid

Anfänger

Beiträge: 2

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

274

11.06.2007, 23:10

Remember I am an idiot

With almost zero linux ability I am trying to do some work on my wl700ge.

I have got for example twonkymedia working so I am not that dumb.

I followed http://www.nslu2-info.de/showpost.php?p=24201&postcount=201

DocumentRoot "./web" DocumentRoot "/web"

So in effect I just took off the "."


Listen 7777 ß I changed this to "Listen 80"

DirectoryIndex index.html

and I added "index.htm index.php" to the above line

and where is this "WEB" that I have to change

chmod &#8211;R 777 /web


as well i changed a couple of things from solli regarding the .sh files.

when i type in

Quellcode

1
/opt/etc/init.d/S81appweb
i get

Quellcode

1
2
3
pidof: not found
#
#    default:1 main  Error: Security risk, Program /opt/sbin/appWeb is writable by others


I also know that this is a really dumb question but

1. where do I put the Ectc_bete9 files?
2. what do I use to start this?

Solo0815

Schüler

Beiträge: 58

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

275

12.06.2007, 16:22

try

Quellcode

1
/opt/etc/init.d/S81appweb

init.d not .de ;)
the document-root of the web-server is /var/www or /opt/var/www afair, but it can be somewhere else

darbid

Anfänger

Beiträge: 2

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

276

12.06.2007, 18:47

Thanks for replying. I made a typo and have fixed it. Of course i used ".d" and not ".de".

I found web in /opt/var/appWeb so i hope that is the right place.

But I still have the other problem. This belongs to a package right, where should it be or where is it normally. (I think these are the right questions)

Übrigens Ihr könnte auch Deutsch schreiben, aber da meine Mutter Sprache Englisch ist, wurde ich mich freuen wenn Ihr mir Englisch schreibt. Ihr könnt üben :eek:

Solo0815

Schüler

Beiträge: 58

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

277

13.06.2007, 23:19

N Abend!

Nachdem jetzt meine neue HD da ist, hab ich die NSLU2 mal wieder angeschmissen und die neue beta9 installiert. Die chk_config.php sagt, alles OK.

Ich habe das Problem, dass ich keinen graph angezeigt bekomme, php_gd hab ich installiert. Wo ist die php.ini in der ich die GD-lib aktivieren kann, wenn das noch nötig ist?

Außerdem werden die ganzen gestarteten torrents als "stopped" angezeigt. Auch oben in der Leiste steht bei Torrents running 0 of 3 obwohl 2 torrents definitiv gestartet sind. Kann man das irgendwie ändern? Wie kann ich ein debug-log erstellen?

Im Anhang habe ich noch ein Bildschirm-Foto. Der Teil mit den Torrent-Namen habe ich weggeschnitten, interressiert ja niemand ;)
Oben drüber steht noch "Torrents uploaded: 2", genau die 2, die laufen.

In den ipkg-Quellen müsste die neue 3.1 sein. Hab mich aber noch nicht getraut, die zu installieren :cool:

CU
Ralf

btw: ist das normal, dass man 5 appWeg-prozesse laufen hat, die jeweils 16,7% RAM verschlingen?
»Solo0815« hat folgendes Bild angehängt:
  • Bildschirmphoto2.png

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

278

15.06.2007, 20:13

Hallo,

Zitat

0 of 3 obwohl 2 torrents definitiv gestartet sind. Kann man das irgendwie ändern? Wie kann ich ein debug-log erstellen?
Ja so ein Debug log hab ich mir auch schon überlegt - gibt es noch nicht....

Laufen die torrents wirklich?? Mach mal "ps -ef | grep enhanced"
Kannst Du mir dann das Ergebnis von "ps -ef | grep enhanced" zuschicken (PN).
Hast Du "procps" installiert??
Check auch mal die "*.stat" Dateien - dort sind die Ausgaben vom enhanced-ctorrent gespeichert.

Zitat

In den ipkg-Quellen müsste die neue 3.1 sein. Hab mich aber noch nicht getraut, die zu installieren
Ja - hab ich bereits ausprobiert - einige Dinge haben sich geändert. Ich muß das PHP-Script anpassen. Vielleicht werde ich es dieses Wochenende umstellen.
MfG
Werner

Solo0815

Schüler

Beiträge: 58

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

279

18.06.2007, 19:50

@ Warti:
Die PM kannst du in die Tonne kloppen. Funzt alles wieder! (Nach 1 Tag Arbeit)

Endlich wird auch ein Graph angezeigt, aber erst als ich folgende Zeile geändert hab:
diagramm.php

Quellcode

1
2
    //Tell the browser what kind of file is come in 
    header("Content-Type: image/jpeg"); 
in

Quellcode

1
2
    //Tell the browser what kind of file is come in 
    header("Content-Type: image/png"); 
Vielleicht gehts ja bei anderen mit der ursprünglichen einstellung, bei mir gings nicht. Mit PNG gehts :)

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

280

18.06.2007, 22:14

.... is natürlich ein BUG!!!

Quellcode

1
2
3
4
5
//Tell the browser what kind of file is come in 
header ("Content-Type: image/[B]jpeg[/B]"); 

//Output the newly created image in [B]jpeg [/B]format 
Image[B]Png[/B]($image);
:rolleyes: Richtig(er) wäre wohl:

Quellcode

1
2
3
4
5
//Tell the browser what kind of file is come in 
header("Content-Type: image/[B]png[/B]"); 

//Output the newly created image in [B]png [/B]format 
Image[B]Png[/B]($image);
MfG
Werner

Social Bookmarks