Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

61

Freitag, 31. März 2006, 13:24

Hallo,

ich habe ein paar fragen an die community.
Ich benutze Neutrino auf einer dreambox DM500 und
"recorder" auf der NSLU2.
Das Aufzeichnen von ARD und ZDF sind nicht schnell
genug (Ruckler etc.). Leider ist mir nicht klar wo das Nadeloehr ist.
Bringt das tunen auf 266Hz der NSLU2 was ?
Ist udrec schneller als dboxgrab ?
Gibt es udrec fuer UNSLUNG5.5 ?
Crossover-Kabel besser als switch ?
Beeinflusst das Schreiben ins log-File die Geschwindigkeit des recorders ?

Gruss Wixon

62

Dienstag, 4. April 2006, 02:02

Ich benutze die selbe Hardware-Kombi, wie Du vielleicht schon gelesen hast. Hmmm, Aussetzer habe ich nicht, es sei denn, AC3 wird als Tonspur aufgenommen - dann kann es bei manchen Sendungen vorkommen.

Ich denke, es liegt an Deinen Neutrino-Einstellungen. Bei den Aufnahme-Einstellungen gibt es ein "Direct Recording"-Submenü. Das wird zwar bei der Auswahl "Server" deaktiviert, die darin enthaltenen Einstellungen sind jedoch TROTZDEM relevant. Also z.B. mal bei den Tonspuren nicht alle aufzeichen lassen - das ist sonst eine zu hohe Datenrate.

Leider wird bei mir bei mehreren Tonspuren des Senders immer die mit der höchsten Audio-PID aufgezeichnet. Ich bin wegen dieses Problems mit den Entwicklern in Kontakt.

Das 266MHz-Tuning bringt für die Übertragungsleistung der NSLU2 nichts.

63

Dienstag, 4. April 2006, 22:49

Es wäre schön, wenn man zum Ansteuern von "recorder" auch NGrab verwenden könnte. Damit wäre man nicht mehr nur auf "Neutrino" als Image auf der Dream angewiesen.

Ich wäre wirklich sehr dankbar, wenn jemand sagen könnte, welche Modifikationen dafür nötig sind. Das Thema beschäftigt mich nämlich schon recht lange.

Spooky

CO-Admin

  • »Spooky« ist der Autor dieses Themas

Beiträge: 355

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

64

Mittwoch, 5. April 2006, 19:06

@Da_Flex

Wie schon mal geschrieben, NGrab gibt es für Linux nicht. Was es gibt, ist ggrab für Linux - wird anscheinend nicht mehr gepflegt und unterstützt kein TS sondern PES Modus. Da recorder und NGrab auf dem selben Standardport 4000 lauschen, wäre erstmal zu klären was bei Dir für eine Fehlermeldung auftaucht. Ich weiß nämlich nicht, was die Dreambox in diesem Zusammenhang ausspuckt: TS oder PES? Es kann durchaus sein, da recorder recht flexibel ist, dass "nur" die eigentliche Grab Engine zu ersetzen wäre. Wir bzw. Du solltest das erstmal eingrenzen, wonach es Enigma bei der Aufnahme mit der Dreambox dünkt. Wenn genauere Information vorliegen, kann man dann auch bei gmo18t im Tuxbox Forum mal höflich nachfragen. Falls es am PES liegen sollte, wird es allerdings schwer werden ihn zu überzeugen, das in seine Grab Engine zu integrieren.

ggrab scheint ja mit der Dreambox zu funktionieren. Und wenn ich mir das offizielle Forum von Dream Multimedia durchlese, existiert es wohl auch als binary für das NSLU2. Da es sich aber , so wie es dort steht, in einem ungern genannten Forum befindet - sind wir jetzt auch nicht wirklich weiter. Heute habe ich ggrab auf der NSLU2 mal selbst kompiliert, es funktioniert aber nicht richtig. Wenn es also jemand wirklich auf dem NSLU2 zum Laufen gebracht hat, wäre der angepasste Sourcecode interessant. Es kann auch gut sein, dass es nicht für uNSLUng sondern für OpenSlug o. DebianSlug existiert, dann sieht die Sache auch schon wieder anders aus.

Spooky

65

Donnerstag, 6. April 2006, 03:47

@Spooky:
Danke für die Antwort! Damit kann ich erstmal weiter arbeiten. Ich werde die Erkenntnisse dann hier posten. :)

66

Donnerstag, 6. April 2006, 22:50

In den Slug Success Stories auf nslu2-linux.org ist ein User zu finden, dem es offenbar gelungen ist, ggrab auf dem Slug zum Laufen zu bringen.

jimjack

Anfänger

Beiträge: 2

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

67

Dienstag, 25. April 2006, 07:52

Streamingserver "recorder" und NFS-Server

Ich habe mal eine Frage an die Experten.
Ich verwende den NSLU2 mit der Firmware 5.5, dem V3-NFS-Server und zwei dboxen (1xSagem- und 1xNokia-Kabel) zum streamen. Die Nokia-Box habe ich erst seit letzter Woche. Vorher lief die Sagem-Box im Zusammenspiel mit recorder auf dem NSLU2 super. Mit der Nokia-Box habe ich nun zusätzlich per NFS aufgenommen.
Dabei habe ich festgestellt, wenn eine Box per recorder streamt die Aufnahmen der zweiten Box per direktem NFS-Streaming nicht auf der Platte landen.
Deaktiviert eventuell der recorder einen vorhandenen NFS-Server? Die obligatorische XML-Datei mit der Aufnahme-Info wird noch angelegt, aber die TS-Datei nicht mehr. Beide Aufnahmen direkt per NFS-Server klappen problemlos.
Ist so ein Problem bekannt?
Steffen

Spooky

CO-Admin

  • »Spooky« ist der Autor dieses Themas

Beiträge: 355

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

68

Dienstag, 25. April 2006, 08:39

@jimjack,

den NFS Server rührt "recorder" nicht an. "Aus der Kalten" kann ich mir nur vorstellen, dass es Performance Probleme auf der NSLU2 unter diesen Bedingungen gab. Auf welche Geschwindigkeit war das Netzwerkinterface eingestellt - 10Mbit o. 100MBit ? Ein Problem mit "lock" dürfte nicht auftreten, da die TS-Dateinamen unterschiedlich sein sollten. "recorder" nimmt ja selbständig Kontakt zur dbox auf. Was hast Du in der recorder.conf angegeben - die IP welcher der beiden dboxen? Ein Betrieb von beiden Boxen mit "recorder" sollte aber gleichzeitig möglich sein, wenn Du mehrere Instanzen von recorder mit separater recorder.conf startest. Die Kombination NFS+recorder habe ich selbst noch nicht probiert, evetuell bist Du der Erste o. Einzige, der das so einsetzt. Um mehr "recorder"-Anwender zu erreichen und an der richtigen Stelle zu posten, solltest Du diese spezielle Szenariofrage, lieber im Tuxbox-Forum nochmal stellen. Dort schaut gmo18t auch öfters vorbei als hier.

Spooky
Unmögliches wird sofort erledigt, Wunder dauern etwas länger.

gmo18t

Anfänger

Beiträge: 4

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

69

Dienstag, 25. April 2006, 09:06

Zitat von »jimjack«


Deaktiviert eventuell der recorder einen vorhandenen NFS-Server?
recorder hat keinerlei Einfluß auf andere Services oder Programme des Hosts. Natürlich wird ein bestimmte Menge an Systemresourcen (CPU, Speicher, Disk-I/O, ...) verbraucht. Inwieweit sich dies nachteilig auf das 'directrecording' auswirkt, kann ich aber nicht sagen.

- GMo -

70

Dienstag, 25. April 2006, 09:16

Hallo !

ich hab vor etwas längerer zeit mit recorder etwas herumexperimentiert !

mit 2 Dboxen gleichzeitig mit recorder aufnehmen war nie ein Problem ! auch während eine per recorder und die andere direkt aufnahm gabs keine probleme!

eventuell hilft die auswertung bei Problemen mittels log !


wie gesagt ist schon ewig her,das einzige was mich gestört hat, war das recorder keine grösseren files als 2 GB erstellt hat und das nervig war wenn man zb 8 GB in einem rutsch aufnimmt und diese files erst wieder zu einem zusammenkopieren muss.

lg Tpol

jimjack

Anfänger

Beiträge: 2

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

71

Dienstag, 25. April 2006, 09:38

Hallo,
danke für die vielen Antworten. Das ist hier ein super Forum mit promten Antworten!

Ich hatte in letzter Zeit wenig Zeit zum probieren. Daher kann ich i.A. keine Logs vorweisen.
Das Netzwerkinterface der NSLU2 hatte ich auf 100Mbit HD eingestellt. Die zwei Boxen und der NSLU2 sind per 10/100er Switch von LevelOne verbunden.

Mit beiden Boxen per recorder streamen habe ich noch nicht probiert. Die eine Box nehme ich fast nur zum Radio streamen und stelle dann dort auf Direkt-Aufnahme ein, weil die Box bei Server-Aufnahme (recorder) nicht mehr in den Standby geht (wenn sie von dort gestartet ist).

In der recorder.conf steht i.A. nur die IP der ersten Box und nur mit der habe ich per recorder aufgenommen. Die zweite Box steht dort gar nicht drin. Dass recorder keine Services disabled habe ich mir schon gedacht.
Es kann wohl dann wirklich nur noch zu Performanceproblemen kommen.

Probleme mit den Dateinamen sollte es nicht geben, es sind ja unterscheidliche Sendungen von unterscheidlichen Sendern mit unterscheidlichen Namen - toller Satz ;-).

Nun denn ran an die tests...

72

Dienstag, 25. April 2006, 09:56

wenn du recorder für beide boxen verwenden möchtest lege dazu eine 2 recorder.conf auf der Slug an un ändere zur sicherheit auch noch die ports.

zb.

Zitat


ServerPort = 4001
ServerPort = 4002


lg tpol

73

Dienstag, 30. Mai 2006, 15:13

Hallo,
ich bin neu hier und muss sagen, das ist echt ein klasse Forum.
Das Installieren von recorder war wirklich einfach, dank der guten Tipps die ich hier lesen konnte. Meine dbox hängt über eine Bridge am wlan und die Nslu2 direkt an meiner Fritzbox 7050. Bis jetzt hatte ich keinerlei Abbrüche bei der Aufnahme, auch nicht beim ZDF.
So, aber jetzt zu meiner eigentlichen Frage! Gibt es in der recorder.cfg eine Möglichkeit den user u. das passwd für Http auf der dbox mitzugeben? Wenn das Webinterface der dbox Passwortgeschützt ist, dann hat man halt ein Problem.

Güße
Dados

74

Donnerstag, 31. August 2006, 07:41

Verschlüsselte Sender Aufnehmen

Hallo

Habe recorder und streamer installiert und hat alles auf Anhieb geklappt (super HowTow) .
Bei Aufnahmen von ORF (verschlüsselt) nimmt der recorder nur ein schwarzes Bild auf. Playback , also das Fernsehbild wird dunkel sobald ich aufneme.
Kennt jemand das Problem oder sogar eine Lösung??

Spooky

CO-Admin

  • »Spooky« ist der Autor dieses Themas

Beiträge: 355

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

75

Donnerstag, 31. August 2006, 09:38

@mehem09

Wenn Du eine Box mit AVIA600 Dein Eigen nennst, kann es an der AC3 Spur bei ORF liegen. Welche µcodes hast Du denn aufgespielt?

Spooky
Unmögliches wird sofort erledigt, Wunder dauern etwas länger.

76

Donnerstag, 31. August 2006, 15:50

UCode´s

Zitat von »Spooky;18374«

@mehem09

Wenn Du eine Box mit AVIA600 Dein Eigen nennst, kann es an der AC3 Spur bei ORF liegen. Welche µcodes hast Du denn aufgespielt?

Spooky


Also das spuckt die Box unter Service Ucode´s aus

Avia 500 :avia500v110
Avia 600 :avia600vb022
UCODE :ucode_001A
Cam Alpha :cam_1_02_105E

Spooky

CO-Admin

  • »Spooky« ist der Autor dieses Themas

Beiträge: 355

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

77

Freitag, 1. September 2006, 19:16

@mehem09,

schau Dir diesen Link mal näher an: dbox2 Wiki

besonders das hier:

Zitat


avia600vb022 mit aktiviertem SPTS

Es ist bekannt, dass Probleme mit Bild/Ton im laufenden Betrieb seltener auftreten. Der AC3-Ton kann im Movieplayer nicht genutzt werden. Beim Direktstreaming wird der AC3-Ton mit aufgenommen. Ein Umschalten des Tonkanals auf AC3 führt zu einem schwarzen Bildschirm.


Hast Du in den Audio Einstellungen "Dolby Digital Default" eventuell auf "EIN" stehen oder per Hand während der Aufnahme auf AC3 umgestellt?

Spooky

PS: Wahrscheinlich hilft es, wenn Du mal nach neueren µcodes vb028 googelst.
Unmögliches wird sofort erledigt, Wunder dauern etwas länger.

78

Samstag, 2. September 2006, 09:44

bei Aufnahme bleibt Bild Dunkel

Hallo Spooky

Habe avia600vb028 aufgespielt,aber keine Änderung.
Spts wird beim Box-start nicht geladen.
Aufnahme "In SPTS-Mode aufnehmen......ein"

Zur Information :bei zdf und ard mit Dolby Digital bleiben meine Lautsprecher stumm. Bei ORF und Premiere funktioniert Dolby Digital einwandfrei.

In den Audio Einstellungen ist Dolby generell ausgeschaltet und wird von mir nur bei Bedarf über die grüne Taste eingeschaltet.

vielleicht hast du mit diesen Infos einen Geistesblitz:rolleyes:

Sandmann

Schüler

Beiträge: 59

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

79

Samstag, 2. September 2006, 10:07

Schagt mich wenns nicht stimmt, aber dächte mal gelesen zu haben das der 001a kein Dolby macht oder nur keins ausgibt? Hast Du mal einen andere probiert?

Sandmann

80

Samstag, 2. September 2006, 10:12

habe ucode.bin (b107) aus meiner original soft eingespielt.

Kann zwar jetzt auch auf ard und zdf ac3 hören ,dafür bleibt orf usw. dunkel.

bin wieder am anfang

Social Bookmarks