Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Spooky

CO-Admin

  • »Spooky« ist der Autor dieses Themas

Beiträge: 355

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

81

Sonntag, 3. Juli 2005, 17:51

@Wolflay

Ich benutze das Script von Essu und lasse auch nur mit UDP+async testen, da das normalerweise die schnellste Möglichkeit ergibt. Vorhin habe ich nochmals einen Gegentest gemacht und bei mir verhält es sich umgekehrt zu Deinen Ergebnissen.

Variante a.)
Schreibrate 8,2MBit - Leserate 8,3MBit

Variante b.)
Schreibrate 7,6MBit - Leserate 8,3Mbit

Wenn ich mir so anschaue , dass Du auch vor "mii-diag" massive Probleme hattest mit der Leserate, vermute ich dass die dbox mit Deinem Switch nicht so recht klar kommt. Zumindest scheint es bir Dir Ärger zu geben, sobald der Switch zwischen einem 100MBit Clienten (NSLU2) und einem 10MBit Clienten dbox vermitteln soll. Damit will ich nicht sagen , dass Dein Switch Mist ist , aber Du bist momentan der einzige hier, bei dem sich die Leserate gar so schlecht verhält. Wie sieht denn Deine /etc/exports aus? Hast Du dort auf sync oder async eingestellt?

Spooky

82

Donnerstag, 14. Juli 2005, 08:34

mii-diag

Morgen,

ich hatte gestern probiert, dass mii-diag einzuspielen. Nachdem ich es kopiert habe, kam die Fehlermeldung disk size exeedet oder so ähnlich. Seidem komm ich nicht mehr auf den nslu2.

Was habe ich falsch gemacht?

Viele Grüsse
db

Spooky

CO-Admin

  • »Spooky« ist der Autor dieses Themas

Beiträge: 355

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

83

Donnerstag, 14. Juli 2005, 14:40

@dabegga

Das sieht drastisch danach aus, dass Deine Festplatte voll ist !

Spooky

84

Donnerstag, 14. Juli 2005, 15:47

Nee, ich hab den nslu2 ja gestern erst installiert(Platte formatiert).

Viele Grüsse
db

Spooky

CO-Admin

  • »Spooky« ist der Autor dieses Themas

Beiträge: 355

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

85

Donnerstag, 14. Juli 2005, 16:01

@dabegga

"formatiert" ->

An einem PC oder über die Funktion des NSLU2? Ersteres ist zu Empfehlen, da kannst Du auch gleich mal Prüfen ob die Platte überhaupt(noch) intakt ist. "unsling" hattest Du nach dem Formatieren Deiner Platte durchgeführt,oder ? Nicht dass Du den Speicher des NSLU2 vollgeschrieben hast.

Fährt das NSLU2 denn noch ohne Festplatte hoch ?

Spooky

86

Donnerstag, 14. Juli 2005, 16:38

Sowohl als auch. Die Platte läuft schon. Ich hatte auch schon super gestreamt mit meiner dbox. Nur wollt ich eben das die lesegeschwindigkeit höher geht.

Naja ich werd es heut abend nochmal probieren.

Ich hab die datei über meine dbox in die nslu2 kopiert (sfu auf meinem rechner) dann mit cp die datei nach /opt/sbin kopiert und rechte vergeben.

edit
Hab jetzt nochmal alles neu gemacht. Wenn ich die Rechte vergebe für das script udn dann reboot eingebe kommt der Spruch. Aber es funktioniert.

Vieel grüsse
db

87

Mittwoch, 5. Oktober 2005, 12:28

Ich habe beim Googln auf folgendes Link gestoßen:
http://slugbug.nslu2-linux.org/bug.php?o…27092d04d1bac3a

Bezüglich Unterstützung rsize/wsize 32768 steht da Folgendes:

Zitat

Added to Unslung 4.9-alpha, will be standard in 4.x-beta release.
:confused:

Vielleicht kann jemand was dazu sagen?

Alioska

88

Mittwoch, 5. Oktober 2005, 12:49

@alioska

hallo !

ja das stimmt aber was willst du hören bzw verstehe ich nicht ganz deine Frage oder auf was du hinaus möchtest !!! :confused:


lg Tpol

89

Mittwoch, 5. Oktober 2005, 13:41

Wenn das so ist, dann müsste r/wsize 32768 auch von "uNSLUng-5.5 beta" unterstützt werden oder ? Ohne weiteres geht es bei mir aber nicht. :confused:

Muss ich dafür einen Startscript mit "mii-diag" erstellen?


Alioska

90

Mittwoch, 5. Oktober 2005, 17:07

mach mal bitte genaue angaben über die boxen Dbox, dreambox,triax usw die du verwendest und neutrino oder Enigma über was mountest du verzeichnisse cifs/nfs/ftp...

bzw lese das 1 posting mit der Zwangsbremse hier durch !

mii-diag wird nur verwendet damit deine Netzwerkkarte von der NSLU2 entweder auf 10baseT-FD oder 100baseTx-HD läuft !
je nach art der anwendung bzw box !!!

lg Tpol !

Ps.Nur ein beispiel:
Hatte zuvor mehrere Dboxen Avia 600 Neutrino und hab über nfs problemlos aufgenommen bzw abgespielt !
mii-diag lief mit dieser konfig 100baseTx-HD l auf der Slug und alles war supi wohlgemerkt 10 MBIT !!!!


Nun hab ich eine kleine dreambox 5620-s und ich kan tun und machen was ich will ein vernünftiges streamen mit halwegs akzeptablen Ergebnissen ist nicht in sicht !! 100 Mbit
scheinbar gibt es aber grosse schwirigkeiten mit den Netzwerktreibern der Dream und das seit anfang an (2Jahre)

lg Tpol

Newbie_3_16

Anfänger

Beiträge: 5

Firmwareversion / your current Firmware: Unslung 2.12

  • Nachricht senden

91

Samstag, 22. Oktober 2005, 08:48

Hallo

Hallo an Alle,

erstmal Glückwunsch an die Admins und die ganzen Poster > Tolles Board (Zu nem Richtig klasse Thema) :D :D

Hab ganz viele kleine Probleme. Ich hatte bevor ich auf dieses Board gestoßen bin massive Probleme bei ORF Streamen, da kam immer ne Fehler Nachricht das nicht genug Zeit gewesen wäre oder so. Jetzt wo ich weiß es ist möglich mit über 8 Mbit zu Streamen und zu Lesen, ich aber gar kein plasssen Plan hab wie ich das Realisieren kann, wollt ich nach nem Komplett TUT fragen. Wenn jemand ne Idee hat wo ich eins finde (Hab auch fleißig gesucht aber nix gefunden was meinen Wissenstand gerecht wäre) oder mir anderweitig Helfen kann wäre ich euch Dankbar.

Als kleine Grundinformation: Ich hab Mittels Redboot das Image von Spooky (die links aus dem erstsen Post) geflasht und hab ne 200GB Samsung HDD an nem Trust USB2.0 Adabter. Das ging auch ganz gut > MP3 und Bilder aber bei Filmen gabs immer schon Problemchen mit meine Nokia Dbox2. Das alles ist an einen guenstig switch Angeschlossen.

Was muß ich deinstallieren auf der NSLU2 und was Installieren, was muß ich Einstellen bei Dbox und beim NSLU2.

Bitte Helft mir, Verzweifel sonst noch :eek: :confused:

Danke für eure Anteilnahme.

CU

Spooky

CO-Admin

  • »Spooky« ist der Autor dieses Themas

Beiträge: 355

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

92

Sonntag, 23. Oktober 2005, 22:19

@Newbie_3_16

Poste mal Deine genauen Einstellungen welche Du beim Mounten von der dbox aus verwendest ! Ganz wichtig sind die Werte für rsize u. wsize. Sofern Du nicht das "mii-diag" Tool verwendest, solltest Du zum Mounten mal "rsize=4096,wsize=32768" ausprobieren o. hast Du das schon versucht? Eine Liste der derzeit bei Dir laufenden Prozesse auf dem NSLU2 kannst Du per Telnet mit "ps -ax" aufrufen - bitte hier posten.

Spooky

roadrunner

Anfänger

Beiträge: 23

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

93

Sonntag, 23. Oktober 2005, 23:01

Hab mal eine Frage bezüglich Dreambox.

Welche Werte von r/wsize sind in kombination Dreambox 7020 und NSLU2 zu empfehlen? Hab immer mit 8192 r/wsize gemountet, und hatte bei einigen Filmen in MPEG Format ein ruckeln verspürt.
Was kann ich da eventuell optimieren?


Gruß
roadrunner

Newbie_3_16

Anfänger

Beiträge: 5

Firmwareversion / your current Firmware: Unslung 2.12

  • Nachricht senden

94

Montag, 24. Oktober 2005, 01:08

Dankefür die Antwort ! Wenn ich ps -ax ausführ kommt folgendes

# ps -ax
PID TTY Uid Size State Command
1 root 1212 S /bin/init
2 root 0 S [keventd]
3 root 0 S [ksoftirqd_CPU0]
4 root 0 S [kswapd]
5 root 0 S [bdflush]
6 root 0 S [kupdated]
7 root 0 S [mtdblockd]
8 root 0 S [khubd]
35 root 0 S [usb-storage-1]
36 root 0 S [scsi_eh_1]
76 root 0 S [jffs2_gcd_mtd4]
91 root 0 D [ixp425_csr]
93 root 0 S [ixp425 ixp1]
95 ttyS0 root 1916 S /bin/sh
218 root 0 S [kjournald]
224 root 1932 S
224 root 1932 S
232 root 0 S [kjournald]
285 root 9888 S upnpd &>/dev/null
296 root 9888 S upnpd &>/dev/null
297 root 9888 S upnpd &>/dev/null
300 root 9888 S upnpd &>/dev/null
301 root 9888 S upnpd &>/dev/null
302 root 9888 S upnpd &>/dev/null
419 root 2136 S /usr/sbin/thttpd -C /etc/thttpd.conf
449 root 3912 S /usr/sbin/smbd -D
451 root 3120 S /usr/sbin/nmbd -D
454 root 1240 S /usr/sbin/download
486 root 1932 S /usr/sbin/QuickSet
493 root 1880 S /usr/sbin/USB_Detect
496 root 1876 S /usr/sbin/USB_Detect
512 root 1216 S /usr/sbin/crond
526 root 1908 S /usr/sbin/CheckResetButton
528 root 1196 S /usr/sbin/CheckPowerButton
530 root 1196 S /usr/sbin/do_umount
604 root 2136 S /usr/sbin/thttpd -C /etc/thttpd.conf
624 root 1276 S /bin/inetd
625 root 1256 S /usr/sbin/telnetd
626 ttyp0 root 1916 S -sh
627 ttyp0 root 1988 R ps -ax

Die Einstellungen der Dbox sind.
Typ: NFS
Server IP 192.168.0.10
Verzeichniss /share/hdd/data/dbox
lok. Verz. /mnt
Bei str Mo. Ja
Mount OPt. rw,soft,udp
nolock,rsize=8192,wsize=8192
BeName admin
passw 0000

Danke für die Hilfe

Newbie_3_16

Anfänger

Beiträge: 5

Firmwareversion / your current Firmware: Unslung 2.12

  • Nachricht senden

95

Montag, 24. Oktober 2005, 02:07

Hab rausgefunden das gar kein NFS Server am laufen war, hab das jetzt mit portmap und nfs-utils nachgeholt. Aber beim Schreiben auf ORF kommt immer wieder konnte nicht schnell genug geschrieben werden? Wie installiere ich dieses mii-diag tool ums doch zum Luafen zu bekommen. ?? :confused: :confused: :confused:

Newbie_3_16

Anfänger

Beiträge: 5

Firmwareversion / your current Firmware: Unslung 2.12

  • Nachricht senden

96

Montag, 24. Oktober 2005, 10:49

Hallo, ich hab die ganze Nacht gesessen und einen kleinen Erfolg gehabt und zwar ich kann jetzt ORF und ZDF Streamen. Aber das wars leider noch nicht ganz, jetzt kann ich nx mehr abspielen. Meine aktuelle ps -ax sieht so aus

# ps -ax
PID TTY Uid Size State Command
1 root 1212 S /bin/init
2 root 0 S [keventd]
3 root 0 S [ksoftirqd_CPU0]
4 root 0 S [kswapd]
5 root 0 S [bdflush]
6 root 0 S [kupdated]
7 root 0 S [mtdblockd]
8 root 0 S [khubd]
35 root 0 S [usb-storage-1]
36 root 0 S [scsi_eh_1]
76 root 0 S [jffs2_gcd_mtd4]
91 root 0 D [ixp425_csr]
93 root 0 S [ixp425 ixp1]
95 ttyS0 root 1916 S /bin/sh
218 root 1932 S /sbin/syslogd -n
219 root 0
224 root 1924 S /sbin/klogd -n
232 root 0 S [kjournald]
284 root 9884 S upnpd &>/dev/null
296 root 9884 S upnpd &>/dev/null
297 root 9884 S upnpd &>/dev/null
300 root 9884 S upnpd &>/dev/null
301 root 9884 S upnpd &>/dev/null
304 root 9884 S upnpd &>/dev/null
419 root 2120 S /usr/sbin/thttpd -C /etc/thttpd.conf
449 root 3912 S /usr/sbin/smbd -D
451 root 3120 S /usr/sbin/nmbd -D
454 root 1240 S /usr/sbin/download
489 root 1932 S /usr/sbin/QuickSet
493 root 1880 S /usr/sbin/USB_Detect
494 root 1876 S /usr/sbin/USB_Detect
512 root 1216 S /usr/sbin/crond
526 root 1908 S /usr/sbin/CheckResetButton
528 root 1196 S /usr/sbin/CheckPowerButton
530 root 1196 S /usr/sbin/do_umount
580 bin 1228 S /opt/sbin/portmap
596 root 1584 S /opt/sbin/statd
599 root 0 S [nfsd]
600 root 0 S [lockd]
601 root 0 S [rpciod]
603 root 1648 S /opt/sbin/mountd
621 root 2120 S /usr/sbin/thttpd -C /etc/thttpd.conf
641 root 1276 S /bin/inetd
643 root 1256 R /usr/sbin/telnetd
644 ttyp0 root 1916 S -sh
645 ttyp0 root 1988 R ps -ax

ich glaub auch ich habe das mit dem mii-diag hinbekommen, sagt mal bitte ob das Okay ist. Da ich nicht wusste wie ich die datei in opt/sbin bekomme hab ichs einfach in den Ordner Dbox kopiert und /opt/etc/init.d/s96dboxfix so configuriert

/share/hdd/data/dbox/mii-diag ixp0 -p 1 -F 100baseT-FD
/share/hdd/data/dbox/mii-diag ixp0 -p 1 -A 100baseT-FD

Also nach Methode a.

mein /opt/exports sieht so aus

/share/hdd/data/dbox 192.168.0.6(rw,async,no_root_squash,anongid=501,anonuid=2000)

Muss ich eigentlich die /etc/exports auch anlegen die sehen bei mir so aus

/share/hdd/data 192.168.0.0/255.255.0.0(rw,sync,no_root_squash)
/share/hdd/conf 192.168.0.0/255.255.0.0(ro,sync,no_root_squash)
/share/flash/data 192.168.0.0/255.255.0.0(rw,sync,no_root_squash)
/share/flash/conf 192.168.0.0/255.255.0.0(ro,sync,no_root_squash)

Meine Dbox Einstellung sehen jetzt so aus

Typ: NFS
Server IP 192.168.0.10
Verzeichniss /share/hdd/data/dbox
lok. Verz. /mnt
Bei str Mo. Ja
Mount OPt. rw,soft,udp
nolock,rsize=4096,wsize=31768 (hab aber auch mit 32768 und 32768)
BeName admin
passw 0000

Und wenn ich jetzt abspiele dauert das 1-2 Minuten lang das überhaupt was kommt und dann hörts nach 3-5 seunden einfach auf.

Auch komisch ist das ich sehr oft dateien dabei habe die nicht ts endung haben sondern 0 als erweiterung??? Diese dateien funktionieren aber nicht wirklich.

Soo, das wars erstmal, ich versuch echt mein Bestes aber ohne Hilfe komm ich nicht weiter

Tschü

Spooky

CO-Admin

  • »Spooky« ist der Autor dieses Themas

Beiträge: 355

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

97

Montag, 24. Oktober 2005, 17:29

@newbie_3_16

Dass Du ZDF u. ORF problemlos aufnehmen kannst sieht ja schon mal gut aus. Ob Deine Mountparameter auch korrekt umgesetzt wurden solltest Du mal mit dem Befehl "mount" auf der dbox per Telnet gegenprüfen. Nur wenn dort auch rsize=4096 steht kann es beim Abspielen funktionieren. Wenn Du höhere rsize Werte verwenden willst, ist mii-diag unbedingt von nöten. Allerdings bringt es nichts, wie Du es anscheinend gemacht hast, die NSLU2 auf 100MBit Full Duplex zu setzen. Je nach Anzahl der dboxen und Verwendungsgebiet solltest Du die Parameter verwenden wie am Anfang dieses Themas erwähnt.

Quellcode

1
2
3
#!/bin/sh
/share/hdd/data/dbox/mii-diag ixp0 -p 1 -F [color=red]10[/color]baseT-FD
/share/hdd/data/dbox/mii-diag ixp0 -p 1 -A [color=red]10[/color]baseT-FD


"chmod 755 /share/hdd/data/dbox/mii-diag" hast Du auch gemacht oder?

Ich bin mir jetzt nicht hundertprozentig sicher, aber mir war so, dass bei korrekter Installation die /etc/exports ein Symlink nach /opt/etc/exports sein sollte und damit der Inhalt identisch.... ??? Da muß ich nochmal nachschauen. Ging bei Dir beim "unsling" eventuell was schief?

Spooky

Newbie_3_16

Anfänger

Beiträge: 5

Firmwareversion / your current Firmware: Unslung 2.12

  • Nachricht senden

98

Dienstag, 25. Oktober 2005, 01:19

Hey Spooky,
so hab jetzt die einträge geändert auf 10base... und hab auch chmod 755 /share/hdd/data/dbox/mii-dia gemacht , mein Prob ist das ich jetzt immer noch nix Abspielen kann, genau der gleiche Fehler wie vorher. Es lädt erst 1 Minute und dann brichts wieder ab. *grummel*

Bei Aufnahmen gehts erst und dann kommt Konnte nicht schnell genug geschrieben werden. Hab jetzt mit 32768 gemountet und es geht trotzdem net.

DBOX Mount
/var # mount
/dev/root on / type squashfs (ro)
none on /dev type devfs (rw)
proc on /proc type proc (rw)
tmpfs on /tmp type ramfs (rw)
/dev/mtdblock/2 on /var type jffs2 (rw)
192.168.0.10:/share/hdd/data/dbox on /mnt type nfs (rw,v3,rsize=32768,wsize=3276
8,soft,udp,nolock,addr=192.168.0.10)
/var #

Schönen Abend (Nacht) noch.

Tschü

Spooky

CO-Admin

  • »Spooky« ist der Autor dieses Themas

Beiträge: 355

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

99

Donnerstag, 27. Oktober 2005, 12:18

@newbie_3_16

Wichtig ist jetzt erstmal eines, dass er bei Dir mit rsize=4096,wsize=32768 mountet und Dir das auch mit dem Befehl "mount" (wie oben) bestätigt. Falls dort trotzdem "rsize=32768" gemeldet wird, hast Du Dich entweder verschrieben bei den Zahlenwerten, oder in der Parameterzeile ein Leerzeichen stehengelassen.

Sobald Du soweit bist, melde Dich bitte hier nochmal.

Spooky

mitdabei

Anfänger

Beiträge: 12

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

100

Samstag, 29. Oktober 2005, 11:42

Hallo Leute!
Habe gerade mit dem Tool Ntest von den Keywelt Jungs mal mein Netztwerk zur NSLU2 ausprobiert.
Bei mir merke ich keine Änderung mit dem Tool Mi-diag.
habe 4096 und 32768 und komme auf 7,3 und 6.2 mbit
Bin nach der Anleitung hier vorgegangen.
Wenn ich das Ntest ausgeführt habe kommt am schluß die Anzeige
was wirklich gemountet wurde. Da wird aber nur 8192 8192 angezeigt
Was mache ich falsch?
Danke schon mal

Social Bookmarks