Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

nippes

Anfänger

  • »nippes« ist der Autor dieses Themas

Beiträge: 1

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

1

Sonntag, 21. Februar 2010, 13:20

apache module compilieren?

Hallo.

Ich benötige mod_proxy_html auf meiner nslu2. Also habe ich nach der Anleitung http://www.nslu2-linux.org/wiki/Optware/AddAPackageToOptware auf einen Debian System eine Cross-Compiler Umgebung aufgesetzt. make apache; make apache-stage lief durch. So weit so gut.

Jetzt habe ich den Source für mod_proxy_html nach /home/slug/optware/nslu2/builds/apache/modules/proxy ausgepackt und mit

Zitat

/home/slug/optware/nslu2/staging/opt/sbin/apxs -c -i -I/home/slug/optware/nslu2/staging/opt/include/libxml2 -I. mod_proxy_html.c
compiliert. Das funktioniert auch ohne Fehlermeldung.

Aber
  1. apxs versucht das Module nach /opt zu installieren. Richtig wäre /home/slug/optware/nslu2/staging/opt/libexec
  2. In mod_proxy_htmls.so wird auf /home/slug/optware/nslu2/staging/opt/include/libxml2/libxml referenziert. Richtig wäre /opt/include/libxml2/libxml. Auf der NSLU startet Apache mit dem Module nicht, weil dieser Pfad nicht stimmt.
Welche Einstellung hab ich übersehen? Hat schon mal jemand ein Apache module für die nslu2 gebaut?

Danke und Gruß.

Anzeigen

Social Bookmarks