Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

maverick_m4a1

Anfänger

  • »maverick_m4a1« ist der Autor dieses Themas

Beiträge: 15

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

1

Dienstag, 10. November 2009, 10:08

NSLU2 mit Debian bootet nicht mehr korrekt

Ich habe seit einiger Zeit eine NSLU2 mit Debian Lenny. Auf einem USB Stick ist Debian installiert und eine externe Festplatte ist am zweiten USB Anschluss angesteckt.
Samba ist einwandfrei gelaufen und seit gestern auch OpenVPN.
Nachdem ich sie ausgeschaltet habe und heute wieder anschalten wollte, startet sie nicht mehr korrekt.
Es leuchten nur noch die zwei Status LEDs für Disk 1 und 2.
Auch kann ich sie nicht mehr über den Power Button herunterfahren oder über Putty auf sie zugreifen.
Ich wäre dankbar für eure Tips!!
Grüße
Christian

Anzeigen

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

2

Dienstag, 10. November 2009, 11:26

Mach mal einen FileSystemCheck auf Deinen USB-Stick an einer anderen LINUX Kiste.
Also USB-Stick rein, fsck /dev/<sdx> (ohne mount!) und schauen ...

MfG
Werner

Anzeigen

3

Dienstag, 10. November 2009, 13:32

Ist die NSLU2 denn überhaupt noch von außen erreichbar, d.h. kommt ein Ping zurück?
Falls nicht, wird ein fsck m.E. kaum etwas nützen.
Vielleicht hilft dieser Thread weiter, die Ursache zu finden? Viel Erfolg!

Meine NSLU2 war nach einem Reboot gar nicht mehr "pingbar", so dass ich Debian komplett neu installieren musste.
Man sollte wohl dringend einen Blick in /etc/network/interfaces werfen.
Dort sollte die Zeile "auto lo eth0" enthalten sein:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo eth0
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
    	address 192.168.xxx.xxx
    	netmask 255.255.255.0
    	broadcast 192.168.xxx.255
    	network 192.168.xxx.0
    	gateway 192.168.xxx.xxx
    	# dns-* options are implemented by the resolvconf package, if installed

Die o.g. statischen IP-Adressen muss man natürlich auf seine NSLU2 abstimmen oder DHCP korrekt einrichten.

Ich meine, irgendwo mal gelesen zu haben (war es der o.g. Thread?), dass diese Zeile nach einer Neuinstallation evtl. fehlt und nach einem Reboot dazu führen kann, dass nichts mehr geht (d.h. kein Netzwerkzugriff).
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

maverick_m4a1

Anfänger

  • »maverick_m4a1« ist der Autor dieses Themas

Beiträge: 15

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

4

Dienstag, 10. November 2009, 17:28

die nslu2 ist nicht mehr pingbar.
Wenn ich fsck ausführe, dann sagt er mir fsck.ext2: Kein passendes Gerät bzw. keine passende Adresse gefunden beim Versuch, /dev/sda1 zu öffnen.
Wie hast du denn die NSLU2 dann neuinstalliert, als sie nicht mehr pingbar war?
Anhand dieser Anleitung habe ich noch folgendes Versucht:
mount /dev/sda1/mnt
mount: /dev/sda1 ist kein gültiges blockorientiertes Gerät
Wie könnte ich denn die NSLU neuinstallieren, wenn ich mit Putty nicht mehr zugreifen kann?

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

5

Dienstag, 10. November 2009, 17:34

Moin,

der Devicename hängt davon ab, welche Geräte Du bereits in Deinem System hast...

bye
JrB
"Supporting joe users worldwide" <- that's our motto


warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

6

Dienstag, 10. November 2009, 17:49

genau caplink811 spricht die Wahrheit!!

Ich schau immer mit <dmesg> welches neue Device dazugekommen ist, wenn ich den Stick rein stecke - es gibt aber sicher besseres....

MfG
Werner

maverick_m4a1

Anfänger

  • »maverick_m4a1« ist der Autor dieses Themas

Beiträge: 15

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

7

Dienstag, 10. November 2009, 18:14

Ich habe es auf meinem Windows Rechner mit Knoppix von cd gebootet probiert.
Er zeigt dabei meine beiden Festplatten Partitionen an hdc1 und hdc2.
Dann bin ich die die root shell gegangen habe versucht den angeschlossenen usb stick zu checken. (sda1 und sda5)
Dabei bekomme ich die oben bereits genannten Fehlermeldungen.
Meine Daten habe ich getrennt vom usb stick auf einer ext. festplatte, die ebenfalls an der nslu angeschlossen ist.
Wie kann ich denn debian auf dem usb stick neuinstallieren, wenn die nslu nicht pingbar ist?

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

8

Dienstag, 10. November 2009, 19:17

Moin,

schonmal ohne externe Datenträger gebootet?

bye
JrB

PS: wäre nicht ein fdisk -l /dev/sda angebracht, um mal zu klären, wie die Partitionen überhaupt benamt sind?
"Supporting joe users worldwide" <- that's our motto


9

Dienstag, 10. November 2009, 21:18

Hilft dieser Hinweis evtl. weiter?
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

maverick_m4a1

Anfänger

  • »maverick_m4a1« ist der Autor dieses Themas

Beiträge: 15

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

10

Mittwoch, 11. November 2009, 10:58

Hallo Zusammen,
jetzt habe ich herausgefunden woran es liegt. Nachdem ich die slug gestern neu geflasht habe und alles neu installiert habe, hat auch wieder alles wunderbar funktioniert. Als ich aber dann neben dem USB Stick auf dem Debian ausgelagert ist, meine externe Festplatte für dei Daten angeschlossen habe, ist das booten diesmal sofort wieder gescheitert und nicht erst nach dem ca. 30 mal als der Fehler bei mir zum ersten mal aufgetreten ist.

Unten seht ihr meine fstab, wie sie nach folgendem Tutorial aussehen sollte:
http://www.tecchannel.de/server/linux/17…lug/index4.html

Ich bräuchte noch etwas Hilfe wie ich das labeln in diesem Fall machen muss. Da blicke ich bei der Anleitung
http://www.nslu2-linux.org/wiki/HowTo/MountDisksByLabel
nicht ganz durch.

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/sda1 / ext3 errors=remount-ro 0 1
/dev/sda5 none swap sw 0 0
/dev/sdb1 /data ext3 defaults 0 2

/dev/sdb1 ist die externe Festplatte auf dem die Smaba shares liegen.
Danke für eure Hilfe!!!

11

Mittwoch, 11. November 2009, 19:37

Schau mal in diesem Thread nach. Da ist es genau beschrieben.
Und dort wird ein Hinweis gegeben, dass es evtl. Probleme mit "commit" in /etc/fstab gibt.
Gruß, ao

NSLU2 (Debian/NSLU2 (armel) 5.0.3 Stable Release, 263.78 BogoMIPS)
Apple MacBook C2D (OS X 10.5, Ubuntu 8.04, Windows XP)

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »ao« (12. November 2009, 09:14) aus folgendem Grund: Link korrigiert


Social Bookmarks