Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Montag, 3. August 2009, 17:17

Probleme nach Stromausfall; NSLU2 bootet nicht mehr

Hallo zusammen!

Folgendes Szenario:

  • NSLU2 mit Debian
  • 2 HDDs per USB angeschlossen

Wir hatten am Wochenende einen recht kurzen Stromausfall.
Dabei sind selbstverständlich auch die NSLU2 sowie die beiden HDDs ausgegangen.

Nachdem nun der Strom wieder da war hab ich die beiden HDDs eingeschaltet und anschließend die NSLU2. Nun fährt sie jedoch nicht mehr hoch.

Nach dem Einschalten passiert folgendes:

  • es braucht ein paar Sekunden bis der Bootvorgang startet (alle LEDs blinken hintereinander)
  • danach sind alle LEDs für 2-3 Sekunden konstant an
  • Status / Ready: orange (konstant) ... Ethernet: grün (konstant), Disk 1 und Disk 2 aus
  • HDD1 (hier liegt das OS, an Disk 1 angeschlossen) zeigt für ca. 10 Sekunden Aktivität

Danach passiert gar nichts mehr. Kann die NSLU2 nicht mehr erreichen; weder per SSH noch über Telnet. Habe die von mir vergebene IP-Adresse versucht, wie auch den Standard (192.168.1.77).

Welche Möglichkeiten habe ich die NSLU2 wieder zu reaktivieren, ohne einen Datenverlust auf den HDDs?
Möchte ungern alles neu installieren, da das ein Aufwand wäre, der sich über zwei Tage erstreckt :(.

--EDIT--

Habe gerade die Platte an eine funktionierende NSLU2 (gleiches OS, Debian) angeschlossen. Auch hier funktioniert der Bootvorgang nicht ...

Kann es vllt daran liegen, dass durch das nicht saubere Herunterfahren (Stromausfall) von der HDD nun nicht mehr gestartet werden kann?
Ich hab die Möglichkeit die Platte an einem Linux-PC anzuschließen und darauf zuzugreifen.
Falls ihr also einen Lösungsansatz habt, um die Platte wieder bootfähig zu machen (denke der Fehler geht in die Richtung), wäre es kein Problem von der HDD zu lesen bzw. darauf zu schreiben.


Vielen Dank schon mal für eure Mühe!
Kaimane

Anzeigen

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

2

Dienstag, 4. August 2009, 06:31

AW: Probleme nach Stromausfall; NSLU2 bootet nicht mehr

Hi,

steck den Memory Stick in einen funktionierenden Linux-Rechner. (Auch Deine 2te SLUG geht - nicht vom Stick booten, sondern im laufenden Betrieb einstecken) und mach ein Filesystem check <fsck> auf den "kaputten" Stick.

MfG
Werner

Anzeigen

3

Dienstag, 4. August 2009, 16:05

AW: Probleme nach Stromausfall; NSLU2 bootet nicht mehr

Hi Warti,

an der "defekten" NSLU2 (also die dem Stromausfall zum Opfer gefallen ist) hing kein Stick. Lediglich zwei HDDs, die im RAID1 laufen.
Ich werd' nun mal die HDD am Linux-Rechner einhängen und ein fsck durchführen. Mal schauen, was dabei rauskommt.

Vielen Dank!
Kaimane

4

Dienstag, 4. August 2009, 17:02

AW: Probleme nach Stromausfall; NSLU2 bootet nicht mehr

Der Lösungsansatz von Warti war genau der Richtige.
Bin wie folgt vorgegangen:

  • Platte am Linux-PC angeschlossen
  • per umount die HDD wieder ausgehängt
  • den Befehl e2fsck -fpC 0 /dev/XXX ausgeführt (wobei XXX bei mir für sdf1 und sdf3 steht)
  • HDD nach dem Vorgang abgestöpselt und an die NSLU2 angeschlossen

Nach ein bissl warten blinkte die Status / Ready LED wieder wie gewohnt 2x orange 1x grün. Per SSH versucht einzuloggen und hey, es hat geklappt!

Warti, vielen Dank für deine Hilfe!
Kaimane

Social Bookmarks